Installation von Batman 2013.4.0 aus den Paketquellen

In den meisten Anleitung zur Supernode Installation wird batman-adv-2013.4.0 selber gebaut, um Probleme beim Update zu verhindern verzichtet man dann teilweise auf automatische Sicherheitsupdates.

Die gezielte Verwendung eines alten Paketes und das manuelle pinnen der entsprechende Pakte vereinfacht die Sache erheblich:

apt-get install batctl=2013.4.0-1
echo "batctl hold" | dpkg --set-selections
echo "batman-adv-dkms hold" | dpkg --set-selections

Zudem sind nun unattended-upgrades unbendenklich.
Zumindest @thomasDOTwtf und @CHRlS hatten nach diesem mini Howto gefragt.

4 Likes

Top!
Genau DAS hab ich gesucht!

Damit das ganze klappt müssen natürlich auch die linux Headers installiert sein, derzeit z.B.

apt-get install linux-headers-3.13.0-53-generic

Ich schreibe das nur da ich heute ewig die Paravirtualisierung im Verdacht hatte, die Meldungen beim

apt-get install batctl=2013.4.0-1

aufmerksam lesen hilft auf alle Fälle weiter.