iPhone geht ungewollt ins "wifimesh"-WLAN

Hallo, ich beobachte seit einigen Monaten ein sehr merkwürdiges Verhalten. Mein iPhone 5 hängt, nicht immer, aber manchmal bei mir zu Hause im wifimesh-ddorf Wlan anstatt im Freifunk oder meinem privaten WLAN. Im Wifimesh bekommt es noch nicht mal eine sinnvolle IP, sondern nur 169.254…Nach manuellem Umschalten auf mein Wlan geht dann wieder alles.

Hat das jemand von euch schon mal erlebt?

danke
Carsten

Oh, ich fürchtete schon, es würde sich aufhängen, also im Sinne von „Freeze“.

Was Du dagegen tun kannst? Nicht alle offenen Wlans erlauben.

Einfach Dieses Netzwerk ignorieren drücken und gut isses.

Das netzwerk wird eigentlich nur ausgewählt wenn du es irgendwann mal ausgewählt hattest

1 Like

bewusst ausgewählt hab ich es natürlich nicht. aber ich hab jetzt mal ignorieren gesagt und beobachte das ganze :wink:
Danke!

1 Like

Vielleicht mal draufkommen ;).

Ich habe mit meinen Apple Geräten ein ähnliches Problem. Die weisen sich auch bei bekannten Netzwerken öfters mal eine selbst zugewiesene IPv4 zu und ignorieren den Lease. iPhone 5c, iPhone 6 und iPad Pro. Alle mit der neuesten Firmware zeigen das Verhalten. Bei Freifunk wie auch verschlüsselten WLAN.

Bei mir hilft dann einschalten des Flugmodus und dann wieder reaktivieren der Funkverbindungen. Ins Mesh verbinden die sich aber nie.

Passiert so zwei-dreimal am Tag und immer nur in Netzen, die IPv4 und IPv6 unterstützen. Vielleicht hat dein Fehlerbild etwas damit zu tun.

Gruß

Ulli

Ich hatte das gestern auch bei einem iPad in einem Nicht-Freifunk WLAN. Weil der betreffende Switch das Client-VLAN nicht drauf hatte, bekam das iPad keine IP-Adresse (DHCP/RA) und wies sich selber eine link-local IPv4-Adresse zu (APIPA).

Das Problem ist dabei, dass diese Adresse nach Spezifikation die einzige IPv4-Adresse auf dem Interface bleibt und das iPad nicht erneut per DHCP eine für Internet-Verbindungen nutzbare Adresse abruft. Daher muss dann die Verbindung manuell getrennt und neu aufgebaut werden. Erst dann geht eine DHCP-Anfrage hinaus.

Hat jemand eine Ahnung, ob sich das auch ohne Eingreifen irgendwann von alleine behebt?

Beim Mesh-WLAN gibt es natürlich keinen DHCP-Server. Dieses muss man schlicht aus der Liste der bekannten Netzwerke streichen. Bei Apple ist das sowohl unter iOS wie unter Mac OS nicht ganz offensichtlich. Daher bekomme ich häufig Anfragen von Nutzern, deren Geräte sich immer wieder ungewollt in irgendwelchen Netze anmelden.

Hallo.

Meinem Sohn ist das mit dem Verbinden ins Mesh mit seinem iPhone auch regelmäßig passiert: „Freifunk ist doof, das funktioniert ja gar nicht“.
Ob es nicht Sinn machen würde, das Mesh mit einer ganz schwachen Verschlüsselung (wep?) zu versehen?

Gruß Christian

Oder schlicht ein Name für das Meshnetz der völlig kryptisch historischen und nicht nach FF ausschaut.

4 Likes

Apple ist doof, wenn die sowas programmieren. Soll er sich halt mal ein Android-Gerät kaufen ;).

4 Likes

Danke für die überaus konstruktive Antwort. Statt zu trollen suche ich lieber nach einer Lösung des Problems.

Das Problem scheint recht weit verbreitet zu sein: auf einem Knoten in der Innenstadt sehe ich im Augenblick mit iwinfo ibss0 assoclist, dass sich dort 4 Geräte mit dem Mesh verbunden haben, die dort nichts zu suchen haben (bei 6 normalen Clients). Vielleicht ist es Zufall, aber das ist auch einer der Knoten, auf denen der Wlan-Bug am häufigsten zuschlägt.

Früher ™ haben sich alle Endgeräte (zb iPhones) ins ad-hoc Netz eingewählt. Es gab nur das eine WLAN-Netz je Gerät, oft mit DHCP-Server, damit es auch mit der IP klappt. Der „Fehler“ liegt hier leider bei Google/android, denn die meisten Geräte unterstützen kein ad-hoc-mode. Somit musste dann vAPs verwendet werden und der ad-hoc Mode wurde für Endgeräte vernachlässigt. Link zum Bug:

https://code.google.com/p/android/issues/detail?id=82

Eine Variante wäre also, wieder DHCP-Server auf allen Freifunk-Knoten zu aktivieren (mit Meshkit-Firmware geht das unter „WLAN → DHCP aktivieren“). Dann roamt das aber nicht optimal.

WEP-Verschlüsselung wäre auch eine Variante. Da könnte man nochmal die Weimarer Freifunker fragen, die hatten diese Option vor vielen Jahren mal (und auch wieder verworfen). Wahrscheinlich könnte man auch 11s anstelle ad-hoc ausprobieren!

Kryptische WLAN-Namen machen keinen Sinn, wenn sich die Endgeräte automatisch verbinden.
Der Hinweis auf den WLAN-Bug ist auch interessant, falls es sich um DEN WLAN-bug handelt :-o Sind da wirklich iphones? Ich hatte eher vermutet, dass das irgendwelche Windows-Smartphones wären, die diese Probleme auslösen-.

finden sich die Knoten immernoch wenn man den broadcast vom wifimesh wlan ausschaltet? oder schauen die Knoten explizit nach der „wifimesh“ SSID um zu meshen?

Leider lässt sich der Broadcast seit einigen Versionen nicht mehr abschalten. Wir wechseln aber bald auf 802.11s beim Mesh Interface, dann sollte das Problem nicht mehr auftreten.