Kann die Geodaten nicht aktivieren

ich kann die Geodaten via ssh nicht aktivieren
ich gebe die folgenden Befehle ein:

uci set gluon-node-info.@location[0]=’location’ dieses wird akzeptiert
uci set gluon-node-info.@location[0].share_location=’1′
hier kommt die meldung Invalid Argument

uci set gluon-node-info.@location[0].latitude=‘52.924709560660986′
hier kommt die meldung Invalid Argument

uci set gluon-node-info.@location[0].longitude=’ 10.764541625976562′
hier kommt die meldung Invalid Argument

uci commit

kann es auch nicht im config modus aktivieren bekomme dort auch eine fehler meldung

versuch es mal nur mit 4 oder 5 Stellen nach dem .

ändert sich leider nichts sobald ich
uci set gluon-node-info.@location[0].share_location=‚1‘

kommt die Fehlermeldung Invalid Argument

Laß mal die Anführungszeichen weg!

1 Like

das problem fängt schon in der zweiten zeile an
uci set gluon-node-info.@location[0].share_location=‚1‘

dort bekomme ich schon eine fehler meldung Invalid Argument
auch wenn ich die anführungszeichen weg lasse

Ich vermute, dass es schlicht die falschen Anführungszeichen sind.
Und ja, je nachdem was da das Cut&Paste macht können die durchaus absurd gewandelt werden.
Am besten manuell neu tippen nach vorlage von dem was da derzeit schon drinsteht und genau hinschauen, dass die ’ im Terminalfenster identisch ausschauen wie die vorhandenen im alten Eintrag.

Die Anführungszeichen sind an der Stelle schlicht nicht erforderlich!

1 Like

http://wiki.freifunk.net/konsole

neulich noch Geodaten aktualisiert.

es ändert sich leider nichts

Klingt für mich jetzt nach einem Fall für einen Sysupgrade mit „Alle Daten zurücksetzen“.

Habe eben
uci show eingegeben

uhttpd.px5g.country=DE
uhttpd.px5g.state=Berlin
uhttpd.px5g.location=Berlin

was mich wundert ist das berlin
sollte dort nicht uelzen stehen
habe mich über uelzen.freifunk.net angemeldet

hmm, so weit sind wir noch nicht. Da bräuchte es dann wohl die Wiedereinführung der Kleinstaaterei.
(Wie würde das Land denn heißen? Aber immerhin könnte man dann auch gleich noch eine lokale Zeitzone definieren.)

hat also damit nichts zutun

also den router neustarten und alle daten löschen
kann ich denn den namen behalten und sollte ich freifunk.uelzen .net vorher bescheid sagen ?

Für mich klingt das eher nach Layer 8-Error.
Ich glaube nicht, daß eine Neuinstallation da hilft.

Dafür reicht in der Shell ein beherztes „firstboot“ :wink:

1 Like

Evtl. könntest du in den Cinfigmodus booten und in dem Interface (Webbrowser) die Daten eingeben. Vielleicht hilft das…

Hallo

ich möchte ich erst einmal für reichliche unterstützung bedanken

ich hatte mich an mein Technik Team von Freifunk Uelzen gewannt dort wurde mir der richtige Pfard mitgeteilt

es ist : /etc/config/gluon-node-info

Kann ich so bestätigen, hatte den selben Brainlock-Bug :slight_smile: