Kann man die 4 LAN Anschlüsse frei konfigurieren?


#1

Hallo,
ich habe ein Kabel vom DSL-Router(Fritzbox) in den WAN-Port des TP-Link WDR4300(Freifunk) gesteckt.
Alles funktioniert.
Ich brauche aber dort wo der TP-Link WDR4300 steht nochmal Internet-Zugriff via Kabel.

Könnte man einen der 4 LAN Ports des TP-Link so konfigurieren, das er das “Heimnetz” zur Verfügung stellt?

Ich möchte also einen LAN-Port auch für das interne Netz zu nutzen. Kann man die auch auf den WAN-Port bridgen?

FF-Wuppertal: TP-Link TL-WDR4300 v1 : wup-20160826 / gluon-v2016.1-248-ge5acba5


#2

Ja aber nicht per Webinterface. Du musst auf die console und ein paar Dinge anpassen. Alles aber nicht Update fest.


#3

Console ist kein Problem. Aber was muss ich wie einstellen? per UCI ?

Update fest braucht es auch nicht zu sein.
Die Firmware ändert sich offensichtlich nicht so oft. :slight_smile:


#4

Das geht per UCI, die genaue Konfiguration ist von Gerät zu Gerät unterschiedlich. Das hängt davon ab, wie das Netzwerk im Router selbst aufgebaut ist.

Für den WDR4300 gibt es hier eine Anleitung:
https://wiki.openwrt.org/toh/tp-link/tl-wdr4300

Siehe Punkt “Every port a vlan”
Die Konfiguration kann man entweder direkt in /etc/config/network eintragen, wie im Beispiel dargestellt, oder man mach das via UCI, wie z. B. hier am Beispiel eine EdgeRouter X:


#5

Das solltest Du mit Deiner Community absprechen.
Also den Autoupdater abschalten solltest Du nicht, damit bleibst Du sonst “auf der Strecke”, wenn man (z.B. wegen entdeckter Linux-Sicherheitslücken) rasch Firmwareupdates ausgerollt werden.
(oder Du steckst das Ding z.B. immer aus bevor Du länger länger als nur 2-3 Tage wegfährst, z.B. in den Urlaub.)


#6

Der Update kann gerne alles überschreiben. Ein paar Zeilen tippe ich gerne wieder ein. :slight_smile:
Ist nur der Fernseher, der in der gleich Ecke steht. Also nicht ganz so wichtig für mich. Streame nur gelegentlich etwas vom NAS , aber kein Netflix.


#7

Das hatte in einem anderen Thread schon mal jemand beschrieben:
https://forum.freifunk.net/t/lan-ports-als-switch-fuer-lokales-netz/12317/14

Mesh auf dem LAN-Port deaktivieren (per Web-Oberfläche)

In /etc/config/network via WinScp oder putty folgendes ändern:
ALT
config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0t 2 3 4 5’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘0t 1’

NEU
config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0t 4 5’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘0t 1 2 3’


#8

So gings mir. Nachdem das Update durchgeführt wurde, war alles auf Werkseinstellung mit der Konfiguration der Lan-Ports… Jetzt bin ich schlauer :wink: