[kbu] TP Link CPE210 einrichten

Vorab, wenn es nicht in der richtigen Kategorie ist, bitte moven…

Ich hab schon Vorerfahrung mit dem Einrichten von den Routern (WR841N). Hab mir aber mal nen CPE210 für Outdoor zugelegt. Firmware drauf geflasht, eingerichtet, etc etc. soweit alles problemlos, ABER! der CPE hat keinen WAN Port, also nur LAN0 (PoE) und LAN1. LAN0 is logischerweise am Strom, LAN1 am LAN Port an meinem privaten Router. Folgende Probleme hier aber:

  1. Man kann durch kbu.freifunk.net auf meine Speedport-Einstellungen zugreifen. Sollte natürlich nicht passieren, wird wohl auch dran liegen, das es am LAN Port vom Speedport ist.

  2. hab ich mich eben in den IRC Chat von KBU verbunden, aber immernoch mit der selben Maske, wie wenn ich mit dem Speedport verbunden wär i.e. (@********.d***.t-ipconnect.de).

  3. Irgendwie kann ich mich nur mit meinem Laptop verbinden. Bei Android wird die ganze Zeit versucht, sich zu verbinden, bis dann die „IP Adresse konnte nicht abgerufen werden“- Nachricht kommt.

  4. WTF? Es sind unmöglich so viele Clients verbunden!

Hab als Workaround was probiert. Und zwar LAN1 vom CPE210 mit irgendeinem LAN Port von nem schon eingerichteten WR841N Router eingesteckt, und von da per WAN an irgendeinen Port vom… Speedport. Leider hat dies das Problem nicht gelöst, es ist immernoch das selbe…

Hoffe jemand kann mir da etwas helfen.

Cheers!

Hi,

der LAN-Port am PoE-Injektor ist der WAN-Port (blau am 841er). Der zweite Port am Gerät ist der LAN-Port (gelb am 841er).

Zumindest unter Gluon funktioniert das. Ich weiß gerade nicht, ob KBU Gluon nutzt.

Viele Grüße
Matthias

Ich weiß ich weiß…

aber wie ist das beim CPE210? Da ist nur LAN0 (PPoE In) und LAN1 (Normal LAN), nix mit WAN… Wenn ich LAN1 an meinen privaten Router an ein LAN Port anschließe, und mich mit dem CPE210 verbinde, ist es quasi wie wenn ich mit meinem privaten Router verbunden bin (vermute ich mal, da ich auf die Einstellungen dadrauf zugreifen kann, was ich beim 841er nicht konnte, da dieser ja per WAN Port an einen LAN Port vom privaten angeschlossen war und somit alles reibungslos lief).

Deshalb hatte ich versucht, den CPE210er an einen der LAN Ports vom 841er anzuschließen, und vom 841er’ WAN Port dann an ein LAN Port am privaten Router.

FW vom CPE210 ist 2016.2-exp20170417 / gluon-v2016.2.5-1-g03fc7b8 btw, also ja, gluon.

Hab grad mal versucht, Freifunk nur mit dem stinknormalen 841er zu machen, funktioniert problemlos und jedes Gerät kann sich mit verbinden, aber bei der CPE210 nicht, also scheint das Problem an dem Teil zu liegen.

Cheers

Am PoE-Injektor LAN0 = WAN also am PoE-Injektor sitzt dann deine WAN Buchse

Oh… aber wie soll der CPE210 dann mit Strom versorgt werden? Von LAN1 bezieht der ja nix, weil kein PoE…

Am Injektor selbst gibt es doch zwei Buchsen, IN und OUT
Dein WAN in die Buchse am Injektor und vom Injektor zum CPE an LAN0
Injektor als Beispiel http://www.tp-link.de/products/details/cat-43_TL-POE150S.html

1 Like

Am Injektor selbst ist nur, genauso wie oben auf dem Dach eine PoE und eine LAN Buchse.

LAN0 (PoE/Strom) - NICHT am Injektor, sondern direkt vom CPE210 selbst- geht per Kabel runter in den PoE Port am Injektor und von da ans Strom.
LAN1 (auch NICHT am Injektor, sondern wieder vom CPE210 selbst) geht ebenfalls mitm Kabel runter, aber nicht in den Injektor, sondern theoretisch in eine LAN Buchse an meinen privaten Router (irgendwo muss ja auch das Internet herkommen…).

Internet kommt durch, ja, aber anscheinend wird es nicht getunnelt, Android kann keine IP vom CPE210 beziehen und ich komme vom CPE210 in meine privaten Routereinstellungen…

Hoffe ich habs gut genug erklärt… :confused:

Für mich klingt die Eingangs-Schilderung so, als ob jemand Client-Netz auf LAN zu liegen hätte (also LAN1), dann auf LAN0 VPN-WAN aktiviert und zusätzlich noch beide Ports (LAN1 und LAN1) irgendwie gebridged worden wären.
Ja, gibt noch ein paar andere Szenarien, wie man Client-Netz am WAN-Port herausbekommt.
In Kombination mit „eingespartem RogueNet-Ebtables“ gibt das dann die Effekte, die früher in vielen Communites im Wochenabstand an der Tagesordnung waren: Leute, die ihre Router „falsch herum“ anschliessen und sich dann (mindestens) wundern.

Ich würde vorschlagen, das Image nochmal „ohne Parameter behalten“ neu zu flashen und MoW und MoL abzuschalten, nur MeshVPN anschalten.

Ich hatte es ja eigentlich geflasht, während MoW und MoL aus und MeshVPN an war. Kanns ja nochmal machen, just in case.

(Btw, muss ich PoE-Passthrough aktivieren vielleicht?)

Nope, immernoch das selbe Problem… Ich hab das unten mal was mit meinen Mad-Paint-Skills verbildlicht, so wie ichs jetzt grad hab…

EDIT: Wenn ich mit dem CPE210, also kbu.freifunk.net verbunden bin und auf wieistmeineip.de gehe, wird immernoch mein Provider und die IP wie wenn ich mitm Privatrouter verbunden bin, statt wie normal das CCC. Knoten wird auf der Map auch als Offline angezeigt.

EDIT2: Aus ner Seite entnommen: „=> Nach dem update ist der CPE210/CPE510 nicht über LAN1 sondern die POE WAN Schnittstelle erreichbar!“

Aber hää? Der CPE210 kriegt bei POE am Injektor doch Strom…

wie oben Beschrieben ist LAN0 das WAN.
Dann kann das (so) auch nix werden.

Verstehe… aber wie bekommt der CPE210 sonst Strom? Bzw. wie müsste ich das dann jetzt verkabeln, wenn man oben die Skizze nehmen würde?

da wo Laptop steht, muss die Fritzbox hin

Laptop an den Speedport anschließen und die CPE über LAN0 (PoE) an den Speedport.

CPE ---- PoE ---- Speedport ---- Laptop

Danke, es läuft! <3 Also war das Kabel am LAN1 Port von CPE210 total unnötig. Naja, live and learn. Danke nochmals! :smile:

2 Likes

Genau ;). Wir wir alle versucht haben zu erklären, glaub du hattest da einen kleinen Knoten im Kopf :P. Freut mich, dass es jetzt klappt.

Den LAN-Port an der CPE kann man verwenden, um dort eine weitere CPE anzuschließen. Kann ganz praktisch sein, wenn man in zwei Richtungen funken will, aber nur ein Kabel zum Dach hat.

Grüße
Matthias