Kein Internet - Keine IPv4 Adresszuweisung intern - WLAN verbunden, auch kein Internet - Wenn Communty Registrierung benötigt, man dieses aber nicht tut


#21

in der Tat.
Geht DNS denn für andere Geräte im selben Netzwerk?
Was steht in folgender Datei:
/tmp/gluon/wan-dnsmasq/resolv.conf
Dort wird der DNS-Server automatisch eingetragen, der per DHCP ermittelt wurde.

Ein statischer DNS-Server kann auch konfiguriert werden, suche nach " gluon-wan-dnsmasq " auf dieser Seite: Commandline administration · freifunk-gluon/gluon Wiki · GitHub


#22

Hallo rotanid,
da kein DHCP vorherrscht, habe ich den DNS manuell eingetragen wie oben beschrieben, also vor den ganzen Posts…

root@DELUH01-FFRN001:~# cat /tmp/gluon/wan-dnsmasq/resolv.conf
nameserver 194.025.000.068

Das ist ein DNS Server der Telekom AG. Ja, alle anderen im Netz können diesen DNS fehlerfrei nutzen.

sfrank@fleknoil:~> dig @194.25.0.68 web.de

; <<>> DiG 9.9.9-P1 <<>> @194.25.0.68 web.de
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18605
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;web.de. IN A

;; ANSWER SECTION:
web.de. 20 IN A 82.165.229.138
_web.de. 20 IN A 82.165.230.17_sfrank@fleknoil:~> dig @194.25.0.68 web.de

; <<>> DiG 9.9.9-P1 <<>> @194.25.0.68 web.de
; (1 server found)sfrank@fleknoil:~> dig @194.25.0.68 web.de

; <<>> DiG 9.9.9-P1 <<>> @194.25.0.68 web.de
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18605
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;web.de. IN A

;; ANSWER SECTION:
web.de. 20 IN A 82.165.229.138
web.de. 20 IN A 82.165.230.17

;; Query time: 12 msec
;; SERVER: 194.25.0.68#53(194.25.0.68)
;; WHEN: Fri Sep 21 17:23:30 CEST 2018
;; MSG SIZE rcvd: 67
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18605
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;web.de. IN A

;; ANSWER SECTION:
web.de. 20 IN A 82.165.229.138
web.de. 20 IN A 82.165.230.17

;; Query time: 12 msec
;; SERVER: 194.25.0.68#53(194.25.0.68)
;; WHEN: Fri Sep 21 17:23:30 CEST 2018
;; MSG SIZE rcvd: 67

;; Query time: 12 msec
;; SERVER: 194.25.0.68#53(194.25.0.68)
;; WHEN: Fri Sep 21 17:23:30 CEST 2018
;; MSG SIZE rcvd: 67

Ich habe dazu diesen Befehl benutzt:
uci add_list gluon-wan-dnsmasq.@static[0].server=XXX.XXX.XXX.XXX

(und habe die Zahlen immer dreistellig wie hier zu sehen angegeben.)

Gruß
ruebenmaster


#23

Hallo rotanid,
ich habe diese Einträge mal geändert. Nun sieht das so aus:

root@DELUH01-FFRN001:~# cat /tmp/gluon/wan-dnsmasq/resolv.conf
nameserver 194.25.0.68
nameserver 194.25.0.60
root@DELUH01-FFRN001:~#

Beide Server sind erreichbar und lösen auf…

sfrank@fleknoil:~> dig @194.25.0.68 heise.de

; <<>> DiG 9.9.9-P1 <<>> @194.25.0.68 heise.de
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6781
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;heise.de. IN A

;; ANSWER SECTION:
heise.de. 66099 IN A 193.99.144.80

;; Query time: 10 msec
;; SERVER: 194.25.0.68#53(194.25.0.68)
;; WHEN: Fri Sep 21 17:33:32 CEST 2018
;; MSG SIZE rcvd: 53

sfrank@fleknoil:~> dig @194.25.0.60 heise.de

; <<>> DiG 9.9.9-P1 <<>> @194.25.0.60 heise.de
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2275
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;heise.de. IN A

;; ANSWER SECTION:
heise.de. 55583 IN A 193.99.144.80

;; Query time: 14 msec
;; SERVER: 194.25.0.60#53(194.25.0.60)
;; WHEN: Fri Sep 21 17:33:39 CEST 2018
;; MSG SIZE rcvd: 53

sfrank@fleknoil:~>

Der Freifunkrouter missachtet restriktiv diese DNS Einträge in der resolv.conf… Gibt man den DNS Server mit, dann klappt das.

root@DELUH01-FFRN001:~# nslookup heise.de
;; connection timed out; no servers could be reached

root@DELUH01-FFRN001:~# nslookup heise.de 194.25.0.68
Server: 194.25.0.68
Address: 194.25.0.68#53

Name: heise.de
Address 1: 193.99.144.80
Address 2: 2a02:2e0:3fe:1001:302::
root@DELUH01-FFRN001:~#

Wieso liest er nicht in der resolv.conf, welchen Server er benutzen soll??? Das ist echt verwirrend, da bei mir jeder Linux Server in seine resolv.conf schaut.

Gruß
ruebenmaster


#24

es gibt zwei resolv.conf.
hast du die oben genannte manuell editiert? hast du den dnsmasq oder den ganzen router nach der änderung neugestart? sonst hat er im RAM ja noch nicht die Änderung - vermute ich
die “führenden nullen” sind glaube ich falsch.


#25

(gelöscht)


#26

Weil da zwar ein Linux-Kernel läuft, OpenWRT aber schon ein sehr besonderer “Linux-Server”, und darauf aufsetzend, Gluon ein spezielles OpenWRT einzig für den Freifunk-Einsatz, ist. Vgl. https://gluon.readthedocs.io/en/v2016.1/dev/wan.html

Bitte geh’ in den Config-Mode und gib’ alle relevanten Daten über die Weboberfläche ein (wenn Du kein DHCP benutzt, solltest Du wissen, welche Daten ein System benötigt, um funktionieren zu können). Und zwar im richtigen Format, d. h. ohne führende Null, das ist generell ein Fehler bei IPv4:

  OS: 18.06-SNAPSHOT, r7204+7-8be3af9     FW: 1.1.0~16                        
  HW: QEMU Standard PC (i440FX + PIIX, 1996)                              
root@33332-FW-Test-S107-1d28:~# ping 194.25.0.68
PING 194.25.0.68 (194.25.0.68): 56 data bytes
64 bytes from 194.25.0.68: seq=0 ttl=56 time=27.808 ms
64 bytes from 194.25.0.68: seq=1 ttl=56 time=14.847 ms
^C
--- 194.25.0.68 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 14.847/21.327/27.808 ms
root@33332-FW-Test-S107-1d28:~# ping 194.025.000.068
ping: bad address '194.025.000.068'
root@33332-FW-Test-S107-1d28:~#

#27

Hallo wusel,
keine Chance. Ich habe die Weboberfläche gestartet und die erforderlichen Daten eingegeben. Keine Veränderung der Lage.
Zum Vergleich habe ich den Freifunk Router an der WAN Schnittstelle mit DHCP eingerichtet, ebenfalls kein Connect ins Internet.

Ich bin der Überzeugung, dass diese TP-Link Router in der Version 5 nicht funktionieren. Es hat auch keiner geschrieben, dass er diese Kombination erfolgreich im Netz hat.

Ich werde die Freifunker Rhein-Neckar darauf hinweisen, dass diese Hardware nicht geht und dass sie die angebotene Software aus der Liste nimmt. Sonst fallen noch mehr darauf ein. ;o)

Wir werden wohl zu einem Anbieter wechseln, vielleicht Telekom AG oder so.

Vielen lieben Dank an alle für Eure Hilfe.

Gruß
ruebenmaster


#28

ist da vielleicht irgendeine Art von Firewall oder Gast-Modus aktiv an deinem Internet-Router?

doch, die funktionieren, wir haben mehrere davon bei uns schon im Netz.


#29

Hallo rotanid,
der Router war mit der festen IP Adresse direkt im Internet, ohne eine Firewall oder Router mit ACLs oder so was… Auch beim DHCP Versuch habe ich einen Router ohne Regelwerk dazwischen, geht auch nicht. Ich sehe dort nur die UDP 53 Pakete, die der Router ins Internet schiesst. Er bekommt aber keine Antwortpakete!

Gruß

ruebenmaster


#30

Aber dass keine Antwort kommt vom DNS-Server ist doch nicht der Fehler des Freifunk/Gluon-Routers?
Vermutlich hast du schon unterschiedliche DNS-Server ausprobiert? Sowohl den deines ISPs als auch generische wie 1.1.1.1 ?


#31

Hallo rotanid,

es sind nicht die von mir eingetragenen Server, die nicht antworten.

Gruß

ruebenmaster


#32

huch?
kannst du mal mit “grep -r IPADDRESSE /” suchen, wo die IP-Adressen stehen, die du eingetragen hast - und wo die stehen, die tatsächlich genutzt werden?


#33

Es ist definitiv irgendein Uplink-Foo.
An der Hardware oder dem Gluon liegt es mit an Sicherheit grenzender Wahrscheinlichkeit nicht.

Dir ist klar, dass ein Gluon auf dem WAN-Interface mit mehr als einer MAC-Adresse sichtbar ist (und diese auch während des Gerätestarts ändert)?


#34

hallo adorfer,
das mit den MAC Adressen wusste ich nicht.

Ich habe nun drei Geräte ausprobiert. Alle drei direkt am Internet mit fester IP oder hinter einem Router (MikroTik, Cisco) , sowohl mit fester IP als auch mit DHCP auf der WAN Seite.

Alle drei funktionieren nicht… Das ist echt kurios. Und es gibt wirklich welche die funktionieren?

Was meinst du mit Uplink-Foo? Bestimmt die WAN Seite des Routers, oder?

Wenn ich manuell beispielsweise einen Ping nach 8.8.8.8 eingebe, dann funktioneirt das. Somit ist erstmal Layer 1,2 und 3 erfolgreich bedient. Warum der Router dann das VPN zu einem der Freifunk Server nicht aufbaut ist mir ein Rätsel… Hänge ich zum Testen einen Raspberry ins gleiche Netz an die gleichen Komponenten, dann kommt dieser auch zu den gw Adressen der Freifunk Server…

Heute Abend hänge ich nochmal einen hinter den Router und schneide den ausgehenden Netzwerkverkehr mit, eventuell können wir hier damit was anfangen.
Gruß
ruebenmaster


#35

Es gibt menschen die behaupten, Openwrt würde kein “waschechtes” DHCP machen auf dem WAN-Port, sondern eher Bootp. Was das bedeutet: Keine Ahnung, aber ein $ADMIN einer Institution gab mir das als Erklärung, warum das mit dem DNS daher angeblich schief laufe an seiner $$$-Hardware mit Portsecurity&al…


#36

ja, also wenn ping zu einer IPv4-Adresse geht, dann scheitert es wohl wirklich “nur” am DNS-Server oder dem DNS-Server Eintrag…
@adorfer soweit ich das sehe hat er die DNS-Server auch schon statisch hinterlegt und es ging dennoch nicht…


#37

Das ist … ungewöhnlich.

Und das klingt irgendwie nach versteckter Kamera. Ich hätte gerne die Ausgaben von ein paar Kommandos, denn ich verstehe grade nicht, was bei Dir Sache ist :wink:

root@33332-FW-Test-S107-1d28:~# ip route show
default via 192.168.175.1 dev br-wan  src 192.168.175.12 
10.255.0.0/20 dev local-node scope link  src 10.255.0.1 
192.168.175.0/24 dev br-wan scope link  src 192.168.175.12 

root@33332-FW-Test-S107-1d28:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-client               7fff.525400251d28       no              eth0
                                                        local-port
                                                        bat0
br-wan          7fff.eabfaa104530       no              eth1

root@33332-FW-Test-S107-1d28:~# batctl gwl
      Gateway      (#/255)           Nexthop [outgoingIF]: gw_class ... [B.A.T.M.A.N. adv 2013.4.0, MainIF/MAC: primary0/ea:bf:aa:10:45:33 (bat0)]
   de:ad:be:ef:02:1c (198) de:ad:be:ef:02:1a [  mesh-vpn]: 215 - 96MBit/96MBit
=> de:ad:be:ef:02:11 (225) de:ad:be:ef:02:1a [  mesh-vpn]: 215 - 96MBit/96MBit

root@33332-FW-Test-S107-1d28:~# ps w | grep dnsm
 1917 dnsmasq   7196 S    /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf.cfg01411c -k -x /var/run/dnsmasq/dnsmasq.cfg01411c.pid
 2612 root      9252 S    /usr/sbin/dnsmasq -x /var/run/gluon-wan-dnsmasq.pid -u root -i lo -p 54 -h -r /var/gluon/wan-dnsmasq/reso
14655 root      3084 R    grep dnsm

root@33332-FW-Test-S107-1d28:~# cat  /var/gluon/wan-dnsmasq/resolv.conf 
nameserver fd00::e228:6dff:fe54:84e9
nameserver 192.168.175.2
nameserver 192.168.175.1
nameserver 8.8.8.8

root@33332-FW-Test-S107-1d28:~# batctl if
primary0: active
mesh-vpn: active

root@33332-FW-Test-S107-1d28:~# ping6 -c 3 google.com
PING google.com (2a00:1450:4001:816::200e): 56 data bytes
64 bytes from 2a00:1450:4001:816::200e: seq=0 ttl=55 time=44.393 ms
64 bytes from 2a00:1450:4001:816::200e: seq=1 ttl=55 time=42.996 ms
64 bytes from 2a00:1450:4001:816::200e: seq=2 ttl=55 time=41.770 ms

--- google.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 41.770/43.053/44.393 ms

root@33332-FW-Test-S107-1d28:~# ping6 -c 3 2001:4860:4860::8888
PING 2001:4860:4860::8888 (2001:4860:4860::8888): 56 data bytes
64 bytes from 2001:4860:4860::8888: seq=0 ttl=58 time=45.544 ms
64 bytes from 2001:4860:4860::8888: seq=1 ttl=58 time=42.900 ms
64 bytes from 2001:4860:4860::8888: seq=2 ttl=58 time=42.618 ms

--- 2001:4860:4860::8888 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss

root@33332-FW-Test-S107-1d28:~# ping6 -c 3 2606:4700:4700::1111
PING 2606:4700:4700::1111 (2606:4700:4700::1111): 56 data bytes
64 bytes from 2606:4700:4700::1111: seq=0 ttl=58 time=42.761 ms
64 bytes from 2606:4700:4700::1111: seq=1 ttl=58 time=45.984 ms
64 bytes from 2606:4700:4700::1111: seq=2 ttl=58 time=43.998 ms

--- 2606:4700:4700::1111 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 42.761/44.247/45.984 ms

root@33332-FW-Test-S107-1d28:~# ping6 -c 3 one.one.one.one
PING one.one.one.one (2606:4700:4700::1111): 56 data bytes
64 bytes from 2606:4700:4700::1111: seq=0 ttl=58 time=46.123 ms
64 bytes from 2606:4700:4700::1111: seq=1 ttl=58 time=45.198 ms
64 bytes from 2606:4700:4700::1111: seq=2 ttl=58 time=43.594 ms

--- one.one.one.one ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 43.594/44.971/46.123 ms

Hmm. Wenn’s dafür 'n Gluon-Build einer Community gibt, dann sollte der prinzipiell schon tun …

Kannst Du bitte auch Dein Setup nochmal kurz skizzieren? Denn …

… klingt komisch. Der TP-Link hat auf WAN-Seite (blauer Port) eine feste öffentliche IPv4-Adresse? Und an seinem LAN-Port hängt Dein interner Router? Woran hängt denn dann der WAN-Port des TP-Links?


#38

Hallo wusel,
ich muss warten bis mein Kollege den Router wieder in die Steckdose steckt, sonst hätte ich das Ding bereits zertrümmert. Sobald er das getan hat, kann ich Deine Prüfungen ausführen.

Ich verstehe Deine letzte Frage nicht, da Du sie schon selbst beantwortest Hast. Der WAN Port (blau) steckt direkt im Internet mit fester IP Adresse. Oder gibt es da mehrere WAN Ports?

Ja der Router der dahinter hängt ist ein CAPsMAN von MikroTik. Dieser Wiederum verteilt das Netz an viele Accesspoints… Der MikroTik Router kann den LAN Port des TP-Link, in meinem Falle 10.142.255.1 anpingen.

Gruß
ruebenmaster


#39

Merci.

Hmm. Bei mir kommt zwar Strom aus der Steckdose, aber kein “Internet” (selbst über einen Adapter zwar IP, aber das ist ein LAN hinter meinen WAN-Routern, überwiegend mit privaten Adressen). Kurz: ich möchte wissen, was grob zwischen dem DE-CIX in Frankfurt und Deinem blauen WAN-Port des Freifunk-TP-Links an Technik liegt. (Gut, ganz konkret eigentlich nur, was zwischen dem blauen Port und dem Zugangsnetz Deines Internetanbieters ggf. Ports blockieren könnte.)

Und zwei weitere Kommandos, von denen ich gerne die Ausgabe hätte:

root@33332-FW-Test-S107-1d28:~# /sbin/start-stop-daemon -c root:gluon-mesh-vpn -S -x /usr/bin/nslookup -- gw02.ffrn.de

root@33332-FW-Test-S107-1d28:~# iptables -L -t nat | grep DNAT

Das obere sieht komisch aus, hat mit der Ausgabe des unteren zu tun (Gluon lenkt DNS-Anfragen von Prozessen der Gruppe gluon-mesh-vpn von Port 53 auf Port 54 um, damit eben der “WAN-DNS” genommen wird und nicht ggf. der Freifunknetz-interne).


#40

Hallo wusel,
der TP-Link hat derzeit keinen Strom. Ich habe den Stecker abgezogen, damit er nicht zum Brandopfer in meinem Ofen wird! :o)))

Wie schon erwähnt, hängt das Ding direkt im Internet, hat eine eigene IP Adresse (217.151.149.75). Da müsste ich mal die TWLkom in Ludwigshafen fragen, ob deren Router, also unser Gateway, da was blockt. Wir haben da schon sehr viel am Start, es wurde noch nie was geblockt…

Sobald mein Kollege den TP-Link Kasten wieder mit Strom versorgt hat, kann ich darauf zugreifen und die Tests ausführen. Da dieser Zugriff per ssh einwandfrei funktioniert, denke ich mal, dass der WAN Port richtig angeschlossen ist.

Grüße
ruebenmaster