Keine IPv4-Adresse / Knoten ohne Verbindung, aber nicht offline

Hallo,

mein Knoten http://ffmap.freifunk-rheinland.net/#!n:c4e984ef4604 macht leider seit dem Wochenende Probleme.
Oft bekommen Clients keine IPv4 zugewiesen, mindestens dauert es aber sehr lange bis man eine Bekommt. Ist man dann verbunden hat man Glück wenn man wenigstens mal eine DNS-Abfrage hin bekommt, mehr ist aber nicht drin.
Von aussen kann ich denk Knoten manchmal anpingen, manchmal nicht. Die Statusseite bekommt man auch nur mit viel Glück zu Gesicht.
Ich dachte bisher das wäre ein generelles Problem, dann sollten das aber auch noch andere haben, oder?
Ich bin gerade etwas ratlos, wie das zu Debuggen ist?

viele Grüße

Biertrinker

Hallo nochmal,

seit gestern Abend ist der Knoten jetzt wieder „halbwegs“ am Netz, sprich es gibt wieder IPv4 Adressen und man kann ihn mit seiner IPv6 auch von Aussen erreichen. Surfen geht auch, aber recht langsam, was ja nichts ungewöhnliches ist.
Zwei Dinge sind mir aber aufgefallen:

  1. Die Karte aktuallisiert sich nicht, der Knoten hat gerade im Moment 3 Clients, in der Karte steht einer.
  2. Gestern war der immer mit dem Supernode Rheinufer2 verbunden, heute mit Rheinufer1

Ist das jetzt einfach generell Überlastung von Rheinufer?

viele Grüße

Biertrinker

Hallo biertrinker,

die Karte läuft seit eben wieder.
Die Performance wird bis es weitere Netsplits gibt nicht besser werden. Das Rheinufer ist einfach zu groß geworden. Ein wenig Entlastung gibt es die nächsten Tage/Wochen dadurch, dass einige Router in andere Communities wechseln. Gleichzeitig kommen aber auch stetig neue Router dazu.

Zu den genauen Plänen zu den nächsten Netsplits und der Zukunft des Rheinufers können dir andere mehr sagen.

Viele Grüße,
David

Über welchen ISP geht der VPN-Tunnel deines Nodes raus? Ist das die Deutsche Telekom?

Wir haben das Problem, dass unser Provider für die Supernodes unseren Traffic mittlerweile über ein Peering rausschickt, das in er meisten Zeit gesättigte Verbindungen ins Netz der Deutschen Telekom hat (wie leider sehr viele andere auch). Daher gibt es dann massive Paketverluste bis hin zur völligen Trennung.

Soweit ich weiß, ist das Team vom Freifunk Rheinland gerade dabei, eine neue Location für Supernodes aufzubauen, an der dieses Problem endlich nicht mehr auftreten wird. Bis dahin muss ich um Geduld bitten, denn auch Netsplits lösen dieses Problem leider nicht.

1 Like

Das läuft über Unitymedia Business, sollte also mit der Telekom nix zu tun haben. Was mir aber gerade auffällt, verbindet sich der Knoten lieber über IPv6 oder IPv4? Ich habe nämlich kein natives IPv6 und dafür einen Tunnel laufen, da könnten die Wege also andere sein. Kann ich das irgendwie tracen?

Der Tunnel ist Dual-Stack, bevorzugt also IPv6. Wenn du das steuern willst, kannst du zum Beispiel die DNS-Auflösung in deinem LAN einstellen, nur A Records auszuliefern.

Habe gerade den IPv6 Tunnel deaktiviert und den Knoten neu gestartet. Erst sah es gut aus, aber noch 2-3 Minuten war dann auch Ende, gehen nur noch sporadisch Pings über die Verbindung.

Ist das so das Bild was zu erwarten ist wenn die Domäne zu voll ist? Wenn ich ein Image für meinen 841v10 für Niersufer hätte könnte ich auch einfach da hin gehen, vielleicht läuft es dann besser.

Wenn du das steuern willst, kannst du zum Beispiel die DNS-Auflösung in deinem LAN einstellen, nur A Records auszuliefern.

Du meinst dass der lokale DNS überhaupt keine Auflösung auf IPv6-Adressen mehr macht? Das schießt ja eigentlich übers Ziel hinaus :wink:

Mein Vorschlag ist, dass du in deinem lokalen DNS-Resolver Einträge für unsere Supernodes anlegst:

ddorf1.ffrl.de 89.163.150.94
ddorf2.ffrl.de 89.163.154.93

So sollte kein AAAA-Record (IPv6) mehr an die Clients hinaus gehen und der Freifunk-Node sich per IPv4 verbinden.

Alternativ dazu geht glaube ich auch eine Einstellung im Config-Mode, unter Experten -> Netzwerk.