LAN-Ports als Switch für lokales Netz?

Hallo,

habe gerade ffhrath-schleypenhof erfolgreich in Betrieb genommen. Alles super beschrieben!
Super finde ich die Möglichkeit, meine private SSID auf demselben Gerät mit zu nutzen. Das erspart mir den zweiten Accesspoint.
Nun habe ich noch einen Wunsch: einen oder alle der LAN-Ports auch für das interne Netz zu nutzen. Kann man die auch auf den WAN-Port bridgen?

Danke und liebe Grüße

Georg

Ich habe das Thema in die Kategorie Technik/Gluon verschoben, da die Frage nicht spezifisch für die Domäne Regio Aachen ist, und so mehr Leute darauf aufmerksam werden.

1 Like

Hallo @Bulli und willkommen bei Freifunk.

Du benötigst ssh Zugang zu deinem Freifunk Knoten, welchen du im config Modus aktivieren kannst.

Logge dich dann per ssh ein und führe folgende Befehle aus:

https://wiki.freifunk.net/Konsole#WAN_auf_allen_Netzwerkports

Dann erhältst du den gewünschten Effekt.

Viel Spaß mit Freifunk.

Achtung! Nach einem Update werden diese Einstellungen zurückgesetzt!

1 Like

Danke für die Tipps.
SSH hatte ich schon freigeschaltet. Habe die drei uci-Kommandos jetzt abgesetzt.
Den Router habe ich neu gestartet und die Verbindung zum Router auf den gelben Port 1 gesteckt.
Der Router hat eine neue IP bekommen, da der LAN-Port wohl eine andere MAC hat.
Jetzt geht der Knoten aber nicht mehr online. Per SSH komme ich auch nicht mehr drauf.
Ping ging vor der Umstellung, jetzt nicht mehr. :frowning:

Lass dein „Internet Kabel“ mal im blauen WAN Port stecken.

Kann ich nicht bestätigen. Habe einen wr841 so im Einsatz und der behielt die Einstellungen bei.

Habe jetzt nochmal komplett neu aufgesetzt und erstmal eine weitere Switch angeschlossen.

Kann es sein, dass sich die Schnittstellen von Router zu Router unterscheiden? Oder liegt es an der Community-Version, wird das evtl. anders konfiguriert?
Ich habe einen TP-Link TL-WR1043N/ND v1 mit 2016.1.2-1-stable / gluon-v2016.1.2.
Ich scheine keine eth1-Schnittstelle zu haben. Bei ifconfig sehe ich bat0, eth0, eth0.1 und eth0.2. Die MAC-Adresse von eth0.2 ist identisch mit der von eth0, eth0.1 hat eine andere.
uri show network:
network.wan.ifname=‚eth0.2‘
network.client.ifname=‚bat0‘ ‚eth0.1‘

Habt Ihr eine Idee?

Gefühlt müsste es so gehen:

uci set network.wan.ifname='eth0.2 eth0.1'
uci set network.client.ifname='bat0'
/etc/init.d/network restart

wenn es funktioniert uci commit network

Schade, geht auch nicht.
Wenn ich in die LAN-Ports jetzt ein Gerät einstecke geht die Verbindung vom Router zum LAN scheinbar weg. Die SSH-Session wird unterbrochen.
Stecke ich das Gerät wieder aus kann ich wieder eine Verbindung aufbauen.

Gibt es irgendwo ein Schaubild oder eine Erklärung, wie die einzelnen Netzwerkinterfaces zusammenhängen?

Kann es sein, dass dein FF-Router direkt an einem Kabelmodem hängt und im Netzwerk kein DHCP Server läuft?

Nein, der hängt an einer Fritzbox.
Da habe ich allerdings hinterlegt, dass der Router immer dieselbe IP bekommen soll, ist aber über DHCP.

Habe das nun folgendermaßen gelöst:
In der /etc/config/network folgende Einträge geändert:

config switch_vlan
option device ‚switch0‘
option vlan ‚1‘
option ports ‚1 2 3 4 5t‘

config switch_vlan
option device ‚switch0‘
option vlan ‚2‘
option ports ‚0 5t‘

jetzt:
config switch_vlan
option device ‚switch0‘
option vlan ‚1‘
option ports ‚4 5t‘

config switch_vlan
option device ‚switch0‘
option vlan ‚2‘
option ports ‚0 1 2 3 5t‘

Das klappt nun. Ich habe auf Port1 den Fernseher eingesteckt und der kann alle Medienserver im lokalen Netz sehen.
Frage: gehen die Einstellungen in /etc/config/network beim Update verloren?