Mesh on LAN/WAN über Console ein-/ausschalten

Hallo,

ich habe die Beobachtung gemacht, dass sich Mesh on LAN / WAN nicht mehr wie beschrieben über die Konsole ein und ausschalten lässt. Wenn ich die Router über den Setup-Mode für Mesk-on LAN / WAN konfiguriere, funktioniert es. Unterschiede in den Einstellungen zwischen funktionierenden und nicht funktionierenden Router habe ich nicht gefunden. Auch in der Setup-Software habe ich nichts gefunden, was anders ist, als beide Einstellung über ssh.

Problem ist, dass das Interface nicht als batman Interface zugeordnet wird. Auch wenn ich das Interface mit batctl if add br-wan / br-mesh-lan aktiviere, scheint nichts zu passieren - wird der mesh nicht in der Statusseite angezeigt.

Hallo,

vielleicht hilft dir http://gluon.readthedocs.io/en/latest/features/wired-mesh.html weiter da steht drin wie man es per uci macht ,-)

Genau nach der Anleitung habe ich es gemacht. Auf den 841v9 und meinen CPE 210 funktioniert es nicht. Die haben schon eine lange Geschichte, aber ich habe sie auch mit „sysupgrade -n“ geflasht.

Immer das gleiche Spiel. Auch unter logread ist nichts zu sehen. Es wird nicht versucht br-wan oder br-mesh_lan dem mesh hinzuzufügen.

Nur bei einem frischen 1043n v5 hat es mit dem Mesh on LAN geklappt.

Ich finde einfach keinen Ansatz, wo ich weiter suchen könnte.

je nach Gluon-Version sind die nötigen Befehle andere, guck mal dort nach:

im aktuellen Gluon Master Branch sind die Befehle anderes als bei v2016.x und v2017.x

1 Like

Ich habe die Befehle aus der Dokumentation der Version v2017.1.5 genommen. Die Konfiguration stimmt auch mit anderen Routern überein, die schon länger über WAN oder LAN mesh und deren erste Firmware auf 2015.x lief.

In latest sind noch die alten Befehle bis 2016.1, die funktionieren auch mit dem master nicht.

In der Diskussion über den 1043n v5 kam über einen Parameter legacy, der nirgends dokumentiert ist. Aber der hilft auch nicht.

Diese Befehle funktionieren nicht. Die Schnittstelle br-mesh_lan wird dadurch zwar erstellt oder nicht erstellt, sie wird aber nicht von batman als Mesh-Interface genommen. Ich ahbe heute eien Router über das Web-Interface konfiguriert und siehe da, es funktioniert. Nur: Das Web_Interface mach soweit ich es sehe auch nichts anderes als die Befehle auf der Konsole.

Hast du es nach dem ändern in der console auch mit neustart probiert ? das ist das einzige was mir noch einfällt. uci ändern uci commit reboot

Moin,
mal ganz infantil gefragt, wie werden die Befehle denn eingegeben? Für das deaktivieren von Mesh-on-LAN

uci set network.mesh_lan.disabled=1
for ifname in $(cat /lib/gluon/core/sysconfig/lan_ifname); do
  uci add_list network.client.ifname=$ifname
done
uci commit network

Wird Zeile 2-4 in einem Block ausgeführt? So habe ich mit wenigstens neulich die Einstellungen in v2017.1.4 kaputt gemacht.

@MisterCrumble

Ja, mehrfach. Oder auch nur ein /etc/init.d/network /restart

@coco
Die Befehle setze ich mit Copy and Paste ab. Fehlermeldungen ergeben sich nicht und die Optionen unter network.mesh_lan bzw network.mesh_wan sind die zu erwartenden.

Mir ist schleierhaft, was die Knoten sonst noch machen sollten. Auch das Setup macht nichts anderes - zumindest auf den ersten Blick.

So wie ich das verstanden habe startet der Router nach dem config modus einmal neu. Keine Ahnung was da beim booten getan wird.

wie im github issue auch geschrieben könnte ich mir vorstellen, dass das Problem von einem kaputten alten Build noch herrührt.
Vielleicht einmal ganz frisch flashen ohne Übernahme der alten Settings - wenn es beim WR1043N v5 dann auch nicht mehr klappt, wären wir einen Schritt weiter in der Analyse.

Da das Problem außer dir bisher keiner berichtet, tendiere ich immer noch zu einem Problem in deinem/eurem Build bzw. Konfiguration…

Befehle haben wir ja jetzt reichlich gesammelt. Bei welcher Firmware geht es bei dir konkret nicht? Hier wurde nur mal was von v2017.x geschrieben.

Das würde mich inzwischen auch wirklich interessieren.
Denn die beschriebenen Probleme kenne ich so schlicht nicht.
Der genannte Ansatz erscheint mir sinnvoll. Eines der Folgenden:

  • Router per Befehel ‚firstboot‘ in Urzustand zu versetzen oder
  • Router per TFTP neu flashen
  • Router mit der Option „Konfiguration nicht behalten“ neu flashen.

Und wenn’s dann wirklich noch nicht gehen sollte, bitte einmal den Output von

batctl br
brctl show
ip a
ip link