Meshviewer - Unsupported nodes or graph version: undefined 1

Moin zusammen,

wir haben den JSON-Merger vom FFRuhr weitergebaut, damit nach der Umstellung unseres Netzes in ein HoodSystem der Meshviewer mit richtigen Daten beliefert wird.

Die neue nodes.json sieht jetzt so aus: http://meshviewer.dev.ffnw.de/data2/new_nodes.json

Die Rohdaten kommen aus folgenden Jsons:
http://mesh.ff-osna.de/data/nodes.json
https://mesh.ffnw.de/public/data/batman-v15/nodes.json

Nachdem die neue json Datei eingebunden wird erscheint im Meshviewer nur noch folgender Fehler:
Unsupported nodes or graph version: undefined 1

Hat irgendjemand eine Idee, was hier falsch sein könnte?

Vielen Dank!

Hey,

ist der json Merger im Netz zu finden? Klingt interessant.

Ja, ff-json-tools/nodes_merger.php at master · ffruhr/ff-json-tools · GitHub

Habe grade festgestellt, dass bei dem Meshviewer ja auch mehrere Datasources eingetragen werden können - nun funktioniert alles bestens :slight_smile:

1 Like

Der nodes_merger.php ist veraltet und ist für das Datenformat des alten ffmap-backend.

Ja, das hatte ich mir grade gedacht. Aber mit mehreren Datasources funktioniert es jetzt schon :wink:

1 Like

Es kommt auch immer drauf an, welchen meshviewer du benutzt…
Das mit mehreren Datenquellen ist im originalen meshviewer nämlich gar nicht enthalten.

Und intern macht der Meshviewer mit mehreren Datenquellen nichts anderes, als sich mal eben beim Laden zu mergen. Ist halt weniger fehleranfällig und so…