[Offloader] [geänder] VLAN erstellen auf 1 oder 2 Netzwerkkarten


#1

Ich habe einen Futro mit einer zusätzlichen Netzwerkkarte. Mein Problem ist ich bekomme keine richtige Konfiguration im Futro das er 2VLAN’s erstellt. Ich möchte auf den einen Port WAN und auf den anderen die beiden VLAN’s die dann zu einem Switch gehen (VLAN fähig)

Fritzbox --> Switch --> (eth1) Futro (eth0)–> Switch --> Unifi Ap

Falls jemand dafür einen Lösung weg hat wäre ich sehr dankbar. Habe eine Lösung mit einer Karte aber mit Probleme (steht weiter unten)


Offloader [Futro] VLAN richtig einstellen
#2

Moin,

du meinst Mesch- und Klientennetz?

Zeig mal die /etc/network/interfaces.

Viele Grüße
Matthias


#3

Moin,

Ich habe es jetzt über die OnBoard Netzwerkkarte am laufen (1 Kabel System). Das Problem ist jetzt nur das VLAN beim WAN funktioniert (Offloader ist Online im FF-Netz) aber ich weiß nicht wie ich das VLAN für Client und Mesh erstellen kann so das ich über den Unifi AP Mesh und Client ausstrahlen kann.

/etc/network/interfaces

config interface ‘client’
option igmp_snooping ‘1’
option type ‘bridge’
option auto ‘1’
option multicast_querier ‘1’
option macaddr ‘00:19:99:a1:86:16’
list ifname ‘local-port’
list ifname ‘bat0’
option ipv6 ‘1’
option keep_ra_dnslifetime ‘1’
option sourcefilter ‘0’
option peerdns ‘1’
option robustness ‘9’
option reqprefix ‘no’
option query_interval ‘2000’
option query_response_interval ‘500’
option proto ‘dhcpv6’

config device ‘local_node_dev’
option type ‘veth’
option name ‘local-node’
option peer_name ‘local-port’
option macaddr ‘16:41:95:40:f7:dc’
option peer_macaddr ‘00:19:99:a1:86:16’

config interface ‘local_node’
option ifname ‘local-node’
option ipaddr ‘10.196.0.127/17’
option ip6addr ‘fd2f:5119:0f2c::127/128’
option ip6deprecated ‘1’
option proto ‘static’

config interface ‘gluon_bat0’
option proto ‘gluon_bat0’

config interface ‘bat0’
option multicast_router ‘2’
option ifname ‘bat0’
option auto ‘1’
option macaddr ‘00:19:99:a1:86:16’
option learning ‘1’
option proto ‘none’

config route6 ‘local_node_route6’
option target ‘fd2f:5119:0f2c::/64’
option gateway ‘::’
option interface ‘client’

config interface ‘mesh_vpn’
option ifname ‘mesh-vpn’
option transitive ‘1’
option mtu ‘1280’
option macaddr ‘5e:bb:63:3b:e7:5f’
option fixed_mtu ‘1’
option proto ‘gluon_mesh’

config interface ‘mesh_lan’
option auto ‘1’
option ifname ‘eth0.20’
option macaddr ‘8D:0C:DB:40:2A:82’
option mesh ‘bat0’
option proto ‘gluon_mesh’

brctl show

bridge name     bridge id               STP enabled     interfaces
br-wan          7fff.5ebb633be758       no              eth0.1
br-client               7fff.001999a18616       no              bat0

#4

Moin,

ich verstehe nicht so richtig, was du bauen möchtest?

Was ist ein 1-Kabel-System?

Die VLANs kannst du über die oben gezeigte Datei einstellen. Da fehlt aber noch einiges, das ist vllt. ein Drittel der Datei.

Letztendlich musst du das Clientnetz auf ein VLAN legen und das Meschnetz auf ein anderes. Dazu muss oben eine weitere Schnittstelle (Interface) mit dem passenden VLAN angelegt werden und dieses dann unten bei Klienten- und Meschnetz zugewiesen werden.

Wenn du die ganze /etc/config/network einstellst, kann dir das sicherlich hier jemand kurz zeigen.

Viele Grüße
Matthias


#5

Ich meinte damit das ich nur ein Lan Anschluss am Futro benutze

Hier die ganze /etc/config/network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd54:b271:e644::/48’

config interface ‘wan’
option igmp_snooping ‘1’
option ifname ‘eth0’
option multicast_querier ‘0’
option peerdns ‘0’
option auto ‘1’
option type ‘bridge’
option proto ‘dhcp’
option macaddr ‘5e:bb:63:3b:e7:58’

config interface ‘wan6’
option ifname ‘br-wan’
option ip6table ‘1’
option sourcefilter ‘0’
option peerdns ‘0’
option reqprefix ‘no’
option proto ‘dhcpv6’

config rule6 ‘wan6_lookup’
option mark ‘0x01/0x01’
option lookup ‘1’

config route6 ‘wan6_unreachable’
option type ‘unreachable’
option table ‘1’
option target ‘::/0’
option metric ‘65535’
option gateway ‘::’
option interface ‘loopback’

config interface ‘mesh_wan’
option ifname ‘br-wan’
option auto ‘0’
option transitive ‘1’
option fixed_mtu ‘1’
option proto ‘gluon_mesh’
config interface ‘client’
option igmp_snooping ‘1’
option type ‘bridge’
option auto ‘1’
option multicast_querier ‘1’
option macaddr ‘00:19:99:a1:86:16’
list ifname ‘local-port’
list ifname ‘bat0’
option ipv6 ‘1’
option keep_ra_dnslifetime ‘1’
option sourcefilter ‘0’
option peerdns ‘1’
option robustness ‘9’
option reqprefix ‘no’
option query_interval ‘2000’
option query_response_interval ‘500’
option proto ‘dhcpv6’

config device ‘local_node_dev’
option type ‘veth’
option name ‘local-node’
option peer_name ‘local-port’
option macaddr ‘16:41:95:40:f7:dc’
option peer_macaddr ‘00:19:99:a1:86:16’

config interface ‘local_node’
option ifname ‘local-node’
option ipaddr ‘10.196.0.127/17’
option ip6addr ‘fd2f:5119:0f2c::127/128’
option ip6deprecated ‘1’
option proto ‘static’

config interface ‘gluon_bat0’
option proto ‘gluon_bat0’

config interface ‘bat0’
option multicast_router ‘2’
option ifname ‘bat0’
option auto ‘1’
option macaddr ‘00:19:99:a1:86:16’
option learning ‘1’
option proto ‘none’

config route6 ‘local_node_route6’
option target ‘fd2f:5119:0f2c::/64’
option gateway ‘::’
option interface ‘client’

config interface ‘mesh_vpn’
option ifname ‘mesh-vpn’
option transitive ‘1’
option mtu ‘1280’
option macaddr ‘5e:bb:63:3b:e7:5f’
option fixed_mtu ‘1’
option proto ‘gluon_mesh’

Hoffe das es jetzt so richtig ist und das mir jermand helfen kann das ich das Client und Mesh Netzwerk rausbekomme als VLAN


#6

Jetzt verstehe ich gar nichts mehr. Davon nur eine Netzwerkkarte zu nutzen wird im Allgemeinen abgeraten. Aus Gründen, die mir noch keiner im Detail erklären konnte, lahmt das im Vergleich zu zweien.

Wenn du zwei Netzwerkkarten hast, würde ich auch beide benutzen. Soll ich dir die Konfiguration für eine oder für zwei aufzeigen?


#7

Ich kann die andere Netzwerkkarte wieder einbauen das ist kein Problem.

Wäre nett wenn du mir die config dafür machen könntest:)

Also eine Netzwerkkarte fürs WAN und die andere wo die beiden VLAN´s herauskommen


#8

Mach das mal, und konfiguriere das Gluon dann nochmal frisch, sodass beide Netzwerkkarten aktiv sind.

Auf der einen hast du dann WAN für den Tunnel. Und auf die andere legen wir Mesch- und Klientennetz.

Zieh dann nochmal die Konfigurationsdatei, ist dann erheblich einfacher, die umzubauen.


#9

Habe die andere Karte reingesteckt und Gluon neu aufgesetzt

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd96:e873:d7ad::/48’

config interface ‘wan6’
option proto ‘dhcpv6’
option ifname ‘br-wan’
option ip6table ‘1’
option sourcefilter ‘0’
option peerdns ‘0’
option reqprefix ‘no’

config interface ‘wan’
option igmp_snooping ‘1’
option ifname ‘eth1’
option multicast_querier ‘0’
option peerdns ‘0’
option auto ‘1’
option type ‘bridge’
option proto ‘dhcp’
option macaddr ‘6e:b7:9e:fa:17:20’

config rule6 ‘wan6_lookup’
option mark ‘0x01/0x01’
option lookup ‘1’

config route6 ‘wan6_unreachable’
option type ‘unreachable’
option table ‘1’
option target ‘::/0’
option metric ‘65535’
option gateway ‘::’
option interface ‘loopback’

config interface ‘mesh_wan’
option ifname ‘br-wan’
option auto ‘0’
option transitive ‘1’
option fixed_mtu ‘1’
option proto ‘gluon_mesh’

config interface ‘mesh_lan’
option igmp_snooping ‘0’
option ifname ‘eth0’
option transitive ‘1’
option fixed_mtu ‘1’
option proto ‘gluon_mesh’
option type ‘bridge’
option auto ‘0’
option macaddr ‘6e:b7:9e:fa:17:24’
config interface ‘client’
option igmp_snooping ‘1’
option type ‘bridge’
option auto ‘1’
option multicast_querier ‘1’
option macaddr ‘00:0e:0c:82:ec:2b’
list ifname ‘eth0’
list ifname ‘local-port’
list ifname ‘bat0’
option ipv6 ‘1’
option keep_ra_dnslifetime ‘1’
option sourcefilter ‘0’
option peerdns ‘1’
option robustness ‘9’
option reqprefix ‘no’
option query_interval ‘2000’
option query_response_interval ‘500’
option proto ‘dhcpv6’

config device ‘local_node_dev’
option type ‘veth’
option name ‘local-node’
option peer_name ‘local-port’
option macaddr ‘16:41:95:40:f7:dc’
option peer_macaddr ‘00:0e:0c:82:ec:2b’

config interface ‘local_node’
option ifname ‘local-node’
option ipaddr ‘10.196.0.127/17’
option ip6addr ‘fd2f:5119:0f2c::127/128’
option ip6deprecated ‘1’
option proto ‘static’

config interface ‘gluon_bat0’
option proto ‘gluon_bat0’

config interface ‘bat0’
option multicast_router ‘2’
option ifname ‘bat0’
option auto ‘1’
option macaddr ‘00:0e:0c:82:ec:2b’
option learning ‘1’
option proto ‘none’

config route6 ‘local_node_route6’
option target ‘fd2f:5119:0f2c::/64’
option gateway ‘::’
option interface ‘client’

config interface ‘mesh_vpn’
option ifname ‘mesh-vpn’
option transitive ‘1’
option mtu ‘1280’
option macaddr ‘6e:b7:9e:fa:17:27’
option fixed_mtu ‘1’
option proto ‘gluon_mesh’

brctl show

br-client 7fff.000e0c82ec2b no eth0
local-port
bat0
br-wan 7fff.6eb79efa1720 no eth1

Wenn du die Config geändert hast und ich den Switch richtig eingestellt habe muss ich dann eigentlich nur noch den Unifi Ap einstellen und es müsste Fumktionieren.

Sage jetzt schon mal Dankeschön :slight_smile:


#10

Ich kann es gerade nicht testen, aber ich glaube, die paar Änderungen sind schon alles.

config interface ‘mesh_lan’
option igmp_snooping ‘0’
option ifname ‘eth0.4’
option transitive ‘1’
option fixed_mtu ‘1’
option proto ‘gluon_mesh’
option type ‘bridge’
option auto ‘1’
option macaddr ‘6e:b7:9e:fa:17:24’

config interface ‘client’
option igmp_snooping ‘1’
option type ‘bridge’
option auto ‘1’
option multicast_querier ‘1’
option macaddr ‘00:0e:0c:82:ec:2b’
list ifname ‘eth0.5’
list ifname ‘local-port’
list ifname ‘bat0’
option ipv6 ‘1’
option keep_ra_dnslifetime ‘1’
option sourcefilter ‘0’
option peerdns ‘1’
option robustness ‘9’
option reqprefix ‘no’
option query_interval ‘2000’
option query_response_interval ‘500’
option proto ‘dhcpv6’

#11

Danke für deine Idee, ich hatte es in der zwischenzeit mit einem anderen Freifunker gelöst bekommen aber ich stehe jetzt vor einem anderen Problem mein Unifi AP strahlt FF Client/ Privat aus aber ich würde gerne mein alten FF AP von TP mit ins Netz hängen komme da nicht weiter.


#12

Da musst du einfach nur LAN-Mesch aktivieren und ihn auf das VLAN mit dem Meschnetz schalten.


#13

Also Mesh on Lan auf dem Futro Aktivieren und auf dem Vlan vom Mesh_Lan (eth0.4) packen ? und auf dem TP-Link Mesh on WAN aktivieren ?


#14

So war es in meinem Beispiel.

Das hängt davon ab, welchen Port du benutzen möchtest. WAN-Mesch ist auf dem blauen Port. Es geht auch über die gelben (LAN-Mesch).


#15

Ich habe bis jetzt nur im Interface “Client” das VLan hinzugefügt und mit dem Unifi AP verbunden also müsste man im interface “mesh_lan” einfach ein Vlan hinzufügen und im Switch einrichten oder welche Vlan´s müssen auf dem Port laufen wo ich den TP-Link AP betreiben will ?


#16

Ich kann es gerade nicht testen, aber ich glaube, die paar Änderungen sind schon alles.

config interface ‘mesh_lan’
option igmp_snooping ‘0’
option ifname ‘eth0.4’
option transitive ‘1’
option fixed_mtu ‘1’
option proto ‘gluon_mesh’
option type ‘bridge’
option auto ‘1’
option macaddr ‘6e:b7:9e:fa:17:24’

config interface ‘client’
option igmp_snooping ‘1’
option type ‘bridge’
option auto ‘1’
option multicast_querier ‘1’
option macaddr ‘00:0e:0c:82:ec:2b’
list ifname ‘eth0.5’
list ifname ‘local-port’
list ifname ‘bat0’
option ipv6 ‘1’
option keep_ra_dnslifetime ‘1’
option sourcefilter ‘0’
option peerdns ‘1’
option robustness ‘9’
option reqprefix ‘no’
option query_interval ‘2000’
option query_response_interval ‘500’
option proto ‘dhcpv6’

Habe es so versucht auch mit der Hilfe einem anderne Freifunker aber ohne erfolg…

Futro: Mesh on Lan Aktiviert und Vlan hinzugefügt
TP-Link: Mesh on Wan Aktiviert
Im Switch VLan hinzugefügt

Mesh on Lan habe ich wenn dann bei mir auf VLAN ID “3”


#17

Was genau klappt denn nicht?


#18
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd4c:65c2:d41f::/48'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'br-wan'
	option ip6table '1'
	option sourcefilter '0'
	option peerdns '0'
	option reqprefix 'no'

config interface 'wan'
	option igmp_snooping '1'
	option ifname 'eth1'
	option multicast_querier '0'
	option peerdns '0'
	option auto '1'
	option type 'bridge'
	option macaddr '6e:b7:9e:fa:17:20'
	option proto 'static'
	option ipaddr '192.168.178.150'
	option netmask '255.255.255.0'
	option gateway '192.168.178.1'

config rule6 'wan6_lookup'
	option mark '0x01/0x01'
	option lookup '1'

config route6 'wan6_unreachable'
	option type 'unreachable'
	option table '1'
	option target '::/0'
	option metric '65535'
	option gateway '::'
	option interface 'loopback'

config interface 'mesh_wan'
	option ifname 'br-wan'
	option auto '0'
	option transitive '1'
	option fixed_mtu '1'
	option proto 'gluon_mesh'

config interface 'mesh_lan'
	option igmp_snooping '0'
	option ifname 'eth0'
	option transitive '1'
	option fixed_mtu '1'
	option proto 'gluon_mesh'
	option type 'bridge'
	option macaddr '6e:b7:9e:fa:17:24'
	option auto '1'

config interface 'client'
	option igmp_snooping '1'
	option type 'bridge'
	option auto '1'
	option multicast_querier '1'
	option macaddr '00:0e:0c:82:ec:2b'
	option ipv6 '1'
	option keep_ra_dnslifetime '1'
	option sourcefilter '0'
	option peerdns '1'
	option robustness '9'
	option reqprefix 'no'
	option query_interval '2000'
	option query_response_interval '500'
	option proto 'dhcpv6'
	list ifname 'eth0.2'
	list ifname 'local-port'
	list ifname 'bat0'

config device 'local_node_dev'
	option type 'veth'
	option name 'local-node'
	option peer_name 'local-port'
	option macaddr '16:41:95:40:f7:dc'
	option peer_macaddr '00:0e:0c:82:ec:2b'

config interface 'local_node'
	option ifname 'local-node'
	option ipaddr '10.196.0.127/17'
	option ip6addr 'fd2f:5119:0f2c::127/128'
	option ip6deprecated '1'
	option proto 'static'

config interface 'gluon_bat0'
	option proto 'gluon_bat0'

config interface 'bat0'
	option multicast_router '2'
	option ifname 'bat0'
	option auto '1'
	option macaddr '00:0e:0c:82:ec:2b'
	option learning '1'
	option proto 'none'

config route6 'local_node_route6'
	option target 'fd2f:5119:0f2c::/64'
	option gateway '::'
	option interface 'client'

config interface 'mesh_vpn'
	option ifname 'mesh-vpn'
	option transitive '1'
	option mtu '1280'
	option macaddr '6e:b7:9e:fa:17:27'
	option fixed_mtu '1'
	option proto 'gluon_mesh'

Problem gelöst :heavy_check_mark::white_check_mark:


#19

Dass du das Meschnetz untaggt und das Klientennetz auf VLAN 2 haben wolltest, kann ich nicht reichen :wink: .


#20

Das Stimmt aber auch dir Dankeschön für deine mithilfe. Mein Problem ist gelöst und in diesen Sinne könne das hier geschlossen werden.