PiVPN einrichten


#1

Hallo!

Ich wollte eigentlich Stronswan installieren, aber weil das doch einige Hürden hat, dachte ok, PiVPN ist einfacher. Würde mir auch dann vorgeschlagen.

Jetz habe ich auf meinen PI1, DNSMASQ, PI-Hole und den Apachen laufen.
PiVPN installieren war nicht schwer und basiert auf OPENVPN und soll einfach sein. Ä?? nein.

curl -L https://install.pivpn.io | bash
ein bißchen config noch und alles läuft.

komisch bei läuft er nicht. Ich bekomme den Dienst nicht am laufen. In der /vat/log/openvpn.log steht:

Mar 26 19:42:56 konigs ovpn-server[25052]: Options error: Unrecognized option or missing parameter(s) in /etc/openvpn/server.conf:26: compress (2.2.1)
Mar 26 19:42:56 konig ovpn-server[25052]: Use --help for more information.

In der Zeile steht nur compress lz4

mein Freund Google bringt mich nicht weiter, habt Ihr eine Idee?


#2

https://www.thomas-krenn.com/de/wiki/OpenVPN_mit_Pre-shared_Key

Ist in weniger als fünf Minuten fertig.


#3

@Comacho: jetzt mal im Ernst!

Ich fühle mich gerade verhohnepiepelt. Ich habe ein Problem und denke, ach fragste mal das Forum, das hat dir schon beim letzten Mal geholfen.

Strongswan ist zu schwer, nimm pivpn. Es gibt was besseres als pivpn, nimm openvpn. Ach openvpn, nimm…

So, wie ich das verstanden habe, baut pivpn doch auf openvpn auf. Wenn openvpn nicht installiert ist, funktioniert das andere auch nicht.

Mein Fehler ist doch nur der ungültige Parameter von compress. Ich will das Rad doch nicht neuerfinden.


#4

Junge es wird sich jetzt keiner in das script rein fuchsen .
Wenn es so einfach und toll ist sollte es ja funktionieren.
Wenn nicht mache bei denen einen Bug report auf.
Wie gesagt die oben gepostete Anleitung funktioniert und dann weiss man was man macht (hoffentlich).

Un die Lösung zu deinem Problem hast du dir doch in deinem ersten Post selber gegeben :wink:


#5

Ach fragste Mal ein Offtopic Thema und wunderst dich über die Antworten.

Vielleicht solltest du dich tiefergehend mit den Themen befassen oder dich an die PiVPN Community wenden anstatt hier herumjammern.


#6

Im Ernst, wieso kommst Du auf “Zeile löschen” (natürlich auf beiden Seiten der Verbindung) nicht selbst?


#7

Hey!

So, jetzt war ich einige Tage in der dunklen Kammer und bin auf Fehlersuche gegangen.
Warum klappt PIVPN nicht und wie hängt es mit OPENVPN zusammen?

Warum es bei mir es nicht klappt hat, war nach einigen Seiten des lesens schnell klar.
PIVPN läuft nur auf dem aktuellen System, meins war schon zu alt und es fehlten die ein oder andere Datei.
Also den Pi neu aufgesetzt und mit OPENVPN und PIVPN installiert. Es ging sehr schnell, wenn man weiß was man möchte, geht es Ruck Zuck!!

Google und Co können mir irgendwie nicht mehr weiterhelfen, fast alle Vorschläge habe ich ausprobiert. Eine Kleinigkeit geht, aber nicht.
Aber jetzt mal von vorne:

Auf dem Pi läuft OPENVPN und alle Portweiterleitung sind gesetzt. Von außen kann ich mich auf mein Heimnetz schalten und alles läuft soweit super. Frag meine externe IP, wird die von Zuhause angezeigt. Lokale IPs direkt werden innerhalb 50ms angezeigt. Schwenk je nach WLAN und Internet Verbindung.
Was nicht läuft ist der interne DNS-Server, bzw nicht über VPN. Lokale Seiten wie http://zuhause.lokal werden nicht aufgelöst.

Habe auf Server und Client, die Datei von Hand nachgearbeitet. Push bei Server und dhcp-option DNS 192.168.0.19 beim Client, aber nix, er nimmt nix an. Immer Bad host, ich denke es ist nur ne Kleinigkeit mit großer Auswirkung.

Danke


#8

Bind9 DNS Server einrichten unter Debian - root@home:~# liest sich ganz gut. Inklusive Hinweise zum Debugging.


#9

Das Debugging werde ich heute Abend mal ausprobieren. Das könnte mir ja schon vielleicht weiterhelfen. Ich müsste nur raus bekommen, auf welchen DNS Server die Anfragen geschickt werden und warum das nicht auch über das VPN geleitet wird.

Ansonsten klappt ja alles!


#10

entscheidend ist, was der client interne resolver stub macht und ob der ueberhaupt beteiligt wird. Schau Dir mal mit strace/ltrace genau an, was da passiert. Evtl bist Du mit DNS aud UDP/53 erst mal auf dem falschen Dampfer.