Privates Netz statt Freifunk über LAN

Ich möchte einen Freifunk-Router (841N) an einen Router hängen, der leider nur einen LAN-Anschluss hat und dieser für das private Netz benötigt wird. Statt einen Switch zu kaufen liegt es erstmal nahe, einen der 4 Anschlüsse des 841 zu benutzen, die zur Zeit aber ins Freifunk-Netz führen.

Ist es möglich (wenn ja: wie?) den Router so zu konfigurieren, dass man über die LAN-Anschlüsse ins private statt ins Freifunk-Netz kommt? Ist die Konfiguration auch nach dem nächsten (Auto-)Update noch vorhanden?

Ich habe zu dem Thema leider weder im Forum, noch in der gluon-Dokumentation was gefunden.

Ihm Rahmen von „Energie sparen“ ist es sicher sinnvoll.
Ansonsten: 5-Port-Switch gibt’s für 10€… oder noch einen alten 741er nehmen nur ein „stock Openwrt“ drauftun, nur als Switch missbrauchen.

Eigentlich ist das recht einfach, wenn du keine Angst vor der Konsole hast. Informationen findest du hier:
http://wiki.openwrt.org/doc/uci/network

Du musst einfach nur die Ports vom VLAN „intern“ (keine ahnung, wie das gerade heißt, wahrscheinlich „LAN“) zum VLAN „WAN“ umbiegen. Wenn ich heute abend dran denke, kann ich dir meine Konfiguration mal posten.

Ob das allerdings ein Gluon-Update überlebt, weiß ich nicht, vielleicht kann uns da ja mal einer der Entwickler erhellen.

Hi,

auf dem 841 gibt’s zwei Ethernet-Devices, per Default ist WAN-Port eth1 und der LAN-Port eth0, am eth0 hängt ein Switch mit vier Ports. Du kannst in der /etc/config/network eth0 und eth1 vertauschen, dann hast du die gewünschte Konfiguration.

Die Konfigurationsänderung bleibt bei Firmwareupdates erhalten. Ich habe einen Node exakt so laufen, aus exakt den selben Gründen.

Gruß, Markus

3 Likes

Kannst Du mal Deine Netzwerk-Config in ein pastebin werfen? (welches FW/Community?)

Hi, hier ist sie. In der Switch-Definition darf man natürlich nicht den eth0 rausnehmen. Meine MAC-Adressen und globale IPs habe ich mit xxx unkenntlich gemacht.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config switch
	option name 'eth0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0 1 2 3 4'

config interface 'wan'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'dhcp'
	option peerdns '0'

config interface 'client'
	option ifname 'eth1 bat0'
	option type 'bridge'
	option proto 'dhcpv6'
	option reqprefix 'no'
	option macaddr 'xxx'
	option peerdns '1'

config interface 'mesh_vpn'
	option ifname 'mesh-vpn'
	option mesh_no_rebroadcast '1'
	option macaddr 'xxx'
	option mesh 'bat0'
	option proto 'batadv'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'br-wan'
	option peerdns '0'
	option ip6table '1'

config rule6 'wan6_lookup'
	option mark '0x01/0x01'
	option lookup '1'

config route6 'wan6_unreachable'
	option type 'unreachable'
	option table '1'
	option target '::/0'
	option metric '65535'
	option gateway '::'
	option interface 'loopback'

config interface 'bat0'
	option ifname 'bat0'
	option macaddr 'xxx'
	option proto 'none'

config interface 'mesh_radio0'
	option proto 'batadv'
	option mesh 'bat0'
	option mtu '1528'

config interface 'mesh_wan'
	option auto '0'
	option ifname 'br-wan'
	option mesh 'bat0'
	option proto 'batadv'

config device 'local_node_dev'
	option macaddr 'xxx'
	option ifname 'br-client'
	option name 'local-node'
	option type 'macvlan'

config interface 'local_node'
	option ifname 'local-node'
	option ipaddr '10.53.254.254'
	option ip6addr 'xxx'
	option netmask '255.255.255.255'
	option proto 'static'

config route 'local_node_route4'
	option target '10.53.0.0'
	option gateway '0.0.0.0'
	option netmask '255.255.0.0'
	option interface 'client'

config route6 'local_node_route6'
	option target 'xxx'
	option gateway '::'
	option interface 'client'
3 Likes

Perfekt!
Das wird mir einen zusätzlich Switch auf meinem Balkon in Eschborn sparen, wenn ich dort jetzt bei beiden Locos daneben hänge.

Dankeschön! :smiley: Der Router steht bei einem Freund, deshalb kann ich die Konfiguration nicht sofort ausprobieren. Nächste Woche nehme ich das aber mal in Angriff und werden dann auch entsprechendes Feedback geben.

Ich habe die Konfiguration mittlerweile ausprobiert und sie tut genau das, was sie soll. (Vorausgesetzt, man denkt daran das Kabel zum Router nun in einen LAN-Port statt dem WAN-Port zu stecken)

Vor Ort musste ich aber leider feststellen, dass es sich bei dem „Router mit nur einem LAN-Anschluss“ um ein Kabelmodem handelt und die Lösung über einen Switch daher nicht funktioniert. Der Freifunkrouter müsste also fürs LAN nochmal ein eigenes Netzwerk aufmachen.

Ich hatte mir folgendes Setup überlegt: Verbindung zum Router über WAN, Netzwerk auf den LAN-Ports und zusätzlich das Standardnetzwerk über WLAN, über das man ins Freifunknetz kommt.

Ich habe mir die Standardkonfiguration genommen und mit Hilfe von Network configuration [Old OpenWrt Wiki] daran rumgebastelt. Die LAN-Ports vom Freifunknetz abzukoppeln war kein Problem, darauf ein neues Netzwerk aufzumachen hingegen schon (mangels Kenntnis zu Netzwerkkonfiguration). Wäre super, wenn mir da nochmal jemand helfen könnte.

Da würde ich mir jetzt aber schon überlegen, ob es in Anbetracht zukünftiger Gluon-Updates nicht einfacher wäre, einfach einen zweiten (R741…) mit „stock-OpenWRT“ davorzuhängen, der dann nur Router spielt, ohne wlan.

Hi,

ich habe ein ähnliches Problem mit meinem Freifunkrouter. Ich habe ein DSL-Modem mit 4 Lan Ports und einen WR841N als Freifunkrouter. In meiner ursprünglichen Konfiguration hatte ich alle 4 Lan-Ports belegt. Nun, da der Freifunkrouter hinzugekommen ist, habe ich wie oben beschrieben den WAN und den LAN Port getauscht um auf den 4 Lan-Ports des Freifunkrouters mein privates Lan zu haben. Leider habe ich fast 50% Packet loss an den Lan-Ports des Freifunkrouters. Vielleicht hat ja jemand ne Idee.
Hier nochmal die etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
	option type 'bridge'
	option peerdns '0'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'br-wan'
	option peerdns '0'
	option ip6table '1'

config rule6 'wan6_lookup'
	option mark '0x01/0x01'
	option lookup '1'

config route6 'wan6_unreachable'
	option type 'unreachable'
	option table '1'
	option target '::/0'
	option metric '65535'
	option gateway '::'
	option interface 'loopback'

config interface 'client'
	option reqprefix 'no'
	option ifname 'eth0 bat0'
	option proto 'dhcpv6'
	option type 'bridge'
	option macaddr 'xxx'
	option peerdns '1'

config interface 'bat0'
	option ifname 'bat0'
	option macaddr 'xxx'
	option proto 'none'

config interface 'mesh_radio0'
	option proto 'batadv'
	option mesh 'bat0'
	option mtu '1528'

config interface 'mesh_wan'
	option auto '0'
	option ifname 'br-wan'
	option mesh 'bat0'
	option proto 'batadv'

config interface 'mesh_vpn'
	option ifname 'mesh-vpn'
	option mesh_no_rebroadcast '1'
	option macaddr 'xxx'
	option mesh 'bat0'
	option proto 'batadv'

config device 'local_node_dev'
	option macaddr 'xxx'
	option ifname 'br-client'
	option name 'local-node'
	option type 'macvlan'

config interface 'local_node'
	option ifname 'local-node'
	option ipaddr '10.53.254.254'
	option ip6addr 'fda0:747e:ab29:cafe::1/128'
	option netmask '255.255.255.255'
	option proto 'static'

config route 'local_node_route4'
	option target '10.53.0.0'
	option gateway '0.0.0.0'
	option netmask '255.255.0.0'
	option interface 'client'

config route6 'local_node_route6'
	option target 'fda0:747e:ab29:cafe::/64'
	option gateway '::'
	option interface 'client'

Viele Grüße

2 Likes

Bist du dir da sicher? Eben gab es auf der Gluon Liste einen Post dazu:

Kleiner Hinweis am Rande: Wenn die Ports in /etc/config/network
getauscht werden, müssen sie auch in /lib/gluon/core/sysconfig getauscht
werden, sonst sind sie nach dem nächsten Upgrade wieder im
Ursprungszustand… ein flexibleres Konzept zum Umkonfigurieren der
Ports wird in einer zukünftigen Gluon-Version kommen.

1 Like

Du hast einen DSL-Anbieter, der Mehrfach-Einwahl unterstützt oder nutzt Du unterschiedliche DSL-Verträge?

Zum anderen: Hast Du in den Freifunk-Router dann eine PPPoE-Einwahl integriert oder wie kommt der FF-Router ins Netz, wenn er direkt auf dem Modem hängt? Oder ist der Router so geschaltet, dass er PPPoe und (NAT-)Internet auf die gleiche Ethernetbuchse liefert? (Vlan?)

1 Like

Nee, bin ich mir nicht sicher. :wink:
Bei einem Firmwareupgrade ist es mal bestehen geblieben, daraus habe ich gefolgert. Inzwischen habe ich aber auch gesehen dass andere Anpassungen an der /etc/config/network verloren gegangen sind.

1 Like

Mittelfristig könnte man es natürlich auch in die GUI-Config bei der Einrichtung mit aufnehmen. Sollte ja eine Kleinigkeit sein.
Auf jeden Fall funktioniert es so und erspart mir damit hier auch einen Switch oder ein weiteren Router, da das Cable-Modem hier im Keller sitzt.

Danke euch!

Hallo Zusammen,

ich bin neu hier und habe genau das gleiche Problem, jedoch weicht meine Config doch um einiges ab. Ich habe einen 841N V11. Muss ich lediglich aus eth0 eth1 machen und umgekehrt?

Warum muss eigentlich eth0 und eth1 (also LAN und WAN) getauscht werden? Kann man nicht beides parallel laufen lassen?

Wäre toll, wenn eine solche Konfigurationsmöglichkeit im Web UI geschaffen würde. Wo kann man einen solchen Verbesserungsvorschlag einreichen?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde0:d013:35e8::/48'

config interface 'wan6'
        option proto 'dhcpv6'
        option sourcefilter '0'
        option ifname 'br-wan'
        option ip6table '1'
        option peerdns '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

config interface 'wan'
        option igmp_snooping '0'
        option ifname 'eth1'
        option auto '1'
        option peerdns '0'
        option type 'bridge'
        option proto 'dhcp'
        option macaddr 'ee:09:6b:aa:d2:c8'

config rule6 'wan6_lookup'
        option mark '0x01/0x01'
        option lookup '1'

config route6 'wan6_unreachable'
        option type 'unreachable'
        option table '1'
        option target '::/0'
        option metric '65535'
        option gateway '::'
        option interface 'loopback'

config interface 'client'
        option type 'bridge'
        option macaddr 'ec:08:6b:aa:d2:c8'
        option proto 'dhcpv6'
        option reqprefix 'no'
        option igmp_snooping '0'
        option peerdns '1'
        option sourcefilter '0'
        list ifname 'bat0'

config interface 'bat0'
        option ifname 'bat0'
        option macaddr 'ec:08:6b:aa:d2:c8'
        option proto 'none'

config interface 'ibss_radio0'
        option mesh 'bat0'
        option proto 'batadv'
        option mtu '1528'

config interface 'mesh_wan'
        option auto '0'
        option ifname 'br-wan'
        option mesh 'bat0'
        option proto 'batadv'

config interface 'mesh_lan'
        option ifname 'eth0'
        option macaddr 'ee:09:6c:aa:d2:c8'
        option mesh 'bat0'
        option proto 'batadv'
        option auto '1'

config interface 'mesh_vpn'
        option ifname 'mesh-vpn'
        option mesh_no_rebroadcast '1'
        option macaddr 'ee:0c:6b:aa:d2:c8'
        option mesh 'bat0'
        option proto 'batadv'

config device 'local_node_dev'
        option macaddr '42:ca:ff:ee:ba:be'
        option ifname 'br-client'
        option name 'local-node'
        option type 'macvlan'

config interface 'local_node'
        option ifname 'local-node'
        option ipaddr '10.123.64.1'
        option ip6addr '2001:470:5168::1/128'
        option netmask '255.255.192.0'
        option proto 'static'

config route6 'local_node_route6'
        option target '2001:470:5168::/64'
        option gateway '::'
        option interface 'client'

@BobaFett … das mit dem tauschen von eth1 und eth0 is ein hack, die gelben ports sind en switch , der blaue halt nur einer - vertauschst du die beiden , kommt dein uplink an gelb und ist geswitcht (anstatt an blau) und an blau liegt dann (einsam) Freifunk … entgegen deiner Annahme hast du also weiter „beides“

das funktioniert, ist aber nicht schön und in vielen Fällen nicht updatefest, mit dem Effekt das man sein homenetz schnell ins Freifunk bläst, da dein uplink ja dann an dem Freifunkswitch hängt und das verdrehen von eth0/1 dann weg ist. Also durchaus Vorsicht angesagt.
(das mal als erstes Feedback ohne gennau auf deine config geschaut zu haben, vorschläge zu gluon macht man bei github bei gluon eben … )

Hallo zusammen!

Da ich nach dem gleichen Sachverhalt gesucht habe und dies eine der ersten Seiten ist wollte ich meine Lösung hier kurz Posten.

Ich habe auch einen TP-Link TL-WR841N und möchte diese Netzwerkports des Geräts dazu nutzen weitere Geräte anzuschließen die in das private Netz sollen. Das Freifunknetz soll nur noch über WLAN bereitgestellt werden.

Der TL-WR841N hat von der Logik her 2 Ethernet Interfaces.
Eth0, das die Verbindung zum Switch herstellt für die gelben Ports
Eth1, das blaue Interface
Sowie natürlich noch das Radio0-Interface (WLAN)

Da hier berechtigterweise der Einwand gegeben wurde, dass wenn man den Uplink an den Switch anschließt es zu einer Freigabe des vollständigen privaten Netzwerks kommen kann wenn die Einstellungen durch ein Update überschrieben werden habe ich eine alternative Variante gewählt.

Nachdem man sich per SSH mit dem Router verbunden hat kann per

uci show

die aktuelle Konfiguration ausgelesen werden.
Hierbei waren bei mir die beiden folgenden Zeilen vorhanden (nicht direkt aufeinander folgend)

network.client.ifname='bat0' 'eth0'
[...]
network.wan.ifname='eth1'

Mein Ziel war es, dass der Netzwerkswitch nicht länger dem virtuellen Interface „client“, sondern an dem Interface „wan“ zugeordent war.
Dazu habe ich die Konfiguration mit folgenden Befehlen angepasst:

uci del_list network.client.ifname='eth0'
uci add_list network.wan.ifname='eth0'

Die Änderungen werden hierbei noch nicht sofort aktiv. Es ist möglich das Ergebnis per

uci changes

und dann per

uci commit

zu übernehmen.
Nach der übernahme sollte ein „uci show“ die neue Konfiguration anzeigen.
Mit einem

/etc/init.d/network reload

wird diese dann aktiv.
In wie weit diese Änderungen ein Update überleben kann ich bisher nicht sagen jedoch kann das Private LAN weiterhin am blauen Netzwerkport angeschlossen bleiben. Sollte die Änderung also verloren gehen wären nur die Geräte, die an den gelben Netzwerkports angeschlossen sind, dann plötzlich im Freifunknetz statt im privaten LAN und das sollte dann vermutlich recht schnell auffallen.

In der Hoffnung, dass das anderen Personen die nach ähnlichen Informationen suchen hilft.

Viele Grüße,
bcz

2 Likes

Hallo bcz

Ich habe einen WR1043nd und habe da auch schon einiges rumprobiert aber funktioniert hat nichts.
Aktuelle Konfiguration

network.client.ifname=‚bat0‘ ‚eth1‘

network.wan.ifname=‚eth0‘

Wenn ich das richtig verstehe löscht man den Client :

uci del_list network.client.ifname=‚eth1‘

Und fügt eth1 zum wan hinzu:

uci add_list network.wan.ifname=‚eth1‘

Ist das so richtig? Ich hab das ganze für meinen 1043 geändert.

Gruß

Viele Wege führen nach Rom:

https://wiki.freifunk.net/Konsole#WAN_auf_allen_Netzwerkports

oder:

In der Datei:
/etc/config/network

nach dem Eintrag:
config interface 'wan’

suchen. Dort findet man den Unterpunkt:
option ifname 'eth0.$ZAHL$'

An der Stelle $ZAHL$ steht dann z.B. eine 2, das ist die VLAN ID des WAN Ports.

Dann geht man ein Stück hoch und sucht die Rubrik: config switch_vlan die im Unterpunkt option vlan ‚$ZAHL$‘ die gleiche Zahl aufweist und schreibt im Unterpunkt option ports ’ die LAN Ports hinzu, die direkt auf das lokale Netzwerk geleitet werden sollen.

So kann man jeden Port einzeln konfigurieren also z.B. Port 1+2 ins lokale Netz, Port 3+4 Freifunk Client LAN. Manchmal ist allerdings die Portnummerierung vertauscht 1 ist 4 2 ist 3 usw… Diese Einstellung ist sysupgradefest.

Nicht vergessen die Ports aus den anderen VLANs zu löschen!