Problem: TP-Link TL-WR1043N/ND v4 und D-Link DAP-2610

Hallo erstmal!

Ich hab im Wohnlager unserer Firma für die dort eingemieteten einen Freifunk-Router angeschafft (Konfig Standard, keine Experteneinstellungen angewandt). An dem TP-Link TL-WR1043N hängen zwei D-LINK DAP-2610 (da POE). Diese habe ich die wie folgt konfiguriert:

IP auf 10.10.9.5 bzw. .6
Subnet 255.255.0.0
Gateway und DNS auf 10.10.0.1

Als SSID analog zum TP-Link, auch unverschlüsselt.

Jetzt ist das Problem, dass über den TP-Link alles einwandfrei funktioniert, aber über die D-Link keine Internetverbindung möglich ist, bzw. nur kurz nach Neustart der Geräte. Sperrt die Freifunk Firmware die APs aus oder habe ich evtl was falsch konfiguriert?

Es handelt sich um folgenden Knoten: https://freifunk-ingolstadt.de/map/#!v:m;n:18d6c7514ca6

Vielen Dank schonmal für die Hilfe!

Moin und willkommen bei Freifunk,

bitte sorge bei der Installation dafür, dass man mit deinem 1043 auch meshen, kann z.B. indem du ihn in Fenster Nähe aufstellst.

Reiner Hotspotbetrieb ist unerwünscht.

Nun zum Problem.

Der DHCP Server auf den DAPs kann komplett deaktiviert und durch eine reine Fallback IP ersetzt werden.

Die DHCP IP Vergabe wird durch das jeweilige Freifunk Gateway erledigt und kann nicht statisch konfiguriert werden.

Der Router steht am Fenster zur Straße hin, ist für alle frei erreichbar. Mesh ist ebenso aktiviert und entsprechende Firmware drauf, möchte die Community ja damit unterstützen.

DHCP auf den DAPs ist deaktiviert. Es ist somit also die Vergabe der IP auf den DAPs das Problem? Wie erreiche ich die APs dann? Nur mehr über die Fallback IP, richtig?

1 Like

Genau.

Willst du mal auf die config Oberfläche musst du sie vom 1043 trennen.

Soll es auch im laufenden Betrieb gehen, muss ein vlan fähiger Switch davor.

Und ja die falsche DNS und Gateway Konfig ist das Problem. Du kannst zwar selbst IPs durch den DAP vergeben lassen musst jedoch sicher stellen das alles ans jeweilige Freifunk Gateway durchgereicht wird, daher meine Empfehlung DHCP auf den Kisten gleich ganz abzuschalten.

1 Like

Muss nicht sein, kann abgesteckt werden.

Danke dir! Werde es ausprobieren und berichten!

1 Like

Wie sind denn die denn verbunden untereiner, die DAPs an den TP-Link?
Wenn die „am gelben Port“ des TP-Link 104ers hängen, dann wäre es interessant, ob die Ports evtl. auf MoL stehen.

Die DAPs hängen an den gelben Ports, ja. Mesh over Lan ist deaktiviert… dachte das muss nur dann an, wenn APs mit Freifunkfirmware dran sind… Gehört das mit an?

Korrekt

Nein.

1 Like

Servus,

habs nun endlich malgeschafft das Problem anzugehen…
Habe aus den DAPs - wie Tarnatos geschrieben - die DNS und Gateway Config raus und es läuft.
Danke nochmal!

1 Like

Zu früh gefreut…

Problem besteht leider weiterhin. Die Leasetime ist ja auf 5 Minuten… komischerweise bekomme ich auch nach ziemlich genau der Zeit meine IP genommen und dann eben 169.254… WIe wenn es eben daran liegen würde, dass die Clients dann keine neue IPs mehr bekommen würden. Nachdem ich die DAPs ausstecke, geht es wieder für besagte 5 Minuten…

DHCP der DAPs ist definitiv aus. Bin mit meinem Latein langsam echt am Ende…

€: Wäre ggf. Ubiquiti UniFi AP AC Lite (UAP-AC-Lite) ab € 77,84 (2019) | Preisvergleich Geizhals Deutschland mit Freifunkfirmware die bessere Lösung?

Maybe.

Ich nehme immer gerne EAP110 bzw EAP245 (Achtung kein PoE Netzteil und 48V PoE) geht aber mit passiven PoE.

Die Lösung war leider eine ganz andere… Firmware gewechselt und siehe da… läuft.

Danke an alle!

Magst Du uns an der Lösung teilhaben lassen?

Was für eine Firmware hast Du gewechselt?
Also bei welchem Gerät? Beim WR1043 das Gluon?
Beim DAP2610 die StockFW?

Und welches war dann die „sinnvolle“ Zielfirmware?

1 Like

Jo… klar… iwie vor lauter schnell schnell die Details vergessen…

wurde beim WR1043 von v2016.2.7+21-l2tp / gluon-v2016.2.7 auf v2016.3.4 / gluon-v2016.2.4-1-gd452a7c gewechselt.
die DAPs laufen nach wie vor mit Stock, hier gibts (noch) keine openwrt fw.

Leider habe ich heute wieder den Anruf bekommen, dass es wieder nicht ging, erst nach Stecker ziehen der DAPs… Werde mir vorübergehend ggf. mit Zeitschaltuhr, die den Neustart der Hardware dann nachts provoziert behelfen.