Probleme beim Setup eines privaten WLANs

Hallo Freifunk Community.
Ich bin gerade dabei, mein Setup zu Hause etwas zu vereinfachen.
Deshalb habe ich mich gefreut zu sehen, dass ich auf einem FF Knoten auch eine private SSID aufspannend kann.
Ich verwende aktuell die Firmware von FFMUC.

cat /lib/gluon/release
v2023.11.5

lua -e ‚print(require(„platform_info“).get_model())‘
Netgear R6120

Ich bin deshalb nach dieser Beschreibung vorgegangen, um eine zusätzliche private SSID zu erstellen.

Meine Konfiguration sieht wie folgt aus:

wireless.radio0=wifi-device
wireless.radio0.type=‚mac80211‘
wireless.radio0.path=‚platform/10300000.wmac‘
wireless.radio0.htmode=‚HT20‘
wireless.radio0.country=‚DE‘
wireless.radio0.legacy_rates=‚0‘
wireless.radio0.band=‚2g‘
wireless.radio0.channel=‚6‘
wireless.radio1=wifi-device
wireless.radio1.type=‚mac80211‘
wireless.radio1.path=‚pci0000:00/0000:00:00.0/0000:01:00.0‘
wireless.radio1.htmode=‚VHT20‘
wireless.radio1.country=‚DE‘
wireless.radio1.band=‚5g‘
wireless.radio1.channel=‚44‘
wireless.mesh_radio0=wifi-iface
wireless.mesh_radio0.ifname=‚mesh0‘
wireless.mesh_radio0.network=‚mesh_radio0‘
wireless.mesh_radio0.device=‚radio0‘
wireless.mesh_radio0.mesh_fwding=‚0‘
wireless.mesh_radio0.mesh_id=‚ffmuc-welt-mesh‘
wireless.mesh_radio0.mcast_rate=‚12000‘
wireless.mesh_radio0.mode=‚mesh‘
wireless.mesh_radio0.disabled=‚0‘
wireless.mesh_radio0.macaddr=‚66:b6:fc:72:c2:29‘
wireless.mesh_radio1=wifi-iface
wireless.mesh_radio1.ifname=‚mesh1‘
wireless.mesh_radio1.network=‚mesh_radio1‘
wireless.mesh_radio1.device=‚radio1‘
wireless.mesh_radio1.mesh_fwding=‚0‘
wireless.mesh_radio1.mesh_id=‚ffmuc-welt-mesh‘
wireless.mesh_radio1.mcast_rate=‚12000‘
wireless.mesh_radio1.mode=‚mesh‘
wireless.mesh_radio1.disabled=‚0‘
wireless.mesh_radio1.macaddr=‚9e:c9:eb:4f:a7:91‘
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname=‚client0‘
wireless.client_radio0.network=‚client‘
wireless.client_radio0.disabled=‚0‘
wireless.client_radio0.device=‚radio0‘
wireless.client_radio0.mode=‚ap‘
wireless.client_radio0.macaddr=‚66:b6:fc:72:c2:28‘
wireless.client_radio0.ssid=‚Willkommen bei Freifunk München
wireless.client_radio1=wifi-iface
wireless.client_radio1.ifname=‚client1‘
wireless.client_radio1.network=‚client‘
wireless.client_radio1.disabled=‚0‘
wireless.client_radio1.device=‚radio1‘
wireless.client_radio1.mode=‚ap‘
wireless.client_radio1.macaddr=‚9c:c9:eb:4f:a7:91‘
wireless.client_radio1.ssid=‚Willkommen bei Freifunk München
wireless.wan_radio0=wifi-iface
wireless.wan_radio0.device=‚radio0‘
wireless.wan_radio0.mode=‚ap‘
wireless.wan_radio0.key=‚XXXX‘
wireless.wan_radio0.macaddr=‚66:b6:fc:72:c2:27‘
wireless.wan_radio0.network=‚wan‘
wireless.wan_radio0.encryption=‚psk2‘
wireless.wan_radio0.ssid=‚test-wlan‘
wireless.wan_radio0.disabled=‚0‘
wireless.wan_radio1=wifi-iface
wireless.wan_radio1.device=‚radio1‘
wireless.wan_radio1.mode=‚ap‘
wireless.wan_radio1.key=‚XXXX‘
wireless.wan_radio1.macaddr=‚9a:c9:eb:4f:a7:91‘
wireless.wan_radio1.network=‚wan‘
wireless.wan_radio1.encryption=‚psk2‘
wireless.wan_radio1.ssid=‚test-wlan‘
wireless.wan_radio1.disabled=‚0‘

Ich bekomme damit zumindest alle SSIDs online und auch die Mesh WLANs bleiben aktiv. Allerdings haben Clients, die sich mit dem „test-wlan“ verbinden keine Verbindung zum Internet.
Zudem war es mir nicht möglich, die 2,4 und 5 GHz Netze auf freiere Kanäle zu setzen (danach sind die Mesh WLANs nicht mehr aktiv).

Ist meine Konfiguration so korrekt?
Habe ich etwas übersehen?

Ich bin für jeden Input dankbar!

Hallo phaus,
hast du deine Einstellungen per ssh vorgenommen oder über den config Mode. Wenn ich es bis jetzt über den config Mode gemacht hab ging nie was schief. Bin in den konfigurationseinstellungen leider nicht so firm, würde also einen kleinen Fehler nicht finden. Kann nur sagen, dass es per config Mode normalerweise läuft :slight_smile:
Viele Grüße
Stefan

Abgesehen davon, das mich die ‚‚‚fancy quotes‘‘‘ extrem irritieren und das in der Anleitung auch so nicht steht… Kann das openwrt überhaupt verarbeiten?

Warum werden die vielen macaddr für die selben 2 interfaces definiert, was soll das bewirken?

Scho mal danke für die Antworten. Die „fancy quotes“ sind wohl durch die Formatierung im Forum entstanden. Die sind tatsächlich in der Config nicht vorhanden.
Die zusätzlichen Mac addresses waren ein Versuch, beide WLANs aktiviert zu bekommen. Ich hatte gelesen, dass dies bei >1 private WLANs wohl notwendig ist (ich muss den Link noch mal raussuchen).
Aber ich entnehme euren Antworten, dass das von der Konfiguration erstmal in Ordnung ausschaut?

1 Like

Mit [</>] kannst du auch Code einfügen. :wink:

Sieht soweit gut aus. SSID sind ja da wie du schriebst.
Bekommst du eine IP über das wan Interface?’ Ohne gluon soweit zu kennen, möglicherweise wird da noch etwas geblockt?

Also…
Ich habe mir jetzt mal einen „Netgear WAX220“ geleistet und mit der neuesten .next firmware und per Web UI, klappt nun alles mit den privaten WiFis.
Ich habe gerade auch das „iw“ CLI Tool entdeckt und kann damit auch Statistiken im internen WiFi sammeln. Sehr cool!

2 Likes