Probleme mit Webseite Freifunk Neuss

Hallo liebe Neusser,

ich war eben mal auf eurer Homepage, und mir ist aufgefallen, dass die Seite extrem unperformant in Firefox läuft. Das äußert sich z.B. dadurch, dass man nur relativ langsam scrollen kann, wenn ich scrolle warte ich knapp 1 Sekunde bis die Seite sich dann auch bewegt. Das läd leider nicht zum Durchsuchen des Angebots ein, und ein User der damit konfrontiert wird, wird die Seite schnell verlassen.

Das Problem mit unperformanten Seiten hängt meiner Vermutung nach mit der Animation im oberen Teil der Seite (mit den sich trennenden und vereinigenden Graphen) zusammen. Das Problem bei Firefox ist, dass solche Animationen ohne Hardwarebeschleunigung nur sehr langsam laufen (auch bei dem Graphen der Freifunkkarte regelmäßig zu sehen). In der Tat funktioniert es, wenn ich Hardwarebeschleunigung aktiviere.

Probleme hat daher vermutlich jeder, der entweder seine Grafikkartentreiber nicht richtig einrichtet (also vor allem Bürorechner?) oder ein Betriebssystem nutzt, wo Hardwarebeschleunigung standardmäßig deaktiviert ist (wie bei mir auf Linux).

Nur als Hinweis. Was ihr daraus macht, ist eure Sache.

Gruß
David

3 Likes

Hmm,

du bist ehrlich gesagt der erste, der dieses Problem äußert. Kannst du etwas zu deinem setup sagen? Welches OS, welcher FF?
Ich nutze selbst Firefox auf allen gängigen OS habe diese Probleme jedoch noch nicht beobachten können. (was natürlich nicht heißt, dass es nicht sein kann)

Daher meine Frage an alle anderen, die hier mal drüber fliegen.
geht mal bitte auf http://freifunk-neuss.de und schaut mal ob ihr ähnliche Performance Probleme beobachten könnt, wie @yayachiken.

Danke!

(PS: Ja die Karte funktioniert gerade nicht, ich hoffe @Florian bekommt es irgendwie hin)

Jap, ähnlich wenig responsiv, wie von @yayachiken beschrieben, also quasi nicht benutzbar.

Firefox 37.0.1 auf Ubuntu 14.04.1 LTS

Im Chromium auf dem gleichen Rechner gibt’s gar keine Probleme.

Kann ich nicht bestätigen:

Kann ich nicht bestätigen: Sitz aber auch grad an einer Höllenmaschine :wink:

Firefox 37.0.2.

Ist es die Kombi Firefox/Linux? Habe die Seite gerade auf einem Windows-Firefox, ca. 4 Jahre alter Rechner, probiert und et löppt.

Wie gesagt, es liegt am scrollen, definitiv nicht an den Ladezeiten im Netzwerk.

Setup ist ein Firefox 37.0.2 auf Arch Linux. Und wenn ich Hardwarebeschleunigung erzwinge verhält sich die Seite auch normal responsiv.

Um es nachzustellen könntet ihr ja mal versuchen, unter Einstellungen → Erweitert → Allgemein den Haken bei „Hardwarebeschleunigung verwenden, wenn verfügbar“ zu entfernen und den Firefox neu zu starten. Bin ziemlich sicher dass es an mangelnder HW-Beschleunigung auf meiner Maschine liegt.

Ist es die Kombi Firefox/Linux?

Auch, da hier die HW-Beschleunigung meistens per eingebauter Blacklist nicht aktiviert wird. Ist nur doof wenn man an einem Windowsrechner mit fehlerhaft eingerichteten Grafiktreibern vorbeikommt.

Ja, ist doch im ersten Post recht ausführlich erläutert.

Hat auch nix mit Ladezeiten oder so zu tun, sondern eben mit der Grafik-Animation.

Seltsam. Ich kann es hier mit der Kombi Ubuntu/FF 37.0.2 auch mit deaktivierter Hardwarebeschleunigung nicht reproduzieren. Verhält sich www.freifunk-brilon.net bei dir denn genau so? Und tritt das Problem schon länger auf oder erst seit kurzem?

ich hab keine Probleme (Win7/64 - Firefox 38), einzig, auf der Karte ist kein einziger Knoten.
Aber Performance, Scrolling, Ladegeschwindigkeit, etc.,sind bei mir völlig OK
Hab nichts entdeckt, was mies war (ausser die Gestaltung ;-))

Denke, diejenigen, die Probleme haben, sollten a) Firefox mal updaten und b) mal ein tracert laufen lassen, c) mal zu Windows wechseln :stuck_out_tongue:

ja, klappt genauso gut. Einziger Unterschied: hier sind Nodes auf der Karte, in Neuss ist keiner

damit hab ich Null Probleme

davon 0 im Rhein-Kreis-Neuss

aha, Karte ist also kein Fehler, wunder mich allerdings dann, dass es „Freifunk Neuss“ gibt ohne Knoten.

Geschmackssache… :wink:

Wie @Maltis bereits erwähnte, ist das Problem mit der Karte bekannt und in Arbeit. Liegt an einer anders aufgebauten nodes.json der neuen ffmap. Für Brilon/Möhne ist das (noch) nicht der Fall. Also bitte nicht an der Karte stören, sondern die Performance testen.
Sehe ich das richtig, dass außer @yayachiken niemand Probleme hat?