Router sind nicht auf der meshkarte [gelöst]

Jetzt gibt es den meshviewer (http://mesh.sjr-ol.de) ja schon eine ganze Weile, aber meine Router (loy-wope9 und loy-wope10) waren seit Anfang an nicht auf der Karte, obwohl sie zu dem Zeitpunk in Betrieb waren. Kann ich irgend etwas tun um das zu ändern?

Gruß, wope

hallo wope,

ich verstehe nicht genau was du meinst?
deine freifunk nodes sind im moment in betrieb?
werden aber nicht auf ihrgend einer karte angezeigt?

gib uns bitte ein paar infos
https://wiki.nordwest.freifunk.net/Störungsmeldung
an nordwest@lists.ffnw.de

gruß
pic

Hallo picard,
vielen Dank für deine Antwort.

Es geht nur über die beiden Router „loy-wope9“ und „loy-wope10“. Die Router sind am Netz und funktionieren.
Das Problem ist, dass sie nicht im Meshviewer angezeigt werden (Beispiel: Stadtjugendring Oldenburg e. V. – Zusammenschluss Oldenburger Jugendverbände ), und somit auch keine Entfernung zu den Nachbarknoten berechnet wird.
Die Koordinaten sind in Ordnung denn im Netmon sind sie richtig plaziert. Es ist also kein Problem des Netmon oder Freifunk allgemein, sondern nur des Meshviewers, bzw falsche Daten in meinen Routern. Ich habe auch schon die Koordinaten im Netmon neu gesetzt, hat aber auch nichts geändert.

Gruß, wope

Kannst du einmal per SSH auf den Router und schauen, ob die Koordinaten aus dem Netmon gezogen wurden?
Das wrird wahrscheinlich der Grund sein!

Hallo stefan6,

kannst du mir die Datei, den Befehl oder das Verzeichniss nennen, wo ich diese Info finde?
Wenn die Koordinaten nicht aus dem Netmon gezogen wurden, wie lasse ich ihn dann ziehen?

Gruß, wope

root@wurstwasserweb:~# uci show gluon-node-info.@location[0]
gluon-node-info.cfg02d91e=location
gluon-node-info.cfg02d91e.longitude=7.9360018648341
gluon-node-info.cfg02d91e.latitude=53.086058399010
gluon-node-info.cfg02d91e.share_location=1

sollten dort keine koordinaten ausgegeben werden und/oder
share_location=0 ausgegeben werden, dann werden keine positionsdaten per
alfred an meshviewer übermittelt. Mit

uci set gluon-node-info.@location[0].latitude=WERT
uci set gluon-node-info.@location[0].longitude=WERT
uci set gluon-node-info.@location[0].share_location=1

kannst du neue koordinaten eingeben. Anschließend:

uci commit gluon-node-info

um die änderungen zu übernehmen. Die automatische Übernahme der
Koordinaten aus Netmon war nur eine Quick’n’Dirty-Geschichte, die wir
übergangsweise in die aktuelle Firmware eingebaut hatten, um zügig die
Positionsdaten der alten Router einzustellen, die ihre Position
ausschließlich in Netmon gesetzt bekommen hatten.

Gruß,
Eike

1 Like

Wenn ich das richtig sehe, dann sind die Daten dort nicht wirklich auf aktuellem Stand (hint: es st der 26. August 2015)

Es nimmt mich daher nicht Wunder, dass dort mindestens „einige“ Knoten fehlen.

Hallo Eike,

vielen Dank für die Info, werde ich ausprobieren! Die Befehle zum Setzen der Koordinaten hatte ich schon gegoogelt, aber ich dachte die Daten kommen von Netmon.
Dann werden demnächst meine restlichen Router auch auf der Karte erscheinen.

Gruß, wope

bitte immer noch ignorieren!

Ich hatte vermutet, dass sich das geändert hat, da diese Karte jetzt prominent auf der Webseite (dem Norwest-Blog) verlinkt ist.

Das verwunderliche ist, die der Data Dump enthält die Korrekten Timestamps.

Weis jemand sowo der Meshviewer das Datum herbekommt?

Die Router Daten sind definitiv korrekt!

lange hat es gedauert :flushed: , aber jetzt ist auch das gefixed.

https://mesh.ffnw.de

1 Like