TP-Link CPE210 V1.1EU mit Berliner Firmware: hardware version not supported

Hallo,
ich habe mir einen neuen TP Link CPE210 V1.1 geholt und wollte die Berliner Firmware kathleen-0.3.0-cpe210-220-510-520-factory via eingebautem Firmware Upgrade flashen. Der Upload verlief ohne Probleme, dann aber die Fehlermeldung „hardware version not supported“ - mehrfachen checken, dass auf der Berliner Liste auch V1.1 dabei ist.

Dann die Original-Firmware (PharOS) auf 2.0 geupdated und alles nochmal: gleiches Ergebnis.
Hilfe, Tipps, Tricks? Braucht es nen neuen Biuld für die 1.1er Version oder bin ich nur zu doof (Einsteiger - allersester Freifunkkontakt) ?

Danke im voraus

Edit: Ich habe den Router nicht explizit vorher eingerichtet (also natürlich das setup, aber nicht als Repeater oder AP ect.)

Hallo,

ich kenne mich mit der berliner Firmware nicht aus, aber die CPE210 ist das einzige Modell von Tp-Link, wo die Firmware auch von der Ziffer nach dem Punkt abhängt.

Es gibt verschiedene Images für 1.0 und 1.1. Guck mal, ob die Berliner dafür ein separates Image haben.

Viele Grüße
Matthias

Hat deine 210 noch ein EU hinter dem V1.1?
Dann ist vielleicht das hier TP-Link CPE210/510 - #318 von adorfer und die Fußnote 5 in der Liste im Wiki hilfreich.

1 Like

Dann wäre es aber eine V1.1EU, und keine V1.1 (die hier gesucht wird).

1 Like

Ok ich habe grade nochmal nachgeschaut:

Modell: CPE210(EU) Version: 1.1
Ist dann höchstwahrscheinlich die so betitelte V1.1EU, war mir nicht bewusst, dass es da Unterschiede gibt.
Ich hab allerdings als Unwissender die verlinkete Erklärung (https://forum.freifunk.net/t/tp-link-cpe210-510/594/318) nicht zu 100% verstanden. Muss ich jetzt eine OpenWRT für V1.1EU draufspielen und dann „downgraden“ zu V1.1 (habe aber nur einen build für V1 gefunden)?
Und inwiefern unterscheidet sich OpenWRT von der Freifunk-Community-Firmware?
Und wenn in der Gluon-Tabelle nur V1 und v1.1 steht, heißt dass das V1.1EU nicht unterstütz wird nehme ich an. Gibt es irgendwie Möglichkeiten rauszufinden inwiefern da eine Version kommen wird oder eine Entwicklung zu initialisieren?
Falls es doch z.Z. möglich ist den CPE210 V1.1EU für Freifunk zu benutzen (ohne komplizierte Eingriffe in Hard- oder SOftware) wäre eine kurze Step-by-Step-Anleitung (erst 1, dann 2 und dann 3 flashen) wäre sehr hilfreich.

Danke

Müssen? Schwer zu sagen. Es gibt halt 2-3 verschiedene Wege, je nach Zählweise.
(oder noch mehr, die aber vermutlich wahlweise „over the top“ oder unpraktikabel für Dich sein werden. Nur damit jetzt niemand was von „aber JTAG-Adapter…“ oder „aber SPI-Chip tauschen“ schreibt.)

Wie im verlinkten Beitrag beschrieben:

Letzteres wird mit hoher Wahrscheinlichkeit auch mit der besagten Berliner Kathleen funktionieren.

Das kann so pauschal sicher nie beantworten und ist eher eine philosophische Frage danach „wie allumfassend ist Freifunk, wenn nach ‚was ist alles Freifunk und was nicht‘“ gefragt wird. Ich kann Dir zumindest versichern, dass es für einige Communities wie z.B. Gelsenkirchen nach wie vor keine Firmware für CPE210v1.1 (auch ohne „EU“) gibt. Aber das hängt da immer ganz vom Engagement der jeweiligen Community ab. Es gibt halt nicht „den Freifunk“. Freifunk ist sehr dezentral.
Ich würde vorschlagen, dass wir uns hier in der Diskussion auf die eingängliche Frage beschränken "für Berliner Freifunknetz mit ‚Katleen‘ (oder wie immer das da genau heisst).

Gerne

Habe nur einen build für V1 gefunden (https://wiki.openwrt.org/toh/start?dataflt%5BModel*%7E%5D=CPE210)

Ich hab bis jetzt nur Smartphones geflashed und keinen Plan was ne TFTP-Rescue ist und worauf ich achten muss, um mir nicht alles zu zerschießen. Irgendeine gute Referenz für Einsteiger?

EDIT: Habe das im Forum gefunden; https://forum.freifunk.net/t/router-recovery-tftp-pushbutton-und-ttl-serial-recovery/8691

gebrickt = ?

Ansonsten nehme ich mal an, dass hier eine solide Anleitung vorliegt. Irgendwelche letzten Tipps, bevor ich mich da ransetze?

Danke

Da hier keine Lösung war hab ich einfach mal probiert… mit Erfolg.

Folgender Ablauf:

Gerät: TP-Link v1.1 EU mit Firmware 1.3.3 drauf

Konnte keine Berliner Firmware flashen, wie oben beschrieben: „Hardware Version not supported“

Daher:

cd /tmp ; wget http: // 192.168.11.161:8888/kathleen-0.3.0-cpe210-220-510-520-sysupgrade.bin

  • und mit „force“ drübergebügelt:

sysupgrade -F -c -v ./kathleen-0.3.0-cpe210-220-510-520-sysupgrade.bin
Unsupported image (model not in support-list)
Image check ‚platform_check_image‘ failed but --force given - will update anyway!
Saving config files…
etc/config/dhcp
etc/config/dropbear
etc/config/firewall
etc/config/luci
[…]

Danach konnte ich via http: // 192.168.42.1/ auf den Router zugreifen und wollte zur Sicherheit nochnal die Firmware flashen, was noch immer nicht ging:

Das hochgeladene Firmware-Image hat ein nicht unterstütztes Format. Stellen Sie sicher dass Sie das generische Format für Ihre Platform gewählt haben.

Router Funktioniert jedoch - nach Tauschen der Ports (Netzwerk/Switch) wie den Einstellungen im Bild und durchgehen des EinrichtungsWizards.

Wäre schön wenn der Patch der oben verlinkten Quelle für die EU Version in die kommenden Firmware Releases mit einfließen würde.

2 Likes