TP-Link CPE210 v2 - Gluon Support


#81

genau, Gluon nimmt nichts auf, was nicht upstream ist - nur so vermeidet man “kuddelmuddel”


#82

Ich habe leider nur noch die V2 CPE210 Router und müsste die ASAP für ein Projekt nutzen…

Daher die Frage:
Von welchem Zeitraum muss ich ausgehen, bis der Patch “offiziell” im GLUON verfügbar ist?

Ich tue mich schwer, eine eigene “inoffizielle” Version mit dem Patch zu erstellen.


#83

Diese Frage wird Dir keiner offiziell beantworten können, wann das soweit ist.

Bis dahin wird man lediglich selber bauen müssen.
Ich denke, das durch das zusammenlegen der Projekte von Openwrt und LEDE es sowieso ein weilchen dauern wird.

Eine Firmware selber bauen und gleich (ohne vorherige Tests und Überwachung) in eine bestehende community rein zu bringen kann mitunter auch eventuell Probleme bereiten.
Je nach dem, wieviel Erfahrung und know how man selbst hat, die Admins der community Fragen ob sie helfen können.
Vielleicht wird schon getestet und es gibt experimentelle Versionen…


#84

Ich glaube die Anleitung von @coco haben ist nicht so schwer. Willst du es einfach mal probieren? Ggfs. helfen wir dir.

Hast du die site.conf von eurer Community?


#85

Copy & Paste - war echt easy :wink:


#86

Hier die Site.conf

Ist gerade erst auf die 2017.1.5 umgestellt worden und wir testen die FW, um sie dann bald auszurollen.


#87

Nach der Zeile "git am cpe210v2.patch"
bekomme ich folgende Fehlermeldung :frowning:

warning: squelched 78 whitespace errors
warning: 83 lines add whitespace errors.

Und nach "make -j6 GLUON_BRANCH=experimental GLUON_TARGET=ar71xx-generic V=s"
wirft es diese Fehlermeldung (wohl Folgefehler) :frowning:

make[1]: Leaving directory `/Freifunk/gluon/lede’
Configuration failed:

  • unable to enable package ‘gluon-config-mode-autoupdater’
  • unable to enable package ‘gluon-config-mode-contact-info’
  • unable to enable package ‘gluon-config-mode-core’
  • unable to enable package ‘gluon-config-mode-geo-location’
  • unable to enable package ‘gluon-config-mode-hostname’
  • unable to enable package ‘gluon-config-mode-mesh-vpn’
  • unable to enable package ‘gluon-web-admin’
  • unable to enable package ‘gluon-web-autoupdater’
  • unable to enable package ‘gluon-web-network’
  • unable to enable package ‘gluon-web-wifi-config’
  • unable to enable package ‘gluon-web-node-role’
  • unable to enable package 'gluon-web-private-wifi’
    make: *** [config] Error 1

#88

Hallo,

die “normale” (tiny und gereric) FW wird aber korrekt erstellt?


#89

ja, die habe ich auch schon erfolgreich auf Router geflasht.


#90

(Intakte Build-Umgebung vorausgesetzt!)
Im Gluon Verzeichnis folgendes ausführen (Anleitung von @coco)

git clone https://github.com/freifunk-alpha-centauri/site-ffac.git

wget https://github.com/FreifunkVogtland/gluon/commit/ffa5a6526f319a43fbe9d0c7721e3c7b87d43dac.patch5 -O cpe210v2.patch

git am cpe210v2.patch

make update

make GLUON_TARGET=ar71xx-generic


#91

nee, läuft nicht. Kommt der beschriebene Fehler aus dem Patch.


#92

Kann dir da als Raubkopierer (copy&paste) bei der Diagnose nicht weiterhelfen…
zumindest mit Gluon 2017.1.4 war das kein Problem
=> https://map.freifunk-moehne.de/biggesee/#!v:m;n:704f57658c0e


#93

Vllt. passt der Patch nicht exakt zu der LEDE-Version. Ich würde einfach warten, bis der Patch fertig ist.


#94

Der Patch funktioniert mit der 2017.1.5 nicht mehr. Also wenn mit dem Patch, dann die 2017.1.4 bauen.


#95

Oh, das ist doch mal ne Info. Auch wenn nicht positiv :frowning:
Danke!

Update:
Ich habe das Ganze auch unter 1.4 probiert. Gleiche Fehler.


#96

Wird der Patch auch die CPE510v2 beinhalten?


#97

Vielleicht kann man die bei OpenWrt eingereichten (überarbeiteten) Patches nehmen?


#98

Hey,
ich habe mit dem weiter oben verlinkten patch Gluon v2017.1.4 und v2017.1.5 gebaut.

Die zusammengefasste Warnung zu “whitespace errors” sollte kein Problem sein. Ich habe die wenigstens ignoriert und auf eingefügte Leerzeilen im Quelltext geschoben. Siehe auch: https://stackoverflow.com/questions/12396622/what-does-1-line-adds-whitespace-errors-mean-when-applying-a-patch#12396793

Warum nutzt du “make” mit “Parallel Execution” also die Option “-j6”? Was bedeutet “V=s”?

Hast du alle Abhängigkeiten installiert? https://gluon.readthedocs.io/en/v2017.1.5/user/getting_started.html#dependencies


#99

Hi.

a)
ich habe eine komplett lauffähige 1.4 und 1.5 GLUON gebaut und laufen. D.h. ohne Patch läuft es. Die Abhängigkeiten habe ich beachtet und auch die site.* Dateien auf 1.5 angepasst.
Da habe ich dann den Patch eingespielt und es gab in beiden den o.g. Fehler. Es wurde kein Firmware Output erzeugt. Keine Ahnung warum :frowning:

b)
Zu V=s warum ich das nutze:
Für bessere Fehlerausgaben beim compilen.
“the V=s option is meant to provide more verbose information for troubleshooting purposes when building the OpenWRT firmware”

Zu -j6:
Damit kann ich schneller compilen, weil die Kerne des Prozessor durch parallele Nutzung besser ausgelastet werden.
“The -j option is only use to speed up application build, it determines how many jobs make can spawn for the build. You can either set -j or even higher -j<nb-core * 1.5> so that compilation can happen in parallel.”


#100

V=s sollte aber nicht mit -j6 genutzt werden. Sonst gibt es zu ungenaue Fehlermeldungen.