TP-LINK TL-WA860RE Lan Anschluss ?

Hallo wenn ich den TP-LINK TL-WA860RE auf Freifunk umstelle kann ich
A mein Lankabel vom Router Einstecken um eine verbindung ins Internet zu Realieren wie über den WanPort bei den üblichen Geräten ?
B Kann ich aus dem Port Freifunk Lan rausholen wie bei den Gelben ports bei 841er z.b.
C oder ist das nur ein Repeater im Mesh wo die Gelbe Dose ein Zugang für Firmware ist

lg

Wenn man das auf der Kommandozeile einstellt, geht alles.

In der Weboberfläche geht nur Mesch oder VPN-Uplink bei den Geräten mit nur einem Port.

Grüße
Matthias

Ok,
Ich flashe das ding denn wenn ich Zeit finde,dann
muss ich sehen wie ich den SSH aktiviere,
dann muss ich noch die IP des teils rausfunden wenn es im Mesh ist ;/
Dann die befehle zum einrichtren über SSH :slight_smile:

Hat da Jemant noch einen Beitrag mal geschireben?
Damit ich mich daas ersrtmal dransetzen kann ?

der rest wird nicht so das große Problenm sein Linux ist nicht so schwer wenn man viele Raspberrys Hat und noch einen VPS hat der in Frankfurt steht :slight_smile:

Vielleicht hilft dir das hier:

@brenner231, du musst das eth0 in das br-client tun und aus dem br-wan rausnehmen. Das geht in der /etc/config/network.

Probier das mal und kopiere deinen Versuch hier rein. Dann helfe ich dir, wenn es nicht klappt. Ist aber eigentlich relativ intuitiv.

Zwischenfrage:
Kann man auch Nano instalieren auf den Tp Link? oder ist es zu groß ? Welcher paketmnanger ist drauf ? Ich bin Apt-get gewohnt .-)
und Vi ist für mich ein schwerer Editor, beforzuge eher den Nano

lg

Hallo, auf den Geräten ist aufgrund von Speichermangel meist nur vi installiert und wenn ein Paketmanager drauf ist dann wohl opkg.

Ich kann dir http://netz10.de/2009/04/28/vi-crashkurs-fur-einsteiger/ empfehlen die wichtigsten Befehle sind dort erklärt.

Hier isrt mal das Original !
Ich mach mal kleine Beschriftungen dran :slight_smile:

Mein versuch wäre:

Im Teil 3,9 was zu ändern ?
ich denke ich probiers mal :slight_smile:
Bin aber auch glückliche wenn C+P vorlage wa wäre mit dem Teil abschitt :-):hushed:

lg

Diese habe ich verändert und keine funktion, das über den Lan nun auch internet rauskommt …

Verändert :

config interface ‚wan‘

option ifname ‚eth0‘

    option ifname ''
    option multicast_querier '0'
    option peerdns '0'
    option auto '1'
    option type 'bridge'
    option proto 'dhcp'
    option macaddr 'f6:ea:b1:4e:2a:08'

config device ‚local_node_dev‘
option macaddr ‚16:41:95:40:f7:dc‘

option ifname ‚br-client‘

    option ifname 'eth0'
    option name 'local-node'
    option type 'macvlan'

gespeichert:
reboot:

ok die Fett dargestellten sind 2mal Raute… ( Ffinde keine Code Formatierung hier)

Hallo.

Zuerst WAN abklemmen:

Teil 4
config interface 'wan’
option ifname 'eth0’
option multicast_querier '0’
option peerdns '0’
option auto '0’
option type 'bridge’
option proto 'dhcp’
option macaddr ‘f6:ea:b1:4e:2a:08’

Dann eth0 in die bridge mit bat0 hängen und aktivieren:

Teil 9
config interface 'client’
option type 'bridge’
option auto '1’
option macaddr '30:b5:c2:29:45:39’
list ifname 'bat0’
list ifname 'eth0’
option proto 'dhcpv6’
option reqprefix 'no’
option robustness '3’
option query_interval '2000’
option query_response_interval '500’
option peerdns '1’
option sourcefilter ‘0’

Das sollte es eigentlich schon gewesen sein.
Abspeichern & reboot nicht vergessen.

mfg
Christian

1 Like

wie aktiviere ich das ???
oder muss ich nich irentwo, wo Bat0 ist was setzen ?

ich probier mal wie weit ich komme …

lg

Ich habe dir die Tele schon entsprechend angepasst. Auf die Schnelle das „changelog“:

In Teil 4 ändern:
option auto '0’

In Teil 9 hinzufügen:
option auto '1’
list ifname 'eth0’

mfg
Christian

1 Like

Funktioniert,
nun sollte ich mir noch eine Shell Datei schreiben das ich einfach nur aus 2 Configs wählen kann,
Wenn ich dann mal doch wieder den router anschließen will um diesen Knoten dann direkt zu versorgen !

Warum denkt keiner an diese kleinigkeit oder reichen die Kliobytes dafür nicht aus ? :slight_smile:
Und wäre nicht eine autmatische erkennung möglich , wenn Internet vorhanden an Eth0 dann normal mode wenn ein Netzwerk endgerät drann hängt dann Lan als ausgang für … und das den bei einstöpseln ?

root@Knoten:~# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 448.0K 236.0K 212.0K 53% /
/dev/root 2.3M 2.3M 0 100% /rom
tmpfs 13.8M 100.0K 13.7M 1% /tmp
/dev/mtdblock3 448.0K 236.0K 212.0K 53% /overlay
overlayfs:/overlay 448.0K 236.0K 212.0K 53% /
tmpfs 512.0K 0 512.0K 0% /dev

lg