TP-Link TL-WDR3600 nur auf einem Band aktiv?

Hallo. Gibt es in der Freifunk Firmware bei einem Dualband Router (im angefragten Fall den WDR3600, dürfte bei anderen Geräten aber ähnlich sein) die Möglichkeit das WLan nur auf einem Band zu aktivieren? Oder geht über den Schalter hinten an der Rückseite nur Beides An / Beides Aus ?

1 Like

Über ssh können einzelne Bänder oder SSIDs abgeschaltet werden.

Um die Frage des Betreffs zu beantworten: Nein, wenn der Router nur auf einem Band funkt und nicht weiter daran herumgespielt wurde, dann ist er schlicht defekt. Hört sich nach einem Hardwareschaden an.
(Wie man es künstlich herstellen kann hat @apo ja schon verlinkt. Das setzt aber voraus, dass das NACH dem Flashen der Firmware getan wurde von jemanden, der weiss wie es geht. Und wenn das nicht vorgenommen wurde, dann wird es sich mit einiger Sicherheit um einen Gerätedefekt handeln.)

Wie das jetzt ausschaut, ob Du das noch unter Herstellergarantie reklamiert bekommst, das könnte evtl. spannend werden.
Denn rein formal erlöscht die Herstellergarantie nach Flashen einer Fremdfirmware.
(Dass die gesetzliche Gewährleistung gegenüber dem Verkäufer besteht: Unbenommen. Wenn man innerhalb der ersten 6 Monate nach dem Kauf ist, dann sollte man die zu nutzen versuchen.)

Nichts desto trotz würde ich versuchen, erstmal das Stock-Image („Werksfirmware“) wieder einzuspielen vor dem Einsenden in den Service.
(Obacht, das Image muss „gestript“ werden, also der erste Datenblock muss entfernt werden. Anleitung siehe openwrt-wiki. Da gibt es auch Downloadlinks für Leute, die das nicht mit dd&co machen möchten.)

1 Like

Hallo Jensi,
der Schalter auf der Rückseite schaltet WLAN komplett an/aus.
Um wifimesh und/oder SID nur auf einem Band zu schalten, musst du dich per ssh auf dem Router einloggen.
Dort musst du die
/etc/config/wireless
editieren.

config wifi-device ‚radio0‘
option type ‚mac80211‘
option hwmode ‚11g‘
option path ‚platform/ar934x_wmac‘
option channel ‚3‘
option htmode ‚HT40+‘
option country ‚DE‘

config wifi-device ‚radio1‘
option type ‚mac80211‘
option hwmode ‚11a‘
option path ‚pci0000:00/0000:00:00.0‘
option channel ‚44‘
option htmode ‚HT40+‘
option country ‚DE‘

config wifi-iface ‚client_radio0‘
option network ‚client‘
option device ‚radio0‘
option mode ‚ap‘
option macaddr ‚16:ce:21:2b:90:95‘
option ssid ‚Freifunk‘

config wifi-iface ‚mesh_radio0‘
option disabled ‚1‘
option mcast_rate ‚12000‘
option network ‚mesh_radio0‘
option macaddr ‚16:cf:21:2b:90:95‘
option device ‚radio0‘
option mode ‚adhoc‘
option bssid ‚32:CA:FF:EE:BA:BE‘
option ssid ‚wifimesh-rheinufer‘

config wifi-iface ‚client_radio1‘
option disabled ‚1‘
option network ‚client‘
option device ‚radio1‘
option mode ‚ap‘
option macaddr ‚16:ce:22:2b:90:95‘
option ssid ‚Freifunk (5GHz)‘

config wifi-iface ‚mesh_radio1‘
option mcast_rate ‚12000‘
option network ‚mesh_radio1‘
option macaddr ‚16:cf:22:2b:90:95‘
option device ‚radio1‘
option mode ‚adhoc‘
option bssid ‚02:44:CA:FF:EE:EE‘
option ssid ‚wifimesh-rheinufer5‘

Das oben ist ein Beispiel von einem WDR4300. Da habe ich mit

option disabled ‚1‘

Freifunk (5GHz) und wifimesh-rheinufer ausgeschaltet.
Anschließend noch das Kommando

wifi

und der Router läuft damit bei wifimesh auf 5 GHz und bietet die SID Freifunk bei 2,4 GHz.