Tp-Link TL-WR1043v3 TFTP Recovery


#10

Gebe ich die Befehle in der cmd aus? Ich bräuchte das ausführlicher
Ich habe versucht mit der stripped bin von Hamburg FF vom Bootloader aus zu flashen, ging nicht.
Habs dann im Freifunk Config versucht zu flashen (mit der gestripped bin bei Firmware aktualisieren), jetzt geht eben nix mehr.


#11

In den von mir oben verlinkten Anleitungen ist doch alles Schritt für Schritt erklärt.

An welcher Stelle hakt es denn nun? Bitte beschreibe dein derzeitiges Problem etwas ausführlicher, sonst können wir dir nicht helfen.

Ansonsten wende dich bitte direkt an die Hamburger Freifunk Community unter: Kontakt – hamburg.freifunk.net


#12

Es liegt am Punkt 5, wo gebe ich die ganzen Befehle ein? Cmd?
Die Frage ist aber auch, ob die stripped WR1043nd wirklich zum flashen hergenommen werden kann von Freifunk Hamburg.


#13

Benenne mal bitte das Image in wr1043v3_tp_recovery.bin um und versuche erneut dein TFTP Recovery.


#14

Genau so habe ich es auch umbenannt


#15

Und ging nicht?

202020202


#16

Nichts geht , leider


#17

Nach einem kurzen Chat kam raus, dass Freifunk3r kein Linux einsetzt, daher konnte die oben verlinkte Anleitung nicht funktionieren.

Aus Zeitmangel konnten wir nicht weiter an der Problemlösung arbeiten.

@heini66
Schöne Anleitung! Wenn du sie noch um eine Passage ergänzt wie man seine LAN If Bezeichnung herausbekommt ist sie fast DAU sicher.


#18

Wenn Du eine stripped benutzt, dann wird es NICHT gehen. Egal von wem die ist.

Man braucht dafür kein Linux, das macht es -zumindest bei CPE210 und 1043&Co auch (vom Timing) nur schwieriger.
Deine initial verlinkte Anleitung ist auch für Windows vollkommen ausreichend, selbst für “harte” Fälle.


#19

Nun ja aber hier ist ja noch unklar, wie das IMG heißen muss, daher der Weg über tcpdump.


#20

Ihr benutzt doch das TFTP32/64 von Ph.Jounin, oder? Dort auf den “Log viewer”-Reiter gehen und schauen, was gefordert wird.

So als Beispiel:


#21

Das wusste ich nicht!

Guter Tipp danke!!


#22

Im Dateinamen feht ein “n”: wr1043nv3_tp_recovery.bin muß es sein.


#23

So, hab den Router tatsächlich zurücksetzen können, im Bootloader stand, dass der Router die Datei wr1043v3_tp_recovery.bin ohne N im
Namen wollte, habe die offizielle Firmware von Tp link genommen.
Somit ist das erledigt.
Vielen Dank an Alle! :smile:


#24

Ich melde mich nach längerer Zeit wieder, ich möchte von einer WR 1043nd V3 mit einer aktuellen Freifunk Firmware, wieder zurück zu Stock TP LINK Firmware.
Ich habe dies wieder mit TFT Methode ausprobiert, der Log Viewer spuckt mir das hier aus:
Bild im Anhang
Firmware ist die hier: http://static.tp-link.com/res/down/soft/TL-WR1043ND_V3_150514.zip


#25

Der Router will die wr1043v3_tp_recovery.bin abrufen, das schlägt jedoch fehl. Hast du die Firmware entsprechend umbenannt und in das passende Verzeichnis gelegt?


#26

Das habe ich eigentlich ja auch gemacht.
Bild im Anhang.Problem%202


#27

Das ist dann nicht das verzeichnis in dem der Server das File sucht.
Wo das directory ist: Schau mal in den Teil des Bildes, den Du oben rechts weggeschnitten (und nicht gepostet) hast, da gibt es ein “show dir” etc gebem-

grafik

(Unter “Browse” kannst Du das ggf auch ändern)

p.S. der Fehler ist vermutlich ein anderer: Du hast die Datei “wr1043v3_tp_recovery.bin.bin” genannt. Denn Dein Explorer “blendet bekannte Dateinamenerweiterungen” aus…


#28

Achso, garnicht drauf geschaut. (Falsches Verzeichnis)
Adorfer hat mir wieder mal den Tag gerettet, vielen Dank :slight_smile:
Fix wieder zurückgeflasht ohne Probleme.


#29

Du hast die Datei versehentlich im Startmenü abgelegt :wink: Schön, dass es geklappt hat :slight_smile: