TP-Link WR940N V5.0


#1

kamen heute rein - Verpackung zeigte V5.0 - Herstellerfirmware unter Upgrade die Version V4/V5
Liess sich problemlos mit V4 factory Firmware flashen.


Welchen Router fĂĽr Freifunk
#2

hab gerade auch ne V5 mit V4 Firmware geflashed …---------> funktioniert.


#3

geht das nur via Pushbutton-TFTP oder auch per Stockfw-Webinterface “mit der falschen”?


#4

einfach im web interface des V5 routers (orginal firmware) die V4 firmware auswählen und instalieren. danach startet der router wie immer in die Freifunkanmelde Oberfläche.


#5

Habe ja gesehen dass einige auf den WR940N v5 einfach ne v4-Firmware geflashed haben, hab aber irgendwie bisschen Schiss davor…
WeiĂź jemand ob da was schief gehen kann und ich mir so den Router zerschieĂźen kann oder ob das alles sicher ist?


#6
  1. Laut OpenWRT-Wiki wird das empfohlen:

WR 940 v5.x: LEDE (use WR940N V4 image)

  1. Selbst wenn es nicht klappt, wird der Router in der Regel nicht beschädigt. De-bricking über TFTP ist nicht schwer, dazu gibt es diverse Anleitungen.

#7

Oh cool, danke!


#8

Ich hab mir fĂĽr Regensburg Freifunk auch einen WR940N v5 gekauft. Unter Firmware Updates steht jetzt: 3.17.1 Build 161010 Rel.36018n
WR940N v4/v5 00000000

installiere ich dann das Freifunk Image:

https://regensburg.freifunk.net/uploads/tx_freifunkregensburg/firmware/stable//factory/ffrgb-tp-link-tl-wr940n-v4-v2018.1.1.bin

dann kommt die Fehlermeldung:

Error Code 18005

Upgrade unsuccesssfully because the version of the upgrade file was incorrect. Please check the file name.
ich hab den Pfad verkĂĽrzt auf C:\temp\ Die Datei hab ich als factory.bin und als image.bin umbenannt.

alles kein Erfolg. Hilfe. Was muss ich tun?


WR940Nv5 mit image fĂĽr 940v4 via TFTP flashen ("Freifunk flashen fehlgeschlagen")
#9

Mangels Gerät kann ich nur orakeln.

Aber da es vorher klappte hat die Fw einfach eine Versionserkennung.

Wenn das so ist und noch v4=v5 fĂĽr die HW gilt ist das nur ein kleiner Gluon Patch, damit es wieder Images dafĂĽr gibt.


#10

hm, interessant, denn an mehreren Stellen wird berichtet, dass das v4 image richtig sei.
u.a. dort:
https://openwrt.org/toh/tp-link/tl-wr940n


#11

Bezieht sich der Tipp nicht (nur?) auf Pushbutton-TFTP?


#12

ich hab nun bisschen rumprobiert. Das Image v4 von Freifunk Nord hat geklappt…
Allerdings ist das irgendwie sehr langsam (ich bin am anderen Ende in Bayern…)

Das FF Nord Image hat geheissen: gluon-ffnord-2016.2.7.1-tp-link-tl-wr940n-v4.bin

Das Regensburger Image das nicht ging: ffrgb-tp-link-tl-wr940n-v4-v2018.1.1.bin

Beide Dateien sind gleich groĂź

Also irgendwas stimmt mit dem Regensburger Image nicht…


#13

Nord ist (zu)groĂź daher derzeit unperformant, aber das ist ein anderes Thema.

Aufgrund der OOM Problematik auf 4/32 Geräten nutzen wir noch Gluon 2016.2.x welches auf Openwrt basiert.

Du darfst unsere Fw gerne nutzen bis deine Community das Problem gelöst hat, aber bitte ohne Koordinaten und bitte informiere deine Community.

Ab 2017 ist es LEDE vermutlich ist da die HWID Interpretation anders.

@rotanid kann dazu vielleicht mehr sagen.


#14

vielen Dank.

Frage: könnte ich vom Freifunk Nord image direkt zum Freifunk Regensburg image wechseln? wenn ja wie geht das? Vielleicht kommt da keine Fehlermeldung? oder ist das zu riskant?


#15

Probiere es aber setze in jedem Fall den Haken bei Einstellungen nicht beibehalten.

Das Update machst du ĂĽber das Web Interface. Also Reset Button gedrĂĽckt halten bis der Router neu startet LAN Kabel dran und 192.168.1.1 aufrufen. Update ist unter Experteneinstellungen zu finden.


#16

muss ich da eine Sysupdate einspielen, oder das normale Image?


#17

Sysupgrade


#18

Hat Funktioniert. Jetzt gehts. Also an alle. Erst mal eine altes Image installieren von Freifunk Nord (v4) und dann über Sysupdate das von Regensburg installieren…

komisch


#19

schön,deutet aber auf ein Problem mit dem Regensburger Factory Image “ffrgb-tp-link-tl-wr940n-v4-v2018.1.1.bin” hin.
oder generell ein Problem mit neueren Gluon-Versionen für das Gerät.