Verständnisfrage FF-Einrichtung: "Router unter 192.168.1.1 nicht erreichbar"

Ich habe soeben meinen Router ausgepackt und nach Anleitung soweit eingerichtet. Es handelt sich um einen WDR4300.

Image: http://images.freifunk-ruhrgebiet.de/stable/factory/
Erster Aufruf (alte TP-Software): http://admin:admin@192.168.2.1
Flash erfolgreich: ja
Neustart, dann zweiter Aufruf: http://192.168.1.1

Soweit kann ich 192.168.1.1 erreichen:
root@host:~# ifconfig br0:0 192.168.1.2 up

Das klappte, bis ich die Daten eingegeben habe. Dannach geht zwar das Geraet an, ist aber weder ueber Ping noch ueber HTTP erreichbar. Den LAN-Stecker habe ich bereits auf die blaue „DSL-Buchse“ umgesteckt, kein Unterschied!

Bitte hilft mir weiter. Mein normaler Internet-Router ist ueber ein anderes Netzwerk (192.168.2.0) erreichbar, somit keine Konflikte, puh!

Was mache ich hier falsch?

Hört sich erst mal ok ein. Wenn du über das Luci FF Interface den Hostnamen, Mash usw. konfiguriert hast bootet der Router und möchte sich mit dem VPN verbinden.
Du hast gleichzeitig eine Aufforderung in deinem Browser erhalten mit dem Pub. Key und dem Namen den du auf der Website eingeben sollst. RICHTIG?
Wenn der Router gebootet hat wartet er auf die Verbindung und ist nicht mehr über 192.168.1.1 erreichbar.
Wenn du deine Netzwerkschnittstelle auf DHCP stellst siehst du erst mal eine IPv6 (über RADVD/dhcpv6) verteilte lokale IP. Erst wenn der Router ein VPN aufbauen konnte bekommst du eine IPv4 und IPv6 IP über die du ins Internet gelangst.

Falls du was „verkehrt“ gemacht hast oder etwas an den Einstellungen ändern möchtest kannste den reset Button solange gedrückt halten bis das Gerät Bootet. Dann ist es auch wieder über 192.168.1.1 erreichbar (bis zum nächsten Boot)

Gruß
Thomas

Hallo,

erstmal danke fuer den Hinweis wegen VPN (ja, ich hatte es nach kurzem Zoegern aktiviert). Leider habe ich 0 IPv6 im LAN, nur IPv4.

Ist das mit dem Image schlimm? Soll ich besser das Rheinufer-Image drauf tun oder Ruhrgebiet behalten?

Hallo Roland,

nein ich denke das sollte erst mal kein Problem sein.
Man muss denke ich heute erstmal von IPv4 only Internet bei den Clientbetreibern ausgehen (leider :frowning: ) entsprechend sollte das gehen.

Siehst du den deinen Router bereits in der MAP Liste?
http://map.freifunk-ruhrgebiet.de/list.html

Gruß
Thomas

Roland schau mal bitte, das der Router über Port 10040/UDP ins Internet kommt. Möglicherweise blockt da irgendwas (dein Router)
Ich hatte da nämlich das gleiche Problem :smiley:

Ich hab das was du schreibst gemacht, Neustart ging, die Seite wo ich die Daten eingeben kann kam, VPN-Uplink aus, speichern → Neustart. Und wieder nicht erreichbar, egal ob ich den blauen Anschluss oder einen von den gelben nehme … :cry:

Du must den WAN Port benutzen. Bei meinem 841 ND ist der Blau :frowning:

Siehst du den Router den in der Map?
Manchmal klappt das mit dem Flachen auch nicht sauber.
Sonst roboote den noch mal in den Maintainance Mode. Dann klickst auf Expert Mode auf der Website und dann gibts da nen Punkt „Neue Firmware einspielen“ oder so.
Routenkonfiguration löschen (haken wegmachen). WICHTIG!

Anschließend Booted der Router.

Aber noch mal für die Verständnis. Du nimmst ein Kabel damit verbindest du den WAN Port mit deinem Internet Router und ein zweites Kabel für deinen PC (NON WAN Port) (oder optional WLAN)

Gruß
Thomas

1 Like

Der Router will nach einem „haendischen“ Neustart immer noch nicht starten. Kurz kamen pings durch, danach aber nicht mehr. Die WLAN-Lampen sind beide am flackern, vermutlich etwas Traffic. Weiterhin aber das bestehende Symptom.

Mit „haendisch“ neustarten meine ich, dass ich den Ein-/Aus-Knopf druecken muss, etwas warten muss und dann wieder einschalten muss.

Soll ich mal das Image hier von ausprobieren?

Ne lass mal . Das Image ist ok. Wie gerade am Telefon besprochen.

Schau mal das du dich per Ethernet an den Router anbindest und ob du eine IPv4 Adresse bekommst.
Das du bei dir IPv6 disabled hast ist wohl der Fehleranalyse nicht wirklich hilfreich.
„Use more IPv6“ :slight_smile:

Gruß
Thomas

1 Like

Ich habe mal einen neuen Namen eingetragen:

Name: FF-KR-GLADBACHER-STR02
Public-Key: 472d77354e1b5bfb1c9de24c93bee32919d5258358b195e024b8b516cad4b1ae
MAC: E8:94:F6:F3:25:80

Kann den wer erreichen? Der Router steht im 3. Stock in meiner Wohnung in der Naehe der kleinen Ampel beim ehemaligen Natalie-Imbiss.

Ich glaube, mein Router kann kein IPv6. Das sollte mal bei euch gefixt werden, dass Freifunk auch in einem IPv4-Netz klarkommt und jeden dazu zwingt, IPv6 aktiviert zu haben.

Ne der ist in der MAP nicht zu sehen.

Biste sicher, das du die richtige MAC genommen hast?
Im Zweifel roboote den in den Maintainance Mode vergebe im Expert Mode ein Password und schaue fix per SSH (im Export Mode) drauf.

Es gibt unterschiedliche Interfaces fürs WAN und ich bin nicht sicher welches davon er für die Kommunikation in Richtung der FF Gateways benutzt.

Bei mir sehe ich bat0, br-client, br-wan, eth0, eth1, local-node, mash-vpn, … und noch ein paar andere.

Nicht das dir noch eine Mac Adresse in deinem MAC Filter fehlt :frowning:
Mach den doch mal temporär komplett aus. Dann siehst ja ob sich der Router verbindet (in der Karte)

Gruß
Thomas

1 Like

Ach, ich Ochse hab die MAC des WLAN eingetragen … Kopf->Tisch …

1 Like

Wenn in Deiner Nähe keine Freifunk Router sind mit denen Du meshen kannst, dann MUSS zwingend VPN Mesh aktiviert sein!

Der gesamte Verbindungsaufbau der Tunnel geschieht per IPv4. Voraussetzung hierfür ist, dass Dein Internetrouter dem Freifunk Router per DHCP eine interne IPv4 Adresse aus Deinem Lan sowie einen DNS Server zuweist.

Sobald die Tunnel aufgebaut sind bekommen Clients die an dem Freifunk Router eingebucht sind oder an den Lan Ports hängen dual stacked eine Public IPv6, sowie eine private IPv4 Adresse. Der Router ist ab diesem Zeitpunkt auch auf der 10.53.254.254 erreichbar. Ein guter Test ist mit dem Browser auf die Adresse zu surfen, da sollte dann die Status Seite erscheinen. Entsprechend hat man ab diesem Zeitpunkt sowohl per v6 wie auch per v4 Internetzugriff…

Um im laufenden Betrieb dann noch auf den Router per SSH zugreifen zu können muss man zwingend ein SSH Passwort oder einen SSH Key hinterlegt haben.

Das Ruhrgebiets Image 0.5 stable ist absolut fehlerfrei, auf allen Routern für die es im /stable/ Zweig verfügbar ist.

1 Like

Yay! Bin gelistet. Nun, ich sollte mal auch die richtige MAC nehmen … :stuck_out_tongue:

Grummel, das Web-Interface bleibt mir verschlossen, obwohl der Port 80 offen ist und obwohl SSH klappt?

Wenn es klemmt:
Um den config-mode zu erzwingen sollte man die Büchse erstmal komplett hochfahren lassen nach dem PowerUp.
(>3 Minuten). Erst dann den Reset-Button so lange drücken bis alle LED gleichzeitig einmal kurz aufblitzen. Und dann auch nochmal 3-4 Minuten warten bevor man de Panik bekommt, dass es an den gelben Lan-Buchsen keinen DHCPd gibt, der 1918er Adressen aus 192.168.1.0/24 herausgibt.

Und wenn’s gar nicht geht: Rechner an einen gelben Port, manuell auf sein Interface auf 192.168.1.irgendwas (größer .1) festnageln, Netzmaske natürlich auf 255.255.255.0 und dann „auf gut Glück“ die http://192.168.1.1 im Webbrowser ansteuern.

1 Like

Hallo Roland,
Ich wuerde ja mal sagen totale solved.
Im normalen Betrieb siehst du da auch nichts auf Port 80
Wobei das nicht ganz korrekt ist.
Aus dem ff Netz kannst du per IPv6 auf
[2a02:f98:0:26:ea94:f6ff:fef3:2581]/cgi-bin/status zugreifen.

Und das geht.

Grus
Thomas

1 Like

Und ins WLAN / LAN des eigenen Routers eingebucht auch auf der 10.53.254.254 (lokale next node Adresse über die man nur den Router erreicht auf dem man soeben verbunden ist)

1 Like

Funktioniert das nur aus der eigenen FF-community oder auch aus anderen Freifunk-Domains (Köln->Lübeck etc)?

Das funktioniert global von überall!

Wir routen echte public IPv6 Adressen über die jedes Gerät, Router, Client aus dem Internet erreichbar ist…

Chris hast recht. Heute morgen kam ich da aus dem Internet zwar nicht drauf aber es ist global offen.