VPN-Offloader-Konfiguration?


#1

Hallo,

seit einem Jahr betreibe ich einen TL-WR841ND als Freifunkknoten. Wegen des geringen Fastd-Durchsatzes will ich einen Turris Omnia (OpenWrt omnia 15.05 r47055) als VPN-Offloader verwenden. Deshalb habe ich im GLUON des TL-WR841ND mesh-vpn deaktiviert und mesh-wan aktiviert. Auf dem Turris Omnia habe ich mit opkg update && opkg install fastd && /etc/init.d/fastd enable Fastd installiert und die /etc/config/fastd des TL-WR841ND auf den Turris Omnia kopiert. Fastd auf dem Turris Omnia erstellt mesh-vpn und baut eine Verbindung auf. Der WAN-port des TL-WR841ND ist mit eth0.4 am Turris Omnia verbunden.

Wie bridge ich eth0.4 und mesh-vpn in OpenWRT 15.05?

Danke für jeden Hinweis! :slight_smile:


#2

Hi, Wenn Du batman nutzt, bridgest Du die beiden Interfaces gar nicht, sondern Du fügst bestenfalls beide Interfaces eth0.4 und mesh-vpn dem bat0 interface hinzu

batctl addif eth0.4 und batctl addif mesh-vpn.

Den Effekt kannst Du auch erreichen in dem Du beide Interfaces in /etc/config/network mit “proto = gluon_mesh” einstellst.


#3

Welche Pakete muss ich in OpenWRT 15.05 für “proto = gluon_mesh” installieren?


#4

Das wird problematisch, weil Du das Finetuning nur schwer hinbekommst und ein Knoten, der nicht im Autoupdater läuft, ist früher oder später IMMER ein Problem für mindestens die lokalen User, wenn nicht den kompletten Netzbetrieb.

Schaue lieber zu, ob Du den Turris-Omnia als Target bei Gluon mit dazu bekommst.


#5

Der Turris Omnia wird als normaler Router, NAS und Application-Server gebraucht. Deshalb kann ich Freifunk nur Huckepack laufen lassen.


#6

Da batman-adv ein kernelmodul ist, wird es es vermutlich ziemlich hakelig, das durchzureichen. Ich würde vorschlagen, ein anderes Gerät zu nutzen. Sofern es nicht nicht gerade um den sportlichen Ehrgeiz (und nicht um die langfristige Nutzbarkeit) geht.

was Du aber machen kannst: Auf dem TurrisOmnia nur FastD laufen lassen und kein Batman. Und damit nur das interface durchbridgen zu dem 841er, der dann batman auf dem eth erwartet.
(Ja, das ist schon advanced im Freifunk-Kontext, aber wenn man zumindest etwas Ubung mit brctl hat, dann gut machbar.)


#7

Bridging habe ich schon versucht, bekomme aber keine IP-Adressen. Verwendet Freifunk-FFM kein DHCP/RA?


#8

auf dem batman-netz wird batman gesprochen. Da gibt es kein IP.


#9

Wie muss ich Gluon auf dem TP-WL841ND konfigurieren, um im AP-Netz IP-Adressen zuzuweisen (DHCP/RA)? Bisher habe ich angenommen, dass Freifunk-FFM mit batdman-adv OSI-Schicht 2 nutzt und erst auf den Fastd-Servern geroutet wird.


#10

Das batman-Netz macht das auf Cleint-Seite automatisch. Radvd und dhcp läuft auf den Supernodes.
Auf der bat-adv-Seite (richtung fastd) ist nichts, was Du tun kannst. das musst Du nur durchswitchen auf Layer2.


#11

Weder die Bridge des Turris Omnia noch die Clients im AP-Netz des TP-WR841ND-Knotens bekommen IPv4/IPv6-Adressen zugewiesen:

root@turris:~# cat /etc/config/fastd 

config fastd 'sample_config'
	option enabled '0'
	option syslog_level 'info'
	list method 'salsa2012+umac'
	option mode 'tap'
	option interface 'tap0'
	option mtu '1426'
	option forward '0'
	option secure_handshakes '1'

config peer 'sample_peer'
	option enabled '0'
	option net 'sample_config'
	option key '0000000000000000000000000000000000000000000000000000000000000000'

config peer_group 'sample_group'
	option enabled '0'
	option net 'sample_config'

config fastd 'mesh_vpn'
	option enabled '1'
	option mtu '1374'
	option group 'gluon-fastd'
	option status_socket '/var/run/fastd.mesh_vpn.socket'
	option packet_mark '1'
	option syslog_level 'verbose'
	option mode 'tap'
	option secure_handshakes '1'
	option interface 'mesh-vpn'
	option secret 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
	list method 'salsa2012+umac'

config peer_group 'mesh_vpn_backbone'
	option enabled '1'
	option peer_limit '1'
	option net 'mesh_vpn'

config peer 'mesh_vpn_backbone_peer_fastd3'
	option enabled '1'
	option key 'e16542b789ebb2f8ec258ee5f1a359ff2852ff5740fe802a35299e711ac57982'
	option net 'mesh_vpn'
	list remote '"fastd3.ffm.freifunk.net" port 10003'
	option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_fastd8'
	option enabled '1'
	option key '55d23f51067cf83967b991cf06fee710d59b0c26d184529eb319405a5e37782e'
	option net 'mesh_vpn'
	list remote '"fastd8.ffm.freifunk.net" port 10003'
	option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_fastd1'
	option enabled '1'
	option key '6d98ed09fc260a65234a65b03ce47c9e1a19226c66220c66b89255bf569fa68b'
	option net 'mesh_vpn'
	list remote '"fastd1.ffm.freifunk.net" port 10003'
	option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_fastd7'
	option enabled '1'
	option key '541ad0b39c10a21337f85f8c721276200f095a8df5196e97c0b6e05128df0983'
	option net 'mesh_vpn'
	list remote '"fastd7.ffm.freifunk.net" port 10003'
	option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_fastd5'
	option enabled '1'
	option key '4235016b554520600d866d34fb7cccf48e7f8c8c5954ec473fabb6fd22c60ecf'
	option net 'mesh_vpn'
	list remote '"fastd5.ffm.freifunk.net" port 10003'
	option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_fastd2'
	option enabled '1'
	option key '9a539d2761a3533b09d01065fb995b6488612ec50d61787703c0fe94a9f79967'
	option net 'mesh_vpn'
	list remote '"fastd2.ffm.freifunk.net" port 10003'
	option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_fastd4'
	option enabled '1'
	option key 'e9d48b3ffa7593a736288bbb7e6f32daf9d0df4c5d03ddbadb9b7d04c334ece8'
	option net 'mesh_vpn'
	list remote '"fastd4.ffm.freifunk.net" port 10003'
	option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_fastd6'
	option enabled '1'
	option key 'e5c9fee48ca3b3e0a5ca59854672dfc238e1068cc1008897148fada1f9590392'
	option net 'mesh_vpn'
	list remote '"fastd6.ffm.freifunk.net" port 10003'
	option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_fastd9'
	option enabled '1'
	option key '7300f366e15a797a8451b1d7a37ddfe8b617c6eed6fcea3c517023c43318c4fa'
	option net 'mesh_vpn'
	list remote '"fastd9.ffm.freifunk.net" port 10003'
	option group 'mesh_vpn_backbone'

.

root@turris:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option broadcast '192.168.100.255'
	option ip6assign '64'
	option ipaddr '192.168.100.2'
	option gateway '192.168.100.1'
	option ifname 'eth0 eth1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4t'
	option vid '4'

config interface 'vpn_turris'
	option enabled '1'
	option ifname 'tun_turris'
	option proto 'none'
	option auto '1'

config route
	option interface 'lan'
	option target '0.0.0.0'
	option netmask '0.0.0.0'
	option gateway '192.168.100.1'

config interface 'freifunk'
	option type 'bridge'
	option proto 'dhcp'
	option ifname 'eth0.4 mesh-vpn'

.

root@turris:~# brctl show
bridge name	bridge id		STP enabled	interfaces
br-freifunk		7fff.d858d7007a25	no		eth0.4
							mesh-vpn
br-lan		7fff.d858d7007a25	no		eth0
							eth1
							wlan0
							wlan1
							veth6CD96X

.

root@turris:~# grep -i fastd /var/log/messages 

2018-11-27 20:07:17 notice fastd[24702]: fastd v18 starting
2018-11-27 20:07:17 debug fastd[24702]: initializing TUN/TAP device...
2018-11-27 20:07:17 debug fastd[24702]: TUN/TAP device `mesh-vpn' initialized.
2018-11-27 20:07:17 notice fastd[24702]: changed to UID 0, GID 999
2018-11-27 20:07:17 info fastd[24702]: adding peer <mesh_vpn_backbone_peer_fastd9>
2018-11-27 20:07:17 info fastd[24702]: adding peer <mesh_vpn_backbone_peer_fastd6>
2018-11-27 20:07:17 info fastd[24702]: adding peer <mesh_vpn_backbone_peer_fastd4>
2018-11-27 20:07:17 info fastd[24702]: adding peer <mesh_vpn_backbone_peer_fastd2>
2018-11-27 20:07:17 info fastd[24702]: adding peer <mesh_vpn_backbone_peer_fastd5>
2018-11-27 20:07:17 info fastd[24702]: adding peer <mesh_vpn_backbone_peer_fastd7>
2018-11-27 20:07:17 info fastd[24702]: adding peer <mesh_vpn_backbone_peer_fastd1>
2018-11-27 20:07:17 info fastd[24702]: adding peer <mesh_vpn_backbone_peer_fastd8>
2018-11-27 20:07:17 info fastd[24702]: adding peer <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd3.ffm.freifunk.net' for peer <mesh_vpn_backbone_peer_fastd3>...
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd8.ffm.freifunk.net' for peer <mesh_vpn_backbone_peer_fastd8>...
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd8>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd1.ffm.freifunk.net' for peer <mesh_vpn_backbone_peer_fastd1>...
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd1>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd7.ffm.freifunk.net' for peer <mesh_vpn_backbone_peer_fastd7>...
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd7>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd5.ffm.freifunk.net' for peer <mesh_vpn_backbone_peer_fastd5>...
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd5>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd2.ffm.freifunk.net' for peer <mesh_vpn_backbone_peer_fastd2>...
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd2>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd4.ffm.freifunk.net' for peer <mesh_vpn_backbone_peer_fastd4>...
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd4>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd6.ffm.freifunk.net' for peer <mesh_vpn_backbone_peer_fastd6>...
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd6>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd9.ffm.freifunk.net' for peer <mesh_vpn_backbone_peer_fastd9>...
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd9>
2018-11-27 20:07:17 debug fastd[24702]: learned new local MAC address d8:58:d7:00:7a:25
2018-11-27 20:07:17 info fastd[24702]: resolved host `fastd4.ffm.freifunk.net' successfully
2018-11-27 20:07:17 info fastd[24702]: resolved host `fastd1.ffm.freifunk.net' successfully
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd8.ffm.freifunk.net' failed: Name does not resolve
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd1>
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd8>
2018-11-27 20:07:17 info fastd[24702]: resolved host `fastd2.ffm.freifunk.net' successfully
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd7.ffm.freifunk.net' failed: Name does not resolve
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd2>
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd7>
2018-11-27 20:07:17 info fastd[24702]: resolving host `fastd9.ffm.freifunk.net' failed: Name does not resolve
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd9>
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd4>
2018-11-27 20:07:17 info fastd[24702]: resolved host `fastd3.ffm.freifunk.net' successfully
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:17 info fastd[24702]: resolved host `fastd6.ffm.freifunk.net' successfully
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd6>
2018-11-27 20:07:17 info fastd[24702]: resolved host `fastd5.ffm.freifunk.net' successfully
2018-11-27 20:07:17 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd5>
2018-11-27 20:07:18 debug fastd[24702]: resetting socket for peer <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:18 debug fastd[24702]: generating new handshake key
2018-11-27 20:07:18 info fastd[24702]: sending handshake to <mesh_vpn_backbone_peer_fastd3>[185.206.209.143:10003]...
2018-11-27 20:07:18 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:18 info fastd[24702]: received handshake response from <mesh_vpn_backbone_peer_fastd3>[185.206.209.143:10003] using fastd v18
2018-11-27 20:07:18 debug fastd[24702]: finishing handshake with <mesh_vpn_backbone_peer_fastd3>[185.206.209.143:10003]...
2018-11-27 20:07:18 info fastd[24702]: 185.206.209.143:10003 authorized as <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:18 debug fastd[24702]: Keeping scheduled task for <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:18 notice fastd[24702]: connection with <mesh_vpn_backbone_peer_fastd3> established.
2018-11-27 20:07:18 info fastd[24702]: new session with <mesh_vpn_backbone_peer_fastd3> established using method `salsa2012+umac'.
2018-11-27 20:07:18 debug fastd[24702]: Keeping scheduled task for <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:18 debug fastd[24702]: cleaning left handshakes with <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:18 debug fastd[24702]: learned new MAC address 02:ff:10:03:03:03 on peer <mesh_vpn_backbone_peer_fastd3>
2018-11-27 20:07:18 debug fastd[24702]: temporarily disabling handshakes with <mesh_vpn_backbone_peer_fastd2>
2018-11-27 20:07:18 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd2>
2018-11-27 20:07:19 debug fastd[24702]: temporarily disabling handshakes with <mesh_vpn_backbone_peer_fastd5>
2018-11-27 20:07:19 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd5>
2018-11-27 20:07:19 debug fastd[24702]: temporarily disabling handshakes with <mesh_vpn_backbone_peer_fastd9>
2018-11-27 20:07:19 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd9>
2018-11-27 20:07:19 debug fastd[24702]: temporarily disabling handshakes with <mesh_vpn_backbone_peer_fastd1>
2018-11-27 20:07:19 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd1>
2018-11-27 20:07:20 debug fastd[24702]: temporarily disabling handshakes with <mesh_vpn_backbone_peer_fastd6>
2018-11-27 20:07:20 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd6>
2018-11-27 20:07:20 debug fastd[24702]: temporarily disabling handshakes with <mesh_vpn_backbone_peer_fastd7>
2018-11-27 20:07:20 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd7>
2018-11-27 20:07:20 debug fastd[24702]: temporarily disabling handshakes with <mesh_vpn_backbone_peer_fastd8>
2018-11-27 20:07:20 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd8>
2018-11-27 20:07:20 debug fastd[24702]: temporarily disabling handshakes with <mesh_vpn_backbone_peer_fastd4>
2018-11-27 20:07:20 debug fastd[24702]: Replacing scheduled task for <mesh_vpn_backbone_peer_fastd4>

#12

Nimm ein gluon base-image, dann bekommst Du das geschenkt.

Du brauchst mindestens gluon-core, gloun-mesh-vpn*,
gluon-mesh-batman-adv-1?
Ich wär mir aber nicht sicher ob ich so etwas grundlegendes wie
gluon-Pakete über ein bereits installiertes OpenWRT drüberbügeln
wollte.