Werbung per DNS/Hostsdatei (im Router/am Supernode) blocken


#1

Normalerweise ist das natürlich keine gute Idee in den Netzwerkverkehr einzugreifen, aber wenn man selbst der einzige Nutzer seines Netzes ist, dann wäre eine Option sehr praktisch, wenn ein Freifunk Router die Funktion eines PiHoles übernehmen könnte, also die Werbing schon beim Internet Zugang blocken.

Ich habe gehört in Suddeutschland gibt es sogar eine Community, die das standardmäßig einsetzt (nicht empfohlen meiner Meinung nach) und zwar sogar so, dass alle Werbebanner durch Werbung für Freifunk ersetzt wird und der User so z.B. in Apps auf seinem Mobiltelefon plötzlich Freifunk Werbung eingeblendet sieht :wink: LOL

Wie könnte man das einbauen? Vielleicht könnte man das ja auch als zusatzoption im Gluon Paket “Private WiFi” ergänzen und dann nur für das Private Wlan so configurieren.


#2

Wir hatten uns auch schon Gedanken gemacht.

Das default aktiviert zu haben geht meiner meinung nach nicht.
Wir sind am Ende drauf gekommen ein Opt-In auf einem Webinterface zu machen wo man sein Gerät registrieren kann. Das müsste nur in einer Liste landen und der DHCP könnte dann nach der Liste den Clients einen anderen DNS Server geben.

War bis jetzt aber nur eine Idee, umgesetzt ist das noch nicht.


#3

Opt in auf einen alternativen DNS Server auf dem Gw der das wegfiltert.


#4

Ich denke, dass das nichts ist, was man im netz tun sollte, sondern auf dem Endgerät stattfinden sollte.
Einfach weil man damit (wie bei jeder Filterstruktur) einen Weg in die Hölle™ vorbereitet.


#5

Derlei “auf dem Endgerät” umzusetzen, ist IMHO nicht trivial, spätestens bei iOS-Devices? Ich nutze selbst PiHole (in Form einer x86-VM) zuhause und bin zunehmend genervt vom Surfverhalten außerhalb der eigenen vier Wände.


#6

ich habe einen tipp zu einer quick&dirty Lösung von @rotanid:

11:55: manuell die dnsmasq config anpassen… doku lesen.
Dann Anpassungen per sed machen, sed befehle in die rc.local


#7

Für OpenWrt gibts es das Package “adblock”:

  • zero-conf like automatic installation & setup, usually no manual changes needed

einfach

opkg update
opkg install adblock

scheint zu laufen, ist installiert… mal testen…

hmm, irgendwie schnall ich das noch nicht. hab dies probiert:

uci set adblock.global.adb_enabled=1
uci commit adblock
/etc/init.d/adblock enable
/etc/init.d/adblock start

aber irgendwie schnall ich nicht ob der jetzt was tut:

# /etc/init.d/adblock status
::: adblock runtime information
  + adblock_status  : enabled
  + adblock_version : 3.5.5-2
  + overall_domains : 0 (normal mode)
  + fetch_utility   : /bin/uclient-fetch (-)
  + dns_backend     : dnsmasq (/tmp)
  + last_rundate    : 10.09.2018 21:23:36
  + system_release  : TP-Link Archer C50 v3, OpenWrt 18.06-SNAPSHOT r7298+7-f7413579c0

#8

aber das wird doch so kaum (hoffentlich) nicht auf L2-Ebene in den Traffic eingreifen.


#9

enabled hab ich adblock ja, aber es lädt keine blocklists runter. habs erstmal wieder deinstalliert. vielleicht findet ja jemand raus, wie es geht.

hab im chat noch ein paar tipps:

@omni: (aus Schwedden http://pjodd.se/ )
00:43 rubo77|m: we run unbound on our gateways and do some adblocking through that ansible/dns.yml at master · pjodd/ansible · GitHub
00:44 granted clients use our announced dns services

fwiw: spamhaus has a bgp feed for networks one should filter out for maleware/botnet reasons

01:29: DROP - Don't Route or Peer lists - The Spamhaus Project

Und vielleicht weis ja jemand, wei man den dnsmasq umkonfigurieren kann, dass der eine blocklist benutzt? Reicht ja auch erstmal, wenn man von hand eine blocklist runterlädt und die irgendwo dann aktiviert, dass der router die benutzen soll.

Ich habe schon probiert was in der /etc/hosts einzutragen`um das auf 127.0.0.1 umzuleiten, aber das scheint aber nichts zu bewirken, weder wenn ich im freifunk-wlan bin (nicht verwunderlich) aber auch nicht, wenn ich im Private WiFi bin.


#10

Schade:

das private wifi interface ist nur eine bridge in dein privates netzwerk, da ist keinerlei mitsprache des gluon routers dabei… fällt mir grade so auf, daher ist dnsmasq und so weiter piepegal

the router would have to dnat dns queries in order for that to work
gluon isnt prepared to serve every niche usecase
gluon isn’t in a good position to filter your wan-bridge internet access