WR841v10 Experimental kein WLAN

Hallo,

ich habe mir eine Build-Umgebung für Gluon aufgebaut und mir ein Image für meinen 841 v10 gebaut, für die neue Domäne Neuss.
Leider scheint aber das WLAN nicht zu funktionieren. Ich sehe kein „Freifunk“ Netz und ein „iw dev“ liefert keine Ausgabe auf dem Gerät.
Ich bin mit dem Debugen auf den Dingern noch nicht so fit, daher wäre es nett wenn mir da jemand ein bisschen weiter helfen könnte.

viele Grüße

Biertrinker

Bei mir, andere site.conf, hat der Router in den Configmode gestartet und erst wenn ich Kontaktdaten eingetragen habe dann startete der 841er als „Freifunk Knoten“. Ich musste dann noch den WLAN Button drücken, damit das WLAN eingeschaltet wurde.

Also mach das Ding mal aus, dann wieder an und verbinde Deinen PC per Ethernet mit einer gelben Buchse, du bekommst dann eine IP (DHCP auf dem Router), der Router hat die IP 192.168.0.1 oder 192.168.1.1, da kommst du auf die Konfigseite und kannst dann einen Kontakt einstellen, dann unten rechts speichern&neustarten anklicken, nach dem Neustart (ca. 40 Sekunden) dann den WLAN Button am Router hinten drücken, ab da kommt WLAN wohl automatisch beim einschalten des Routers.

Edit: Meine Site.conf ist eine von DUS Flingern, eben eine für das neue Release von Gluon.

ohne einen Link zu der von Dir genutzten site.conf werden die meisten hier nur sagen könnten, dass sie keine Glaskugel besitzen.

2 Likes

Ich vermute stark, dass hier eine site.conf für v2015.1.2 genutzt wurde. Das führt exakt dazu, dass man kein WLAN hat.

Ein Beispiel der aktuellen Syntax findest du z.B. hier in unserem Münsterraner Repo: https://github.com/FreiFunkMuenster/site-ffms/blob/gluon-master/site.conf

Grüße
Matthias

Hallo,

so ist es, ich bin fälschlicherweise davon ausgegangen, das die site.conf von der neuen Neuss Domäne schon angepasst wäre. Ich habe das jetzt entsprechend überarbeitet und mache gerade einen neuen Build fertig, mal sehen ob dann klappt.

Ihr müsst außerdem darauf achten das wir Batman-Advanced in einem Vlan laufen haben (Option mesh_vlan in 2015.1.2).
Ohne dies können die Nodes nicht kommunizieren. Dies wird verwendet um in Zukunft einfacher von Batman-Advanced zu Layer 3 Meshing wie etwa Babel zu wechseln.

Wahrscheinlich solltet ihr dann einfach mal die site.conf gemeinsam anschauen.

Fall es sich um diese Config handelt:

Dann ist diese falsch :wink: Da fehlt das VLAN komplett

Hier befindet sich eine Gluon 2015.2 kompatible Config: