Zwei Netzwerkkarten im Futro


#1

Fortsetzung der Diskussion von Konfiguration und Einsatz von VLANs im Zusammenhang mit Freifunk:

Rein aus Neugier, wie hast Du das realisiert? (Welches Modell?)
Eine DualPort-PCI oder hast Du es irgendwie fertigbekommen, einen Raiser mit zwei PCI-Slots zu verbauen. Und wenn ja, wo sitzt dieser zweite Netzwerkkarte dann?
Oder bist Du die “Notfallroute” via USB-NIC gegangen?


Futro S550 2. Netzwerkkarte
Konfiguration und Einsatz von VLANs im Zusammenhang mit Freifunk
#3

Hallo zusammen,

ich würde hier gerne nochmal ansetzen. Ich habe einen Futro mit zwei Netzwerkkarten und möchte aus der LAN-seitigen Netzwerkkarte gerne zwei VLAN herausbekommen. Eines mit Clientnetz und eines mit Meshnetz. Im Moment kommt da nur Mehnetz raus und das sieht so aus:

root@ffac-FutroOffloader:~# brctl show
bridge name bridge id STP enabled interfaces
br-wan 7fff.021a995XXXX no eth1
br-client 7fff.0019995XXXX no bat0

auf einen TP-Link sieht das so aus:

root@ffac-TPLink-1:~# brctl show
bridge name bridge id STP enabled interfaces
br-client 7fff.60e327cXXXX no eth0
bat0
client0
br-wan 7fff.62e427cXXXX no eth1

Ich vermute also, dass ich (mangels Switch im Futro) eth0 irgendwie mit zwei VLAN belegen muss. Eines mit bat0 (Meshnetz) und eines mit Clientnetz (client0, das gibt es aber bisher gar nicht). Wie kann ich das konfigurieren, möglichst updatesicher?

Gruß

Ulli


#4

Punkte 15 und 16: F.A.Q. zum Offloader Fujitsu-Siemens Futro S550


#5

Hallo @MPW, das kenne ich. Ich habe aber zwei Netzwerkkarten im Futro. Eine soll WAN (via Mesh-on-VPN) und die andere Netzwerkkarte soll ein Freifunk Client VLAN und Mesh VLAN liefern. Das ist doch sicherlich anders zu konfigurieren. Vielleicht bin ich auch nur zu blöd das zu verstehen.

Gruß

Ulli


#6

Eine intern, eine per PCI?


#7

Das weiss ich nicht, ob die beiden Karten PCI oder eben USB oder DualNic.


#8

Hallo zusammen,

ich habe die interne Karte (LAN) und eine Digitus PCI Gigabit Karte (WAN) von Conrad mit der in der Futro FAQ empfohlenen Riser Card.

Es ging mir ja nicht um die zwei Netzwerkkarten im Futro, sondern um zwei VLANs auf der LAN-Netzwerkkarte. Jetzt kommt nur Mesh-Netz da raus, ich möchte aber, dass dort zwei VLANs rauskommen: Eines mit Mesh-Netz (VLAN ID 4 tagged) und eines mit Client-Netz (VLAN ID 6 tagged). Die VLAN Nummern habe ich mir jetzt willkürlich ausgedacht.

Bildlich so: WAN (an FTTH-Router bzw. DMZ) --> Futro --> LAN (VLAN 6, VLAN 4)

Das möglichst Updatesicher oder mit einem kleinen Script, was nach manuellen Updates ausgeführt werden kann.

Ich habe jetzt schon so viel gelesen, blicke aber nicht wie ich das angehen kann. Ich stelle mir das so vor:

  • VLANs erstellen an virtuellen Netzwerkkarten
  • ClientNetz auf VLAN6 legen (Das gibt es im Futro gar nicht)
  • MeshNetz (bat0?) auf das VLAN4 legen
  • Keine ungetaggten Pakete rausjagen, damit mein internes LAN (untagged) nicht überschwemmt wird bzw. im schlimmsten Fall der ClientNetz-DHCP mein internes Netzwerk durcheinander bringt.

Mir ist bewusst, dass ich einen Managed Switch benötige. Ist in der Beschaffung.

Auf den Clients (zwei Freifunkrouter zum Meshen Garten/Garage und bald noch Dach) muss ich sicher auch etwas umstellen. Mesh-on-LAN/WAN mit VLAN4, müsste das ja denn sein.

Auf zwei anderen Clients (dd-wrt) soll dann das Clientnetz VLAN6 an eine Freifunk SSID gebridged werden. (Ich weiß, die Meshen dann nicht, ist aber inhouse auch nicht nötig. Nach außen wird kräftig gemeshed, auch wenn ich hier noch fast alleine bin. Roaming ist inhouse auch nicht so wichtig.)

Idealerweise lege ich noch ein VLAN5 an, dass mein Internes Netzwerk getagged beinhaltet, sodass die Freifunkrouter in Garage und Gartenhaus auch noch mein privates WLAN raushauen.

Soweit meine Ideen, aber wie stelle ich das jetzt an?

Gruß

Ulli


#9

Ich habe mal ein bisschen weiter recherchiert und mir für den Futro folgendes überlegt:

  1. Software nachinstallieren (nano und swconfig via opkg)
  2. Anhand der Seite Freifunk WIKI der Mainzer eine Konfiguration (mit vielen offenen Fragen) zusammengeschrieben:

Bin gespannt über euer Feddback, geht das in die richtige Richtung, oder bin ich auf dem Holzweg? Ich habe mich nicht getraut, den Futro damit zu bespielen. Erst wollte ich mal euch Profis hören.

#Änderungen in der /etc/config/network

WAN ist eth0
LAN ist eth1

#Geaenderte Config wg. VLAN

config interface 'client'
        option type 'bridge'
        option macaddr '00:19:99:xx:xx:xx'
        option proto 'dhcpv6'
        option reqprefix 'no'
        option igmp_snooping '0'
        option peerdns '1'
        option sourcefilter '0'
        list ifname 'bat0 eth1.6' #Kann das so stimmen? Oder besser eth1.4 eth1.6?
config interface 'mesh_vlan4'                                                          
        option auto '1'                                                                  
        option ifname 'eth1.4'                                                         
        option mesh 'bat0'
        option macaddr 'xx:xx:xx:xx:xx:xx'   # frei erfundene - aber netzweit eindeutige - MAC einsetzen.                                                                
        option proto 'batadv' 

config interface 'client_vlan6'
option auto '1'
        option ifname 'eth1.6'     
        option macaddr 'xx:xx:xx:xx:xx:xx'   # frei erfundene - aber netzweit eindeutige - MAC einsetzen.                                                                
        option proto 'dhcpv6' #für IPv6
        option proto 'dhcp' # für IPv4 (geht beides parallel hier in der Config?)

#Zusaetzliche Config wg. VLAN

config switch
       option name 'switch0'
       option reset '1'
       option enable_vlan '1'
       option enable_vlan4k '1'
       option max_length '3'

 #Freifunk Client VLAN
 config switch_vlan 'vlan6'
       option device 'switch0'
       option vlan '6'
       option ports '0t 2t 3t 4t 5t' #Hat ja nur einen Port, ist das richtig so?

Freifunk Mesh VLAN
 config switch_vlan 'vlan4'
       option device 'switch0'
       option vlan '4'
       option ports '0t 2t 3t 4t 5t' #Hat ja nur einen Port, ist das richtig so?

#10

Fortsetzung der Diskussion von Konfiguration und Einsatz von VLANs im Zusammenhang mit Freifunk:

Rein aus Neugier, wie hast Du das realisiert? (Welches Modell?)
Eine DualPort-PCI oder hast Du es irgendwie fertigbekommen, einen Raiser mit zwei PCI-Slots zu verbauen. Und wenn ja, wo sitzt dieser zweite Netzwerkkarte dann?
Oder bist Du die “Notfallroute” via USB-NIC gegangen?


#11

Entschuldigt die Rumschieberrei. Ich hab mich verklickt.


#12

Mir geht es aber um die zwei Netzwerkkarten, da ich gut 3 (performante) Ethernet-Interfaces im Futro gebrauchen könnte.
Also zusätzlich zum Onboard-Interface noch 2 Netzwerkkarten.


#13

Dann bräuchte ich auch nicht mit VLAN im Futro arbeiten, sondern arbeiten, sondern könnte das den Switch machen lassen. Auch charmant…


#14

Ich habe mal im Ur-Futro-Thread rumgeparsed, mir war doch so als hätte jemand einfach rotzfrech ne alte Dual PCI-X NIC in das Ding gestopft.

HTH


#15

http://pages.ebay.com/link/?nav=item.view&id=391368087933&alt=web

Einfach mal rein werfen und testen.