Zwei TL-WR841N bilden kein Mesh-Netzwerk


#1

Hallo,
ich besitzen seit längerem ein TL-WR841N V8 auf dem ich die Freifunk Firmware von ddmesh.de aufgespielt habe. Läuft seit her alles problemlos. Diese Woche hab ich einen TL-WR841N V9 dazu bekommen. Auf diesem habe ich ebenfalls ohne Probleme die Freifunkfirmware installieren können. Der TL-WR841N V9 läuft ansich auch gut und stellt über WLAN einen Accespoint bereit. Leider verbinden die beiden sich nicht im Mesh. Der benachbarte Knoten der am Internet hängt wird von dem neuen nur ganz schwach gesehen und als unbenutzbar eingestuft, obwohl die Geräte genau nebeneinander stehen. Im WLAN-Scan können beide Geräte das Mesh-Netzwerk und den Acesspoint des jeweiligen anderen sehen. Gibt es eine Möglichkeit der Sache genauer hinterherzuforschen?
Grüße
Nico


#2

Hallo Nico,

eventuell stehen die Gerät zu nah aneinander. Stell mal einen in den Nachbarraum.

Grüße
Matthias


#3

hi,
Welche Signalstärke und welchen Kanal wird auf deinen 3 Geräten angezeigt?
wenn die Kanäle unterschiedlich sind und die Router zu nah stehen, Wird auch auf unterschiedlichen Kanälen einen Verbindung hergestellt, Welche extrem schlecht ist.
wie ist die Verbindung vom Handy zum v9? ist diese nutzbar, auch aus größerer Entfernung?
läuft auf allen drei Geräten die gleiche Firmware Version?
hilft werkseinstellung?
VG Stephan


#4

Hallo,
ich habe gerade nur 2 Router im Einsatz. Den 3. müsste ich mir erst von meinem Nachbar besorgen.
Knoten 1461 TL-WR841N/ND v9 Firmware Version: 4.2.2 Kanal 13 TX Power 18 dBm
Knoten 1146 TP-Link TL-WR841N/ND v8 Firmware Version: 4.2.2 Kanal 10 TX Power 16 dBm

Ich hab die Router jetzt soweit wir es mir möglich ist auseinandergestellt.
Zu beiden Routern habe ich sowohl mit dem Handy, als auch mit dem Laptop gute Verbindung.
Ich habe beim TL-WR841N/ND v9 bereits einen Reset auf Werkseinstellung durchgeführt. Das Problem habe ich eher bei dem neuen Router gesehen. Der TP-Link TL-WR841N/ND v8 hatte sich in der Vergangenheit bereits erfolgreich mit einem weiteren TP-Link TL-WR841N/ND v8 verbunden. Wenn es sinnvoll ist, würde ich den TP-Link TL-WR841N/ND v8 noch einmal auf Werkseinstellung zurücksetzen.


#5

Kanal 13 und Kanal 10?

Damit sie sich per Funk verbinden muss auf beiden Geräten der gleiche Kanal eingestellt werden


#6

Reset auf Werkseinstellung des TP-Link TL-WR841N/ND v8 scheint das Problem zu lösen.
Vielen Dank für die Hilfe.


#7

hi, das Problem ist der falsche Kanal 10. normalerweise kannst du diesen nicht über die Weboberfläche einstellen. das geht nur, wenn du dich via ssh auf dem Router einloggst und manuell die Konfiguration änderst. oder du hattest zuvor openwrt oder einen andere Firmware drauf, wo Kanal 10 eingestellt war. denn Freifunk Firmware basiert auf openwrt.
VG Stephan


#8

Ich wollte es eigentlich nicht sagen…
Aber ja, wenn man Knoten “aus anderer Firmware” umflashed und dann die Parameter nicht komplett zurücksetzt, dann passieren diese -und noch schlimmere- Sachen.

Ich hatte aber wirklich nicht angenomen, dass es hier zutreffen würde, da ich nicht davon ausgegangen war, dass auf den Knoten vorher was anderes (als die Werksfirmware) drauf gewesen ist (oder der Threadstarter hätte das zumindest ansatzweise erwähnt.)


#9

Hi.
Ich habe bis jetzt nur die Freifunk Firmware auf die Router geflashed. Leider kann ich bei den beiden TP-Link TL-WR841N/ND v8 nicht ausschließen das zuvor etwas anderes darauf gelaufen ist. Die beiden habe ich 2015 im Zuge der Bunten Republik Neustadt von einem Freifunker bekommen. Die beiden Router hatte damals keine Verbindungsprobleme. Damals war aber noch eine älter Version der Firmware drauf, die ich zwischendrin geupdated habe.


#10

Hi,

wenn die beiden alten Router manuell auf Kanal 10 gestellt wurden, so meshen diese mit einander, aber leider nicht via wlan mit anderen. das wäre damals aber nicht so aufgefallen, da es da noch weniger knoten gab. Die router haben dann aber über das backbone mit dem freifunk netz gemesht. und so ist der kanalwechsel wohl nicht aufgefallen.
Alle deine Router sollten auf kanal 13 sein. Auch der Nachbarrouter, der vermutlich jetzt noch Kanal 10 hat, sollte zurückgesetzt werden, denn sonst würde er nicht mehr mit deinen Routern meshen.

VG
stephan


#11

Hi.
Ich hab auf dem dritten Router (TL-WR841N/ND v8 ) noch mal die Firmware aktualisiert und auf Werkszustand zurückgesetzt. Der Nachbar hatte für eine Veranstaltung DD-WRT aufgespielt. War etwas arbeitsintensiver, aber jetzt gehts.
Vielen Dank für die Hilfe.
Nico