Admin-Tagebuch GL


#1

2016-04-23 20:00

Das conntrack-Limit auf dem Konzentrator ist vollgelaufen. Ich habe das Maximum temporär hochgesetzt. Die Scripte, die das tun sollen (in /etc/sysctl.d/) tun es nicht richtig.


#2

Kernel-Module rechtzeitig laden:


#3

Auf gl1 (Firmware- und ehml. Kartenserver) war der Webserver aus unbekannten Gründen abgestürzt. Die logs wurden leider schon rausrotiert. Ich den Server wieder gestartet.


#4

Gültig für Bergisch Gladbach und Leichlingen:
Aktuell GW Ausfall, wir haben eine Fehlkonfiguration erzeugt.
GW wird schnellstmöglich neu aufgesetzt.


#5

2016-04-28 ~13.00

Störung ist behoben

Eine kleine Zusammenfassung der Ursachen, Probleme und Maßnahmen:

Ursachen:

  • Gestern habe ich das Blech umbenannt, sowohl in der /etc/hostname als auch /etc/hosts.
  • Ich habe LetsEncrypt-Zertifikate nach Doku für die Proxmox-Verwaltung eingebaut

Problem 1:
Man muss beim Umbennen eines Proxmox auch in /etc/pve/nodes den Ordner mit den VM-Configs umbenennen. Nach einem Reboot heute morgen ist mir das Blech dann um die Ohren geflogen. Genauer gesagt konnte ich die VMs nicht mehr starten. Ich habe versucht, den Fehler zu korrigieren und dabei in der Eile die Konfigurationen der VMs gelöscht.

Maßnahmen:

  • Ich habe versucht eine Bridge zu GL.Wupper einzurichten, was vorne und hinten nicht funktioniert hat.
  • Ich habe die VM-Konfigurationen neu angelegt und manuell die Platten neu erkennen lassen mit qm rescan -vmid 10X.

Problem 2:
Nachdem die Konfiguration einer VM wieder angelegt war, ließ sich diese nicht starten, weil das Script aus der Doku die Zertifikate in /etc/pve/local/pve-ssl.{key,pem} löscht aber nicht neu anlegt. Startet das Blech neu, werden dort neue, selbstsignierte Zertifikate angelegt. Damit kommt Proxmox nicht klar und beim Starten einer VM will der VNC-Server nicht.

Lösung:
Die Zertifikate aus /etc/letsencrypt/live/ nach /etc/pve/local/pve-ssl.{key,pem} kopieren / symlinken.


#6

Wir haben einen zweiten Host dazubekommen von @Pinky.
Ich habe ein PVE-Cluster mit silver (Host von @Frank) und tungsten (Host von @Pinky) erstellt und nach einigen Startschwierigkeiten können VMs nun sogar online migriert werden.
Dabei wurde keine Downtime verursacht.

Zunächst habe ich den Konzentrator von silver umbenannt von “konzentrator” zu “silver-kon”. Dafür musste ich zwei mal neu starten und es gab insgesamt so eine halbe Minute Downtime.

Jetzt setze ich 2 Supernodes bcd0 und ode0 auf tungsten auf.
Tunnel für tungsten muss ich noch “bestellen”.


#7

[quote=“PetaByteBoy, post:6, topic:11871, full:true”]
und tungsten [/quote]
wattndatt ? der Servername? Protest! Nimm was hübsches, z.B. rote Lola oder so :wink: Oder LBO
Lecker Bunt Ofein


#8

Ich werde jetzt nicht den Aufwand betreiben um den Namen zu ändern… Außer du schlägst mir was deutlich besseres vor…


#9

wird werden zwar bald amerikanische Kolonie sein, aber man muss das mit dem Englisch ja nicht übertreiben.
Abgesehen davon fände ich beides ätzend. Kann sich kein Aas was drunter vorstellen. Ist Dein Kind, nenn es wie du willst, aber LBO fänd ich trotzdem treffender.

Edit
“deutlich beseres” :wink:
ist eindeutig LBO
(bitte nicht schlagen)


#10

schlag 202020202020

Ich bleibe bei Tungsten


#11

AU! Ich verlange Volksabstimmung!

Ich reiche eine Petition ein

Schleichwerbung



#12

LBO größte Schleichwerbung wo gibt


#13

der gilt nicht, Du hast Deines auf Wikipedia bezogen, also mal nach:

Ich bleib bei LBO, wg. konkretem Bezug. Und Wiki wird gehackt.

Edit:
Linksradikales Blasorchester - sagt Wikipedia
der ist gut :wink:


#14

Ticket ist angelegt, wir warten ab jetzt auf die Tunnel zum Backbone.


#15

Erfahrungswert über benötigte Zeit dafür?


#16

Letztes Mal mehrere Monate aber da ist auch was schief gegangen.


#17


:alien:


#18

Tunnel sind da - hat fast nur 12h gedauert!
Danke @Lars!


#19

ja,danke, auch von mir


#20

Der Supernode für Burscheid läuft. Odenthal ist jetzt auch nicht mehr viel.