[ANNOUNCE] Gluon v2016.1

Hallo zusammen, ich hatte mich mal lesen in gluon-mailingliste gehängt. Da kamm frohe Kunde, nicht nur für die bei denen die Karnevalsumzüge abgesagt wurden!

Hi,
I’m happy to announce that Gluon v2016.1 has finally landed!

As you’ve already noticed, this has taken a lot longer than planned. The
change from Barrier Breaker to Chaos Calmer had caused some unexpected
instabilities which had to be addresses before making this release.

The release notes can be found at

https://gluon.readthedocs.org/en/v2016.1/releases/v2016.1.html

12 Likes

Das ist eine gute Nachricht! Gleichmal durchbauen. :smiley:

1 Like

5 Beiträge wurden in ein neues Thema verschoben: Schwierigkeiten beim Bauen von Gluon 2015.1

Gerade der Support für 1043v3, 841v10, CPE210v1.1 wird wirklich helfen.

Wer mag, der möge bitte bei einem 841(v9/v10) mit dem neuen Build „MoW“ aktivieren.

Den Node ohne gestecktes Lankabel (nur als "Wifimesh) booten.
Dann schauen, ob sich das Ding noch per IPv6 „non-Linklocal“ erreichen lässt, also ssh, status-Seite.

da viele neue Geräte unterstützt werden müssten wir dann die hardware specs der unterstützen Geräte anpassen - Freiwillige vor :wink:

Freifunk-Firmware Gluon/Hardware – wiki.freifunk.net

1 Like

Bin sehr gespannt wie das verhalten in der freien Landschaft sein wird. Es sind doch einige Bugs gerade WLAN basierend einfach auf das nächste Release verschoben worden.

https://github.com/freifunk-gluon/gluon/issues/605

Gruß
Thomas

Da sehe ich keine dramatischen Sachen bei, bei der Sendeleistung sind wir im Ernstfall zu gering, damit können wir leben.

Der Autoupdater wurde deutlich optimiert:

Das Mesh on WAN den Knoten stört wenn kein Kabel im WAN Port steckt ist auch kein Grund das Release heraus zu zögern

Das WiFi Stack Problem konnte ich bei mir nicht reproduzieren.

Ich bin der Meinung es ist soweit die Firmware mit gutem Gewissen in die Beta und Experimental Branches auszurollen. Nur sofern sie sich verhält wie erwartet geht sie dann auch in den stable Branch.

Das MoW stört auf 841&Co, wenn ein Kabel am Lan-Port steckt beim Boot.