DNS-Problem Domäne Ruhrgebiet

Hi,
nachdem sich mein Handy nun immer wieder automatisch mit dem Freifunk-Netz verbindet, ist mir aufgefallen, dass ich seit geraumer Zeit keine wirkliche Internetverbindung habe. So bin ich mal auf die Suche gegangen.

Letztenendes ist mir aufgefallen, dass Android als einzigen DNS-Server 10.53.16.2 zugeordnet bekommt, welchen ich aber nicht anpingen kann.
Internetverbindung an sich funktioniert aber, beliebige IP(v4) im Internet kann ich anpingen. (z.B. Googles DNS-Server 8.8.4.4)
Auch der zugeordnete Standardgateway (10.53.32.1) lässt sich anpingen und ist (nach den Pingzeiten) nicht der lokale Router.

Kann es sein, dass der DNS-Server ein Problem hat?
Kann ich als Workaround in Gluon irgendwie einen zusätzlichen DNS-Server einrichten?

Beschwören könnte ich es nicht, aber ich glaube, das Problem habe ich nicht nur auf meinem eigenen Node. Ich schaue morgen früh mal, ob der Nachbar-Node auch kein DNS kann.

schöne Grüße,
fkyle

Zumindest im Rheinufer gibt es das beschriebene Problem nicht:
Pinging [10.40.230.1]with 64 bytes of data:
1.Reply from 10.40.230.1:Size: 64bytesTime:81msTTL:64
2.Reply from 10.40.230.1:Size: 64bytesTime:74msTTL:64
3.Reply from 10.40.230.1:Size: 64bytesTime:29msTTL:64
4.Reply from 10.40.230.1:Size: 64bytesTime:37msTTL:64
< Completed >
Ping statistics for [10.40.230.1]:
Packets: Sent:4, Received:4, Lost:0 (0% loss)
Approximate round trip times in milli-seconds:
Minimum: 29ms, Maximum: 81ms, Average: 55ms

Lässt sich erstmal nicht nachvollziehen. Ping läuft, Ping6 läuft, Namensauflösung läuft:

~# nslookup www.google.de 10.53.16.2
Server: 10.53.16.2
Address: 10.53.16.2#53

Non-authoritative answer:
Name: www.google.de
Address: 173.194.44.95
Name: www.google.de
Address: 173.194.44.79
Name: www.google.de
Address: 173.194.44.87
Name: www.google.de
Address: 173.194.44.88

Habs heute morgen nochmal auf dem Nachbarknoten getestet. Auch da kann ich (vom Handy aus) zwar IPs im Internet anpingen, aber nicht den DNS-Server erreichen. Ebensowenig funktioniert die Namensauflösung.

Vom Freifunk-Router aus funktioniert der Ping sowie die Namensauflösung (mit nslookup) auch nicht. Irgendwas liegt da im argen.

@fkyle Bei Dir ist also auch keine Namensauflösung möglich.
Nach der ersten Mail hatte ich es so verstanden, dass DNSlookup zwar funktioniert, der DNS jedoch lediglich auf CTCP NICHT antwortet, was dann je nach Client durchaus ein Problem darstellen könnte.

Kannst Du es evtl. mal mit einem komplett anderen Client probieren? Ich habe nämlich gerade den Verdacht, dass da im Netzwerk/Adapter-Setup des Endgerätes was vergurkt sein könnte.

Kopf → Tisch.

Hätt ich ja auch mal selber drauf kommen können. Es liegt tatsächlich an meinem Handy.
Ich frag mich bloß, warum ich dann aber trotzdem den Nameserver vom Handy aus nicht pingen kann. Und warum das von gestern auf heute nicht mehr funktionierte.

1 Like

Na besser so herum als ein grundsätzliches Problem (Kompatiblitätsproblem) zwischen „Gluon und bestimmten OS“.

Ich muss das Thema noch mal aufgreifen, wobei ich dazu ein anderes „Problem“ habe.

Aktuell funktioniert die Namensauflösung auf beiden meiner FF Router nicht.
Was mich irritiert das in der resolv.conf gar kein externer DNS Server eingetragen ist, sondern nur localhost.
Trage ich manuell z.b. den Google DNS 8.8.8.8 ein, funktioniert die Namensauflösung wieder.

dnsmasq läuft als Service und in der dnsmasq eigenen resolv.conf (/var/gluon/wan-dnsmasq/) ist ebenfalls der Google DNS hinterlegt, der aber scheinbar nicht greift.

root@FF-MG-Backyard:/# cat /tmp/gluon/wan-dnsmasq/resolv.conf 
nameserver 8.8.8.8

root@FF-MG-Backyard:~# cat /etc/resolv.conf 
search lan
nameserver 127.0.0.1

root@FF-MG-Backyard:~# nslookup www.google.de
Server:    127.0.0.1
Address 1: 127.0.0.1 localhost

Nach der Anpassung:

root@FF-MG-Backyard:~# nslookup www.google.de
Server:    8.8.8.8
Address 1: 8.8.8.8 google-public-dns-a.google.com

Name:      www.google.de
Address 1: 2a00:1450:4001:80d::101f fra02s28-in-x1f.1e100.net
Address 2: 173.194.116.152 fra02s28-in-f24.1e100.net
Address 3: 173.194.116.159 fra02s28-in-f31.1e100.net
Address 4: 173.194.116.143 fra02s28-in-f15.1e100.net
Address 5: 173.194.116.151 fra02s28-in-f23.1e100.net

Ich kann in meinem x86-gluon gerade auch nichts mehr mit DNS machen, konkret wget, was ich noch vor ein paar Tagen ging.

Was mich wundert ist, auf einem FF Client (mein Handy) funktioniert das browsen trotzdem. Es dauert jedoch sehr lange bis eine Seite erscheint, weil vermutlich die Namensauflösung hinkt.

Auf dem Router selbst, bekomme ich keinen DNS Namen aufgelöst.

Der Client hinter der VM hat bei mir keine Probleme (mit IPv4, der kann kein IPv6)

Guten Morgen, seit gestern stelle ich fest, dass ich mit mit zwei Android Geräten aus dem Freifunk-Netz keinen Dienst im Internet nutzen kann.

Es werden unter anderem Verbindungsfehler gemeldet, gibt es dazu eine Lösung bzw. ist das bekannt?

Bei den Geräten werden die Google DNS Server genutzt.

1 Like

Hallo @rabaucke!

Ich kann das Problem hier nicht nachvollziehen.
Hast Du mehr Informationen? Traceroute, Ping usw.

Gruß,
Philip

Ping Type: ICMP
Packet Size: default
TTL: default
Timeout: 3000
Count: 3
Interval: 1000
General Timeout: not used

PING google.com
ping: unknown host google.com

traceroute to google.com (google.com), 30 hops max
traceroute: unknown host google.com

Die Anzeige kann nicht stimmen, da wir den 8.8.4.4 noch NIE in Nutzung hatten!

@CHRlS, glaub es mir so ist es, musste den Punkt statisch anklicken um das sichtbar zu machen, sonst läuft das Gerät per DHCP wie auch das zweite betroffene Gerät. Was müsste denn als DNS drin stehen?

Hallo,

der DNS 8.8.4.4 ist im original Android als Standard eingetragen.

Mit dem Network Info II ist die Anzeige besser zu gebrauchen.

Gruß Jörg

@jbacksch, schon klar Jörg. Ich habe hier ein Laptop und ein Chromebook die beide mit einem Primary DNS 8.8.8.8 im Freifunknetz spielen und auch raus kommen. Per Zufall ist mir dann gestern aufgefallen, dass zwei Android Devices dieses nicht tuen mit eben den selben DNS Einträgen bzw. mittlerweile per DHCP mit einem Primary DNS 10.53.16.2 es auch nicht raus schaffen aus dem Freifunknetz. Das Laptop bekommt per DHCP aber immer noch 8.8.8.8. und kommt raus.

Mir stellt sich die Frage wie es anderen Usern geht die sich hier auf meinen Node mit einem Android Device anmelden?

Wie soll ich das feststellen? :smile:

Bitte lasse uns doch einfach einmal ein paar Pings und Traceroutes zu den DNS zukommen, damit wir das Problem eingrenzen können.

Gruß Jörg

Am späten Nachmittag habe ich dann meine Geräte mal genommen und mich an anderen Freifunk Nodes in Dortmund angemeldet. Weiter das Problem mit beiden Geräten kein DNS und kein Entkommen aus dem Freifunk Netz. Privates Wlan funktioniert ohne Probleme.

Eines der Geräte habe ich nun auf Werkseinstellungen zurück gesetzt, es ergibt sich keine Änderung. Trotz geputztem Gerät kein entkommen aus dem Freifunk Netz, Laptop und Chromebook arbeiten ohne Probleme am Freifunk Router.

Frage an die Technik, kann es sein das aus irgendwelchen Gründen die MAC Adressen meiner Android Geräte geblockt/gesperrt werden auf den Freifunk Gateways.

Das Problem ist mir aufgefallen als VPNCilla beim Anmelden am Freifunk Node keinen Tunnel auf das Zielsystem für den Tunnel aufbauen konnte. Ich kann mich daran erinnern, das ich in den letzten Tagen den Tunnelaufbau mehrfach abgewürgt habe wenn ich mich an meinem eigenen Freifunk Node angemeldet habe. Liegen möglicherweise auf den Gateways nicht abgeschlossene VPN Sessions, die dazu führen das meine MAC Adressen blockiert werden.