[Firmware] Neue Firmware für den Rhein-Sieg Kreis

Hallo Zusammen,

anfang des Jahres gibt es eine neue Firmware für den Rhein-Sieg Kreis.

Die Firmware erscheint für alle bereits eingetragenen Städte.

#Änderrungen#

  • Neue Wupper Server (Wupper 5 und 6 wurden hinzugefügt)
  • In einigen Städten war noch das Paket Gluon Legacy eingebaut und wurde entfernt.
  • Vereinheitlichung aller Firmwares. Es gibt nun bis auf den Site Code der Stadt, und der unterschiedlichen Update Server keine unterscheide mehr in der Firmware.

Sobald die Firmwares fertig sind (Für alle Städte bauen dauert etwas) gebe ich nochmal ein Signal.

1 Like

Was genau ist denn Gluon Legacy?

legacy : package
Configuration for the legacy upgrade path. This is only required in communities upgrading from Lübeck’s LFF-0.3.x.

Alles Klar :smiley:

die Server sind nicht neu, sie existieren, seit Wupper definiert wurde. Im Wiki steht, dass alle Server in die Firmware gehören, um die gleichbleibende Qualität zu gewährleisten. Man weiß nie, wann mal wieder was um die Ohren fliegt … außerdem wird bald™ ein Programm implementiert, welches alle bis auf einen fastd-Tunnel für einen Knoten sperrt. Wenn nicht alle Server implementiert wurden, könnte man in die Röhre gucken.

1 Like

@stefan
Habe jetzt in der 2015.1 site von Hennef w5 bis w9 eingefügt.
In der 2015.2 waren die ja schon drin

Wenn ich das Wiki richtig gelesen habe ist 7-9 nur für Wuppertal

Ja du hast Recht!
Aber laut diesem Satz „Bei Bedarf wird die Serveranzahl angepasst, deshalb sollten alle Server in eine Firmware eingetragen werden.“ würde ich sagen, dass alle Server aufgeführt werden müssen?!

@phip
Was ist jetzt richtig?

Es steht zwar schon oben in meinem Text geschrieben (16. Wort im Text) und auch im Wiki

deshalb sollten alle Server in eine Firmware eingetragen werden

um aber alle Klarheiten zu beseitigen und sie erneut klar auszudrücken: „alle“. Dies ist ein Wiki. Wenn es schwammig und unverständlich ausgedrückt geschrieben steht, sollte es „irgendwie“ nach dem Wiki-Prinzip verbessert werden. Also: Attacke. Wenn das neu Geschriebene sich zu weit von Sinn, Realität und Intention entfernt, werde ich die Änderungen bei Gelegenheit der Realität entsprechend wieder gerade biegen. Ist ja ein Wiki …

Ich verstehe aber nicht, woran das Verständnis jetzt gescheitert ist. Ist das Wort „alle“ zu kurz und fällt nicht auf und wird übersehen? Muss es dick geschrieben werden? Gibt es ein Synonym, welches noch eindeutiger ist? Anleitungen zu schreiben ist nicht meine Stärke; ich will ja lernen besser zu werden, deshalb sind diese Fragen ohne Unterton oder zwischen den Zeilen zu verstehen.

Hintergrund: Wird es eng oder es gibt einen GaU, kann ich, indem ich allein nur Wuppertal rette, ganz Domäne Wupper retten, da sie ja identisch aufgebaut ist und jede Änderung nur ein mal getestet werden muss.

Ich habe die Formulierung im Wiki mal angepasst.

Es gibt ja jetzt eine neue Firmware. Muss ich jetzt noch was machen wenn Autoupdate eingeschaltet ist?

Gruß

Hagen

Die Firmware liegt auf dem Server ist aber noch nicht für das Autoupdate freigegeben, weil ich noch nicht dazu gekommen bin sie zu testen.

Wenn jemand die mal aufspielt und sagt das sie funktioniert kann ich sie freigeben…

Hallo!

Rheinbach *-sysupgrade.bin für

  • 841.v9 stable funktioniert
  • 841v10 exp funktioniert
  • wdr1043v2 stable funktioniert

Gruß
Thomas

1 Like

Hallo!

Kleine Ergänzung:
Rheinbach *-sysupgrade.bin für

  • wr842v2 exp funktioniert

Thomas

1 Like

Hallo

Meckenheim sysupgrade.bin für tp-link-tl-wr841n-nd-v9 hat nicht geklappt. keine IP Adresse bekommen.

Wie kann man das debuggen?

Mein Fehler. Die Firmware hat eine falsche MTU … Ich habe die FW wieder von dem Server gelöscht und baue nun neu

kein Thema. dafür machen wir ja die Tests.

Hallo Stefan, welche MTU hast Du genommen?

Ich habe ein experimentelles Image für Rheinbach gebaut ( Stand Master 10. Januar) es läuft so weit gut und ich habe es auch auf die Router in Rheinbach verteilt.

Was mir auffällt ist, dass die Knoten immer wieder kurz von der Karte verschwinden und keine Verbindung anzeigen. Sie sind aber definitiv am Netz und erreichbar.

Die MTU in der 2015.2 Site war korrekt. Lediglich in der Stable Site war sie falsch.

Das die nodes ab und zu auf der Karte als Offline gezeigt werden ist ein bekanntes Problem. Das macht aber (bis auf die Optik) nichts.

Hallo,

mir ist dieses „Verschwinden“ nur noch nie so stark aufgefallen. Es war mit der v2016.1 beta (oder wie immer man sie nennen will) sehr auffällig.