Firmware TP Link WR841N V11.1

Ich bin ja ganz neu im Freifunk Thema und habe ganz unbedarft den Router bestellt, der in der Anleitung von der Domäne Niersufer als „Standardrouter“ angegeben ist. Der zweite angegebene Router ist ja neu gar nicht mehr zu bekommen. Über die Versionsnummern habe ich mir erst Gedanken gemacht, als die beiden Router hier waren und sich die V9 nicht in den V11.1 Router einspielen ließ. Ich war eigentlich von einer Art „PlugandPlay“ ausgegangen. Router kaufen, Firmware einspielen, aufstellen, einschalten, läuft. War wohl leider nichts! Selbst mit dem als „Standardrouter“ angegebenen Gerät nicht. Was mich jedoch arg wundert. Die V11 scheint schon seit einem halben Jahr auf dem Markt zu sein und man findet dazu in den Foren fast nichts.
Das „Nierufer“ hier arbeitet ja noch mit mit der Firmware V0.7.7. „Flachland“, Kreis Wesel ect. mit V0.8.3.1. Dort ist auch eine Firmware für den WR841N V10, aber auch nichts für den V11 (11.1). Muss sich hier jede Domain selber um die entsprechenden Firmware für alle Router kümmern?
Was nützt es mir, als neuer „Anwender“ und „Unterstützer“, wenn hier 30 verschiedene Router unterstützt werden, diese aber nur in „Uraltversionen“ aber noch nicht einmal das angegebene empfohlene „Standardgerät“ in der aktuellen Version. Wenn die neue Version des Routers erst gerade auf dem Mark wäre, vollkommen verständlich, aber ein halbes Jahr? Rumliegen hat ja wohl kaum jemand so ein Gerät, da doch fast alle mit irgendeiner Version der Fritz.Box privat arbeiten. Es bleibt demzufolge nichts anderes übrig, als ein passendes Gerät neu zu kaufen und woher soll man wissen, welche Versionsnummer gerade aktuell ist und z.B. von Amazon geliefert wird.
Ich finde es super und ganz toll, das Daniel sich her gemeldet hat und versucht etwas zu basteln, leider scheint das ja nicht ganz so einfach zu sein, wie ich in der Essener Gruppe von ihm lesen musste.
Mir wird so langsam klar, warum die Freifunkzellen hier in KR hauptsächlich aus dem gewerblichen Umfeld kommen. Da kümmert sich dann ein „Profi“ für viel Geld um die Einrichtung und die Firmen sehen das als Werbemaßnahme. Aber so bildet sich dann kein Netzwerk, sondern es werden kleine einzelne Inseln bleiben.
16€ plus Strom für den WR841N haben bestimmt auch viele private Anwender über, aber ich möchte nicht wissen, wie viele das Ding auch einfach wieder zurück geschickt haben, weil die Firmware nicht passte. Die wenigsten sind doch „freakig“ genug um sich in Foren zu tummeln, und nach Hilfe zu fragen. Dann wird halt, wenn es nicht funktioniert,
kein Freifunk Router aufgestellt.
Ich finde die Idee super und auch das Engagement der Einzelnen hier. Nicht, das das jemand falsch versteht!
Dennoch bin ich der Meinung, das es doch nicht so schwierig sein kann, für die aktuelle Version des „Standardgeräts“ eine Firmwareversion zu basteln, in der dann jede Domain nur noch Ihre Daten ändern muss. Wenigstens für ein Gerät, das dann in der entsprechenden Anleitung angegeben ist.
Ansonsten wird das nie eine Massenbewegung, sondern wird ein System bleiben für die wenigen Fachleute und Freaks.
Ich bin mir sicher, das ich einige Nachbarn dazu überreden könnte die 16€ für den WR841N zu investieren, aber ich weiß jetzt schon, das ich dann für jeden einzelnen das Flashen übernehmen müsste. Wäre ja auch nicht das Thema, wenn es denn funktioniert, ist ja nicht so, das ich von der Materie gar nichts verstehe.

Ich hoffe, das Daniel das in den nächsten Tagen noch irgendwie zustande bringt und ich würde mich riesig darüber freuen! Sein „Dienst“ ist ja weniger für mich, als für die Allgemeinheit. Ich habe ja meinen Zugang. Leider kann ich das nicht.
Wenn nicht, dann ist es halt so und die beiden Router gehen erst einmal wieder zurück. Vielleicht lager ich sie auch erst einmal ein. Das werde ich mir dann noch überlegen. Ich werde dann ab und zu mal wieder vorbei schauen und sehen wie es sich entwickelt. Vielleicht werde ich auch versuchen meinen Ubiquiti Unifi AP umzuflashen. Ich wollte dies aber eigentlich erst einmal mit 16 investierten Euros probieren und nicht gleich das fünffache in den Sand setzen, wenn es denn schief geht.

In diesem Sinne, danke erst einmal an Daniel und vielleicht schaue ich ja mal im August oder September im 35blumen vorbei. Am 6. Juli kann ich definitiv nicht.

Ist jetzt doch ein wenig länger geworden als gedacht, aber ich bin doch ein wenig enttäuscht, das es nicht so funktioniert, wie auf der Krefelder Freifunkseite angegeben. Kein Wort davon, das die neuen Versionen (für die V10 gibt es am „Niersufer“ ja auch nichts) vom empfohlenen WR841N nicht unterstützt werden.

Viele Grüße und nichts für ungut
Lutz

Hallo @ElBe,
Hier im Forum kamen Anfang April16 die ersten Berichte das der 841V11 geliefert wird. Vor einen halben Jahr gab es die ersten Firmwaren für den V10.
Die Revisionszyklen bei TP-Link sind kurz, Hut ab vor den Openwrt/Lede, Gluon und Firmwarebauer, da nach zukommen… das ganze will ja entwickelt, getestet und praxiserprobt werden, bevor das großflächig verteilt wird.

Hallo Lutz,

ich kann verstehen, dass du etwas frustriert bist. Ich würde gerne noch zwei Punkte ergänzen, über die du dir vielleicht noch keine Gedanken gemacht hast.

Im Einzelhandel kann man leider nur Produktnamen kaufen, keine Hardwarerevisionen. Wer sich im Linuxbereich ein wenig auskennt, kennt das. Unter demselben Produktnamen stecken oft ganz verschiedene Produkte, weil ein Hersteller findet, dass die Chipsätze gleichwertig sind. Der Hersteller liefert dann auch einen Treiber, der beides kann. Die Hersteller haben dabei einen zeitlichen Vorsprung. Die Entwickler von OpenWRT bekommen die Hardware erst das erste mal zur Hand, wenn sie jemand auf dem freien Markt zufällig erwischt, dann erst kann die Entwicklung beginnen.

Allerdings wurde der V11 ziemlich schnell unterstützt, anders als der V10 damals, wo es einige Probleme gab. Dass es für deine Community noch keine passende Software gibt, ist schade. Aber man kann sie in der Regel in wenigen Minuten bauen, bzw. anstoßen und dann darauf warten, weil das Gerät eben schon voll unterstützt wird.

Grüße
Matthias

@ElBe du kannst da kaum was „in den Sand setzen“, fast jeder Router / AP lässt sich auf die eine oder andere Art wieder retten, selbst wenn das Flashen schief gegangen ist.
Was deinen 841N v11 betrifft, kommt Zeit, kommt Rat. Bei neuer Hardware dauert es immer ein bisschen, bis sie unterstützt wird. Die Leute machen das größtenteils in ihrer Freizeit und bekommen dafür kein Geld, das sollte man im Hinterkopf behalten.

Ich hab mal die site.conf umgebaut: GitHub - MPW1412/site-ffkk

Wenn ich nichts dummes gemacht hab und die Abhängigkeiten klappen, hast du in ~25 min die Firmware.

1 Like

Danke für die schnellen Reaktionen!
War ja, wie gesagt, alles nicht böse gemeint, habe nur meinen Gedanken im leichten Frust freien Lauf gelassen.

@lumo Schau mal hier: TP-Link TL WR-841n-v11 vom November 2015. Das ist jetzt mehr als ein halbes Jahr. Wann, welche Version wie im Handel vertreten war kann ich natürlich nicht nachvollziehen.

@MPW Ich schau mir das mal an, bin ja durchaus gewillt, innerhalb meiner Möglichkeiten, selber Hand anzulegen. Komisch ist nur, das @rippendaniel , der das ja nicht zum ersten mal macht, anscheinend Probleme damit hat, wie er im Essener Forum schreibt:

Danke jedenfalls.

@MPW Ich habe gerade einmal in Deine Dateien hinein gesehen. Ich gehe jetzt erst einmal davon aus, das „Freifunk Kempen“ (ffkk) die „Niersufer“ Domäne ist, an die sich die Krefelder angeschlossen haben. Ansonsten haben die Krefelder alle FF-KR im Namen.

Da ich kein Linuxer bin und auch keinen Rechner mit Linux hier stehen habe, ist das zwar nicht ganz „Bahnhof kofferklauen“ für mich, aber fast. D.h. ich müsste mich erst einmal in das ganze System einarbeiten.
Wenn ich ehrlich bin, habe ich dazu im Moment keine Zeit und die Lust ist auch nur begrenzt, mich jetzt über Stunden in das Herstellen und Kompilieren einer Firmwaredatei einzuarbeiten. Da fehlt mir einfach zur Zeit noch das Basiswissen. Die Konfigdateien sind ja zu verstehen, aber was fange ich damit an? ;-D
Ich halte jetzt also schön die Füße still, warte darauf, ob irgendwann meine Community das bin-File für die V11 zur Verfügung stellt und werde dann wohl von Amazon V12 oder V13 geliefert bekommen…
Nein, Scherz beiseite, ich lege mir die beiden V11.1 er ins Regal und warte ab. Die Überlegung ist, ob ich nicht noch 5 Stück dazu bestelle, damit ich beim nächsten Mal nicht tatsächlich V12 oder V13 geliefert bekomme und das selbe Problem wieder auftritt.

Ich hoffe, dass das richtig und aktuell ist. Ich hab ja auch keine Ahnung, wo die Firmware liegt. Ich hab einfach nur gegoogelt und das gefunden.

Ich habe gerade das:

gefunden.

Sorry, da bin ich raus! ;-D

Wie oben geschrieben,ich werde warten bis was fertiges kommt und wenn nicht, dann halt nicht.

@ElBe, probier mal die hier: https://mpw.no-ip.biz/freifunk/ffkk/

(factory, wenn du noch die Originalfirmware hast!)

Danke!!! Ist zwar wie gesagt Kempen und nicht Krefeld, aber das wäre mir egal. Liegt ja gleich um die Ecke.

Firmware ist drin und startet auch. Leider konnte ich im Wizard die Internetverbindung über meinen Zugang nicht frei schalten. Der entsprechende Hacken ließ sich nicht setzen.
Habe aber erst heute Abend wieder Zeit, vielleicht finde ich ja was im Expert Mode.
Der erste Ansatz ist jedoch vielversprechend.

Werde mich melden

Fehler gefunden, lag an meinem alten Browser auf dem Netbook. Mit anderem Browser konnte ich die Felder anklicken.
Werde heute Abend dann mal testen :smiley:

1 Like

Wo liegt denn die richtige site.conf? Dann bauen wir die auch. Ist doch kein Problem.

Hast du mal einen Link zu deiner Community?

Hi,

ich teste gerade eine neue Stable Firmware sobald die Tests gut verlaufen sind wird die Deployed.
Dieses ist dann auch mit dem 841v11 kompatibel.

@ElBe Ich habe dir gerade eine PM mit einem Link geschickt.

Wenn auch zukünftig Fragen bzgl Firmware sind könnt ihr euch aber auch direkt an das Niersufer Admin Team wenden.

www.freifunk-niersufer.de
oder im speziellen zu Krefeld:

Gruß
Thomas

@MPW Den Link zur V9 habe ich ja oben angegeben, das ist die Krefelder Community. Ich habe aber gerade gesehen, das die Kempener beim letzten Update wohl auch vom Ruhrgebiet zum „Niersufer“ gewechselt sind. Von daher ist alles gut! Sind jetzt alle in der gleichen Karte. Da muss m.E. nichts mehr gemacht werden.

Der Router scheint zu laufen. WLAN it ok, Verbindung ist da und er wird in der Karte angezeigt.
Wenn ich mir die Statistik so anschaue, ist mein Router der Einzige im „Niersufer“ mit V11 und auch der Einzige mit 2016.1.5+0.7.2b

Erst einmal ein dickes DANKESCHÖN!!!

Jetzt aber noch eine Frage zum Verständnis. Wieso hast Du 0.7.2b genommen. Für mich als Laie sieht das so aus, als ob das die älteste Basis ist. Die meisten nutzen 0.7.7 aber auch schon viele 0.8.2.

Dann noch eine Frage zur Karte, hinter meinem Router wird in der Liste der neuen Clients, als einer von ganz wenigen, ein geschlossenes Schloss gezeigt. Die meisten haben dort gar nichts bzw. nur den Marker für die Koordinatenanzeige oder eine Weltkugel. Ist das die Anzeige dafür, das ich dem Remote Access Zugang ein Passwort verpasst habe?

Ich werde jetzt erst einmal testen, sieht für den Augenblick aber sehr gut aus.
Danke noch einmal!

@MPW Danke für deine spontane Hilfe. Ich finde das aber den falschen weg.

Außer du willst die Firmware für immer und ewig updaten.

Ich fände es echt besser wenn auf uns verwiesen würde und wir dafür eine Lösung finden (die es gibt)

Gruß
Thomas

Hi @ElBe

finde ich gut das du dich für Freifunk interessierst.

Wir benutzen im Niersufer aus gründen eigentlich keinen 2016er FW.
So wie ich das sehe hat sich an den Gründen bis heute nichts geändert :smiley:
http://freifunk-niersufer.de/vorerst-kein-gluon-2016-1/

Ich würde dich bitten die Firmware zu nehmen, die ich dir geschickt habe. Diese wird auch gepflegt und aktuallisiert.

Gerne würde ich dich auf unserem öffentlichen Treffen am ersten Mittwoch nächsten Monats mal kennen lernen :smiley:

Wenn du magst komm doch vorbei.

Gruß
Thomas

Jetzt aber keinen Streit hier :smiley:
Ich habe ja hier extra im Krefeld Forum nachgefragt …
MPW war einfach schneller als als Ihr … und es funktioniert.

Wie oben schon geschrieben, kann ich nächsten Mittwoch nicht, möchte meinen Geburtstag schon etwas anders feiern ;-D

Komme aber spätestens zum Treffen im September gerne mal vorbei. August ist ja Urlaubszeit und wir haben vor irgendwann im August noch weg zu fahren

Bitte. Für mich ist Firmware halt was, was es einfach gibt und was da sein muss, sonst hat man den Ärger, der hier aufgeschlagen ist. Das führt einfach zu Frust, weil der Freifunk-Beginner nicht wissen kann, was Revisionen sind. Wusste ich auch nicht, bevor ich mit Linux angefangen habe.

Ich kenne das halt gar nicht, dass man da Arbeit in die Firmware steckt. Gluon + site.conf kompilieren und fertig. Dass jetzt eure eigene noch besser optimiert ist und dass man da tolle Dinge tun kann, will ich gar nicht abstreiten. Aber stumpf Gluon 2016 für einen 841er V11 zu haben kann gefühlt vier Monate nach Erscheinen des Geräts nicht so schwer sein.

Jeder kann die Firmware bauen, das ist doch gerade das tolle. Und wenn ihr dann eure Spezialbastellung fertig habt, dann aktualisiert sich der Knoten von selbst.

Grüße
Matthias

1 Like