Futro S550 2. Netzwerkkarte

Hallo Freifunker,

ich möchte gerne den Futro S550 als offloader nutzen.
Firmware habe ich drauf bekommen.

„Hostname
ffs-0019995b6982
Hardware-Modell
Mobile AMD Sempron™ Processor 2100+
Gluon-Version
v2016.1.3
Firmware-Release
0.7+2016.04.01-03.33-g.b704308-s.b00a7b1
Site
Freifunk Stuttgart“

Nun komme ich mit der 2ten Netzwerkkarte nicht zurecht.
Vielleicht könnte mir jemand helfen, der bisschen mehr von Linux versteht als ich.

Telnet spuckt mir bei „ifconfig“ folgendes raus:

root@ffs-0019995b6982:/# ifconfig
br-setup Link encap:Ethernet HWaddr 00:19:99:5B:69:82
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::219:99ff:fe5b:6982/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:393 errors:0 dropped:0 overruns:0 frame:0
TX packets:142 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:31231 (30.4 KiB) TX bytes:26623 (25.9 KiB)

eth0 Link encap:Ethernet HWaddr 00:19:99:5B:69:82
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:464 errors:0 dropped:0 overruns:0 frame:0
TX packets:135 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:60845 (59.4 KiB) TX bytes:25805 (25.2 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:76 (76.0 B) TX bytes:76 (76.0 B)

root@ffs-0019995b6982:/#

Wurde da die 2te Netzwerkkarte erkannt?

danke für eure Antworten.

Hallo,

es klingt ein bisschen so, als hättest du den Futro erst mit einer Netzwerkkarte in Betrieb gehabt und dann die zweite installiert.

Gluon erkennt nur beim aller ersten Start die zweite Netzwerkkarte. Wenn du das Image da nur mit einer gestartet hast, musst du es komplett überformatieren. Also CF-Karte in einen PC und neu das Image draufbügeln.

Grüße
Matthias

Habs grad neuinstalliert, alles beim alten.

Die PCI Netzwerkkarte ist eine: RTL8169SC

Zeig mal bitte die Ausgabe von

ip a s

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: teql0: mtu 1500 qdisc noop qlen 100
link/void
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-setup qlen 1000
link/ether 00:19:99:5b:69:82 brd ff:ff:ff:ff:ff:ff
4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000
link/ether 04:8d:38:c2:53:4f brd ff:ff:ff:ff:ff:ff
5: br-setup: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue
link/ether 00:19:99:5b:69:82 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.1/24 brd 192.168.1.255 scope global br-setup
valid_lft forever preferred_lft forever
inet6 fe80::219:99ff:fe5b:6982/64 scope link
valid_lft forever preferred_lft forever

Sieht eigentlich gut aus. Du musst dich jetzt an die zweite (also die zusätzlich eingesteckte) mit einem PC über LAN verbinden und ganz normal über den Browser das Gerät konfigurieren.

Grüße
Matthias

ok.
Also die Onboard karte ins „heimnetz“ und die zusätzliche ist dann das „freifunk“ netz?

Die primäre Karte ist quasi der blaue Port, die zweite der gelbe Port, wobei die Erkennung glaube ich nicht 100% deterministisch ist. Es könnte also auch genau andersherum sein.

Du müsstest jedenfalls erstmal gucken, auf welchem Port du das Gerät konfigurieren kannst. Ich tippe mal auf die zweite Karte.

ist bei mir genau anders rum. kann nur über die „onboard“ karte zugreifen mit 192.168.1.1

über die „pci“ karte komme ich nicht drauf.

Okay, hat es jetzt geklappt?

also ich bin drauf.

die PCI Karte hängt am Netzwerk. Werde jetzt mal den Key zum freischalten verschicken und dann ausprobieren.

Muss mich noch mit Mesh auf dem WAN-Port und LAN-Port ect. schlau machen, was ich da aktivieren muss.

Ich möchte hier 3 Häuser mit WLAN versorgen.
Deswegen auch der Offloader mit dem werden die TP-Links WR940N per Lan verbunden und an die per LAN Verbunden WR940N werden über WLAN noch paar verbunden. Nur weiß ich noch nicht genau welche Mesh ich aktivieren/ deaktivieren muss…

Dann musst du LAN-Mesch aktivieren. Darüber kannst du dann weitere Knoten verbinden.

ok mache ich.

und auf den Routern?

also offloader (mesh over lan) - per kabel an - switch - per kabel - tp-link(blaue buchse) ?

Ich habe den Eindruck, als ob das alles schon diskutiert worden wäre im Thread:

Inklusive des Problems, dass bislang die meisten Futros eigentlich gut mit einer Netzwerkkarte (plus dem Onboard-Ethernet) auskommen.
Wer mehr als zwei Ethernet-Interfaces braucht, der wird sich in der Regel auch nicht mit drei begnügen wollen, sondern gleich 4 oder mehr Batman-Interfaces haben wollen. Und dann sollte man besser in Richtung Vlan + Switch als Breakout-Box schauen.

Ich würde das immer über zwei Netzwerkkarten machen, weil es updatefest ist.

Auf den anderen Knoten kannst du dir WAN- oder LAN-Mesch aussuchen. Bei ersterem den Futro über den blauen Port verbinden, bei letzterem über den gelben.

Ohne LAN-Mesch kannst du über die gelben Ports noch PCs oder andere feste Geräte über Freifunk anbinden. Dafür hast du bei LAN-Mesch die Möglichkeit mehrere Geräte anzubinden. Hat eben beides Vor- und Nachteile.

Es fehlt nur nach wie vor eine (dokumentierte) Möglichkeit, wie man überhaupt zwei Netzwerkkarten in den Futro hineinbekommt.
Unter der Voraussetzung, dass man den Deckel wieder schließen möchte.
Ich selbst habe so eine Broad-com-Dualport, um 3 Ports in den Futro zu bekommen, damit ich (updatefest) br-wan, br-client und br-mesh herausbekomme „ohne vlan“.
Aber eventuell gibt es ja irgendwo einen „Extended Deckel“ für Futros, um einen 2slot-Raiser einzusetzen.

Der Themenstarter hatte den Teil doch schon fertig.

Für mich liest sich das so, als ob er bislang nur eine Netzwerkkarte eingesteckt hätte und dazu die Config suchte.
Wie man das dann mit einer zweiten Karte(also einem dritten physikalischen eth) machen würde war zumindest bislang noch nicht Thema.

Du verwirrst mich. Welcher Futro hat denn zwei Netzwerkkarten?

Hab gerade mit ihm geskypt, funktioniert jetzt soweit alles. Nur der Durchsatz ist immer noch bescheiden.

Ich weiss es nicht. Das ist der Titel des Threads.
Die Setups die ich kenne haben in der Regel eine Netzwerkkarte, so dass es neben dem Onboard-Ethernet noch eine zweite (physikalische) Schnittstelle gibt und man sich das Vlan-Zeug spart.
Und dort wo ich auch noch br-client brauche, da nehme ich eine Doppel-PCI-Karte, um dann in Summe 3 Interfaces zu haben.

Es gibt diese Flex-Raiser. Aber wenn die dann auch 20€+ kosten, dann lohnt sich das schlicht nicht. Dann kann man auch gleich eine Dual-Ethernet-PCI nehmen.

Nur das ist leider nicht besonders preiswert (gemessen am Preis des Futros)
Eine Möglichkeit, da irgendwie (z.B. mit einem Flachbandkabel…) eine 2. Netzwerkkarte „als Hack“ hineinzubriegeln: Ich wäre mehr als interessiert daran.