Gluon (Lede) und Archer C2600

Da müssten nun mal die dechnischähn Äxbärten hier im Forum ran. Wieso, weshalb, warum und überhaupt. Viel wichtiger, wie man es beheben sollte oder kann. Ich hoffe @MrMM schlägt mich nicht Ihn mal so zu taggen :stuck_out_tongue:
Entweder weiß er es oder er kennt den, der es weiß :wink:

Mit den von @Katerchen verlinkten Artikeln hat das Thema sicher wenig zu tun, da ja schon Lede drauf läuft.

Ich würde einmal das offizielle Lede-Release testen, und wenn das dort behoben ist, dann vll noch 2016.2.4 von gluon.

Ansonsten immer gut ist das flashen der Firmware entweder neu, oder einer anderen Community, um Fehler beim bauen auszuschließen.

1 Like

@Brother_Lal
Gute Hinweise.
Bei gluon wird ipq806x nur vom master branch unterstützt.
Die Idee mit einer anderen Community ist gut, aber wer hat schon ipq806x mit broken=1 ?
Ich hoffe auf @NeoRaider.

Ohne jegliche Ahnung spiele ich nur die Vermittlung für Tante Google:
https://mgmt.saar.freifunk.net/openwrt/snapshots/trunk/ipq806x/generic/packages/management/

Daraus schließe ich die Antwort ist Freifunk Saar - nur ist mir zu hoch. Schau einfach mal … :smile:

Suchbegriff: ipq806x freifunk
Da kommt noch einiges mehr bei Freifunk Saar als Ergebnis staun

In der Hoffnung dass ich nur ansatzweise verstehe, wovon Ihr da redet, hatte ich diese Suche mal gestartet. Schlauer bin ich nun nicht :stuck_out_tongue:

@Katerchen

Leider falsch.
Nach meinen Recherchen setzt Freifunk Saar aktuell 1.4.0 / gluon-v2016.2.4 ein und zwar stable/beta und exp. vom 22.3.17. D.h. kein ipq806x. Dein Link führt zu OpenWrt ??

ipq806x zeigt auf die CPU Qualcomm Atheros IPQ8064 (verbaut im Archer C2600).

Wie ich oben geschrieben habe, ist der gluon Support relativ neu und nur im master branch zu finden

Welchen der vielen ETSI300328-Threads meinst Du?
Den hier?

Ansonsten:

Meinst Du solche Commits?

https://git.lede-project.org/?p=source.git;a=commit;h=d1a2c3f9b1f79baca2d16b8bf8bd6c409ee56e2e

(und nein, es hat nichts mit dem Thema dieses Threads zu tun, sorry.)

@Seligenthaler versuche mal in der /etc/config/wireless beim mesh Netz disabled =1 zu setzten.

Ich hatte etwas vergleichbares mit konfiguriertem IBSS Mesh Netz auf einem Gerät dass dies nicht unterstützt.

Bitte einmal:

  • Issue im Gluon-Projekt auf Github machen
  • Inhalte von /etc/config/network, /etc/config/wireless und die Ausgabe von logread anfügen

Danke!

4 Likes

@MrMM
Ausprobiert - keine Änderung. Bin für alle Hinweise dankbar.

@NeoRaider
Issue 1088 erstellt

Update, Firmware jetzt:
Gluon: v2016.2-244-g13c61d9

Laß’ das bitte. Googlen können die meisten hier hinreichend, und illegal ist da auch nichts.

Gluons master-Branch ist nicht zwingend funktional, die Fehlermeldungen besser in einem Gluon-Issue aufgehoben als hier für Verwirrung zu sorgen, imho.

3 Likes

@RubenKelevra
Bist du mit deinen C2600 weitergekommen?

Bist du mit deinen C2600 weitergekommen?

Jain, konnte noch nichts testen. Aber schau mal hier:

https://github.com/freifunk-gluon/gluon/commit/57070a56be6080bebb879058a787713bb42a593f

Lieben Gruß

Ruben

@RubenKelevra
Genau damit (dein Link) habe ich ja meine Version gebaut. (s.o.)

Testen hört sich so an als ob du eine Version installiert bekommen hast und läuft bei dir batman?
Hast du auch das Boot-Problem?
(Habe im Git dein damaliges Issue gelesen)
Schönen Gruß zurück
Clemens

Ich hatte mal OpenWRT drauf, das lief (nur halt ohne passende WLAN-Treiber).

Gluon wollte damals nicht kompilieren, seit dem Ticket ist von meiner Seite nichts mehr passiert, hab schon genug Zeit investiert gehabt und 0 Unterstützung dafür zurück.

Alles was LEDE angeht kann ich dir nicht beantworten, hab noch keine Hardware damit ausgestattet. Der C2600 liegt hier im Schrank bis Gluon damit läuft.

Gruß

Ruben

So einen passiv-agressiven Kommentar halte ich für wenig zielführend. Wie wär’s stattdessen mit konstruktiver Kritik? :wink:
Keine Ahnung, wieso genau du gefrustet bist, aber meine Erfahrung ist da eine gänzlich andere. Ich habe viel und gute Unterstützung von @NeoRaider bekommen, als ich am LEDE-Support für den D-Link DIR-869 mitgearbeitet habe. Wenn man Spaß am Tüfteln, Durchhaltevermögen und eine hohe Frustrationstoleranz hat, dann kann man sich der Aufgabe, an der LEDE-/Gluon-Unterstützung für ein neues Gerät zu arbeiten, stellen - mir hat’s Spaß gemacht und ich habe viel dazugelernt.

Das war in keiner Weise aggressiv gemeint.

OpenWRT kompilierte wunderbar, Kiste lief und deswegen sollte Gluon kein großes Hindernis sein.

Nachdem ich den gesamten Branch von OpenWRT durchforstet hatte und alles zusammen gesammelt in ein großes Patchset, damit auch die ältere OpenWRT-Version das Target kompilieren kann, welches Gluon damals verwendet hat musste ich feststellen, das Gluon nach allem Kompilieren am Zusammenbau des Images scheiterte.

Ich hab noch einige Stunden herum gesucht aber das eigentliche Problem nicht gefunden. Dann hab ich das entsprechende Ticket erstellt.

Ich erwarte nicht unbedingt Hilfe bei solchen Problemen, wenn aber Zusagen wie, in zwei Wochen hab ich dafür Zeit, gemacht werden, das ist es einfach frustrierend wenn dann doch über Monate nichts passiert.

Insbesondere da die Hardware durchweg interessante Spezifikationen hat.

Auf die Bitte hin die Patches per Mail einzureichen ist übrigens auch, außerhalb des Tickets, keinerlei Antwort mehr eingegangen.

Insgesamt war meine Antwort hier mit keiner Wertung verbunden, das ist ein Freizeit Projekt und Freizeit bedeutet auch, jeder investiert die Zeit die er hat und tut das wo er Lust und Spaß dabei hat.

Jemanden dafür zu kritisieren auf meine Problemlösung keine Lust zu haben liegt nicht ferner von dem was ich ausdrücken wollte.

Hätte ich ein Problem mit @Neoraider oder seiner Arbeit, würde ich diese Kritik ihm gegenüber äußern uns nicht öffentlich in einem Forum.

Im Gegenteil, er macht eine unglaublich umfangreiche und verantwortungsvolle Aufgabe in unserer Community und sollte dafür öfter gelobt werden!

Die Frage die sich hier gestellt hat war aber, ob ich helfen kann - und das muss ich verneinen. Ich hab derzeit keine Lust mehr die Hardware aus dem Schrank zu kramen und weiter herumzudoktorn, das können andere erstens viel effektiver und zweitens mit viel mehr Spaß dabei.

1 Like

Hallo zusammen,

habe gerade den Archer C2600 mit Gluon auf Lede Basis 2017.1.1 ausprobiert, jedoch bestehen die genannten Probleme immer noch. Bei Reboot schaltet der Router ab, VPN wird nicht aufgebaut. An der Konfig kann es nicht liegen, habe andere Router mit dem gleichen Build laufen WDR4900 z.B. Es handelt sich bei meinem C2600 auch um Version 1.1.
Per SSH komme ich ja drauf, im Logread fiel mir auf: Failed to resolve hostname ‚wetter-1.ff-en.de‘.
Vielleicht hilft das irgentwie, komplettes Logread kann ich auch gern bereitstellen.

Hier ein erstes Fazit mit Gluon 2018.1:

  • Reboot-Problem beim C2600 v1.1
  • Mesh-VPN via Tunneldigger/L2TP läuft
  • WLAN-Meshing läuft ebenfalls
  • Mesh-on-LAN-Config muss noch gefixt werden
  • Client-Netz läuft noch nicht richtig
  • LEDs funktionieren noch nicht richtig

Ich baue gerade den Gluon-Master, der basiert auf der neuen OpenWRT-Version. Stay tuned.

3 Likes

Das Gerät läuft jetzt mit dem aktuellen Gluon-Master (Stand 2018-07-13)
https://karte.freifunk-muensterland.de/map36/#!v:g;n:18a6f758646a

  • Client-Netz auf jeden Fall stabiler, aber wohl noch mit Luft nach oben
  • Reboot klappt jetzt auch beim C2600 v1.1
    • Vermutung: firstboot muss nach dem Upgrade von LEDE 17 auf OpenWRT 18 ausgeführt werden, um das Reboot-Problem zu beheben.

Was genau bedeutet das? sehr vage Angaben, die zu einer möglichen Lösung wenig nützen :wink: