Hotspot-Only hinter x86-gluon (Fritz Box hinter Offloader auf QNAP Virtu. Station)

Ein if nachträglich zu aktivieren geht nicht, das muss beim Setup bereits vorhanden sein. Also if in deiner VM aktivieren und das Freifunk Image neu aufspielen (Einstellungen NICHT beibehalten).

Ansonsten ist es ganz easy, Fritzbox per LAN dran (WAN Port wenn vorhanden) DHCP aus und fertig.

Hmm, das habe ich bislang immer nachträglich auf UCI-Ebene gemacht.

notfalls (warum auch immer) muss man halt manuell an /etc/config/network dran.

(Ich habe aber nicht verstanden, was hier eventuell spezielles „für Fritzbox“ oder „für QNAP“ beachtet werden muss. Ich kann nur für normales Gluon sprechen, also egal ob nun x86-image oder andereres „normales Gluon-Profile“. Vermutlich ist bei dieser „Virtu-Station“ noch irgendwas besonders speziell.)

eth1 ist doch schon vorhanden, dann sollte das doch gehen? Ich frage, weil ich eine änliche Sache habe…

Das ist die Frage.
Je nachdem was da gebaut wurde. Ist das ein LXC mit batman-adv als nachkompiliertem Kernelmodul im Hostsystem?

(Bei der Fritzbox ist meines Erachtens nichts spezielles einzustellen. Allerdings kann die natürlich kein Mesh-Netzwerk. Daher eigentlich chancenlos das Unterfangen.)

Meine nachträglich hinzugefügte Netzwerkschnittstelle konnte ich mit Hilfe von einem Artikel hier einfach aktivieren:

uci add_list network.client.ifname=eth1
uci commit network
reboot

Und was unglaublich ist, nachdem ich meine alte Fritzbox im Client Modus mit der zweiten QNAP NAS Schnittstelle verbunden habe, bin ich online. My IP Info sagt, dass mein ISP Freifunk Rheinland ist.

In 2 Tagen geschafft, ohne einen Router zu kaufen. Mich hat immer geärgert, dass man die FBen nicht nutzen konnte. Habe derer mittlerweile vier.

Habe zwar noch nicht ganz kapiert, wie alles zusammenspielt, aber was soll’s :wink:

Solange die FritzBox kein NAT macht und du Mesh-on-LAN/Mesh-on-WAN ausgeschaltet hast, prima. Nur etwas schade um den Stromverbrauch, aber naja.

Und schade um das fehlende Freifunk-Mesh-Netz.

Ich habe den Thread-Titel mal angepasst, da es hier ja weder um Spezialitäten der Fritzbox, noch um solche von QNAP geht, sondern schlicht darum, Freifunk als ClientAP-Only Hotspot Betrieb zu nutzen.)

2 Likes

Gibt aber auch weit und breit keine anderen Freifunker. Wenn ich es richtig verstehe, macht es also keinen Unterschied.
AVM macht doch mit seiner neuen Firmware Werbung weil sie mesh können, kennt einer die eingesetzte Technologie?

Wie komme ich jetzt eigentlich auf die Fritzbox Webseite? fritz.box geht ja nun nicht mehr :frowning:

wenn du den dns server geändert hast unter netzwerkeinstellung ist die seite auch nicht mehr erreichbar

Welcher Stromverbrauch? Mein QNAP NAS läuft eh und ob jetzt eine FB oder ein anderer WLAN Router sendet, macht bestimmt keinen großen Unterschied.

Aber eigentlich™ ist es doch Sinn dess Unterfangens, lokale Wolken zu bauen. Und ebe nicht nur „cheapest Hotspot-Provider ever“
Auch wenn es derzeit niemand gibt, der meshed, wenn man AP-only fährt, dann bleibt das auch ewig so.

2 Likes

Ist genau mein Setup. Nur dass ich einen Futro habe als Offloader und außen noch einen AP hängen habe, der mesht. Ich bin auch der einzige… bis auf einen Nachbarn. #meshistmuss finde ich.

Wie ist dein AP am Offloader angebunden? Über br-client oder über lan?
Glaube ich habe bei dir abgeschaut, dann müsste es br-client sein. Wie hast du dann mesh enabled oder geht über br-client automatisch?

Gar nicht, siehe Eingangsposting.
Das ist „AP-Hotspot-Only“.

Genau, aber dass soll sich ja mal ändern. Und da ich ein Bastelbruder bin, mit dem Equipment welches ich habe :wink:

Kaufen kann jeder. Da lernt man nichts dazu und macht keinen Spaß.

1 Like

Dann wirst Du hier das Scheitern lernen.
(Sorry, wenn ich Dir das so barsch vor den Latz knalle. Aber es wird leider die Realität sein. Du hast keine Chance, einen nutzbaren Wifimesh-Router zu bauen, wenn Du nicht mindestens einen „normalen, funktionsfähigen“ Gluon-Node zum Testen danebenstellst. In der Regel wirst Du sogar zwei Stück brauchen. Da Du aber ncihts kaufen möchtest und Du ja sagst, dass Du keine Gluon-supporete Hardwarware hast: Keine Chance für Dich.)

Nunja. ›Fritten‹ sind nett, aber eben für Freifunk nur bedingt tauglich (kein Mesh, und da kein offener Treiber vorhanden und IIRC über die AVM-Tools kein AdHoc aktivierbar, bleibt da auch so). Natürlich ist Deine Fritzbox nun ein Hotspot und die Leute daran tauchen als Clients Deines Offloaders auf; und vielleicht kannst Du das WLAN sogar noch über die AVM-Repeater-Funktion vergrößern. Aber: mit Meshing hat das nix zu tun. Und nachdem AVM dem Hacking/Modding ihrer FW den Kampf angesagt hat, ist das für mich auch nur noch eine blöde CPE wie andere auch — wenngleich mit meistens guter Usability und geringen foobar-Faktor (Version 6.8x ausgenommen).

Sinn des Offloaders war es mal, das Jonglieren von IP-Paketen im Userspace (fastd) zu beschleunigen, um die kleine Büchsen zu entlasten und nur einen Tunnelendpunkt bei einer größeren Installation zu haben …

Passt nicht ganz aber hier mal mein Setup: Freifunk Router als virtuelle Maschine — psi.cx

Afair ist es wichtig, dass man Meshen kann um nicht gegen das pico peering agreement zu verstoßen.

2 Likes

Vielleicht hilfreicher für Leute mit ähnlicher Konstellation.

gluon-tauglicher-usb-wlan-stick

Mein QNAP NAS hat 3 USB Schnittstellen. Diese können der VM zugewiesen werden und somit als Mesh WLAN genutzt werden.

Hallo @kla960 ,

ich versuche nun schon seit einem geschlagenem Tag unsere QNAP NAS als Offloader (VM) laufen zu lassen. Leider nimmt er das .img Image einfach nicht, bzw. ich kann es noch nicht einmal auswählen (Es bleibt ausgeblendet) Wenn es dann geht, sagt die VM No bootable Device.

Könntest du mir sagen, wie du es hinbekommen hast? Ubuntu samt Unifi Controller war innerhalb von Minuten aufgesetzt. Das Gluon Image will und will einfach nicht :confused: Würde mich freuen, wenn du einmal kurz Zeit hättest mir zu helfen…

LG Adrian