Instabile Meshlinks unter 802.11s

Fortsetzung der Diskussion von Test 11s gegen ibss mesh:

Konkret gibt es in einer Meshwolke (802.11s only) Probleme mit der Stabilität dieses Meshlinks
https://service.freifunk-muensterland.de/maps/map14/#!v:m;l:60e327c783cc-f4f26d303de6

Auf der einen Seite läuft eine CPE210, die Gegenstelle ist noch ein WR841, soll bei Gelegenheit durch einen WR1043 getauscht werden. An der CPE wird das Eingangssignal mit etwa -77 dbm gemessen, der 841 meldet -70 dbm. Beim Betrieb mit IBSS war der Link stabil bei bei einer TQ von in der Regel 75…90 %, seit der Umstellung auf 802.11s kommt es häufiger zu Ausfällen, die TQ sinkt dann auf 5…10 %. Bisweilen tritt dies auf, wenn auf dem benachbarten Router http://karte.freifunk-muensterland.org/map14/#!v:m;n:c46e1ffe44e6 mehrere Clients angemeldet sind, einen eindeutigen Zusammenhang konnte ich aber bisher nicht feststellen.

  • Welche Ursachen könnten dafür in Frage kommen und wie ließe sich das Problem behenben? Oder liegt es einfach daran, dass der Link durch den höheren Datendurchsatz mehr wackelt. In der 1. Fresnelzone steht leider ein Baum.
  • Wie könnte man sinnvoll den Zeitlichen Verlauf der TQ loggen?

Da es keine richtige Abstimmung zwischen dem Meshnetz und dem Clientnetz gibt, schießen die sich einfach die Pakete kaputt. Das ist bei adhoc dasselbe. Mesh ist was tolles, solange es nicht wirklich belastet wird. Unter Last kann man das vergessen.

Grüße
Matthias

1 Like

Die Wolke läuft jetzt mit

wireless.mesh_radio0.mcast_rate='6000'

Das hat die Stabilität der Links deutlich verbessert. Viel geht durch die Wolke nicht durch, aber in Anbetracht der Bandbreite der Uplinks reicht das (leider) aus.

Nach meinem Eindruck führte die verringerte multicast rate bisher zu keinen anderweitigen Problemen, da mit 802.11s auch schwache aber unbenutzte Links unter Last schnell wegbrechen.