Konfiguration und Einsatz von VLANs im Zusammenhang mit Freifunk


#1

Hmm, klingt interessant.
Leider bin ich "VLAN-doo"f, vielleicht kann mir jemand einen Hinweis geben.

Mein Switch (HP1810), dort habe ich ein VLAN angelegt (100, für Mesh).
Die WLAN AP in Port 4-8, die Ports dort auf 100 getaggt.

Futro in #3.
Im Switch kann ich pro Port & VLAN Tagged, Untagged oder Exclude einstellen.
Ich denke man müsste den Switch dazu bringen, die Tags die aus dem Futro fallen “unverändert” akzeptieren bzw lernen. Jemand einen Tip?

Ach so, was ich machen möchte: Mesh Traffic aus meinem LAN raushalten.
@vax


F.A.Q. zum Offloader Fujitsu-Siemens Futro S550
Thin Client Siemens Futro S550 im Einsatz als günstiger Offloader
Zwei Netzwerkkarten im Futro
#2

@vax VLANs können mehrere Ports einschließen (Optionen Untagged, Tagged, Exclude in deinem Fall für jeden Port).
Wenn ich das richtig verstehe, möchtest du Port 3-8 benutzen. So viele brauchst du übrigens garnicht…
Das ist mal ein Beispiel: Mach auf deinem Switch ein VLAN 100 (wolltest du ja für Mesh). “Exclude” alle Ports bis auf 3 und 4.
Port 3 machst du tagged. Port 4 machst du untagged.
Jetzt mache ein weiteres VLAN (sagen wir mal 101 oder was auch immer). Exclude alle Ports bis auf 3 und 5. Port 3 machst du tagged und Port 5 untagged.

Jetzt zur Konfiguration auf dem Futro - Dort setzt du mit UCI folgende Einträge:
network.wan.ifname=eth0.101 (101 ist die “WAN” VLAN ID)
network.mesh_lan=interface
network.mesh_lan.auto=1
network.mesh_lan.ifname=eth0.100 (100 ist die “Mesh” VLAN ID)
network.mesh_lan.macaddr=DENKDIRWASAUS
network.mesh_lan.mesh=bat0
network.mesh_lan.proto=batadv

Jetzt schließt du den Futro an Port 3 des Switches an. An Port 5 des Switches schließt du das LAN von deiner FritzBox oder Ähnliches an. An Port 4 des Switches hast du jetzt das Mesh-on-LAN-Interface.

Und hoffentlich hast du jetzt auch das Prinzip verstanden. Ein VLAN besteht meist aus einem oder mehreren getaggten und ein oder mehreren ungetaggten Interfaces/Ports. An dem ungetaggtem Interface/Port ist ganz normaler Netzwerkverkehr… An dem getaggtem Port/Interface lassen sich mehrere getaggte VLANs auf einer Leitung übertragen (in diesem Fall Port 3).

Sorry, falls das verwirrend sein sollte. Ich bin echt grottenschlecht im Erklären.

Schöne Grüße,
Vincent


#3

Angenommen, die Konfigurierst VLAN1 so

VLAN1: 1=U 2=U 3=U 4=E 5=E 6=E 7=E 8=E

Dann hast du schonmal einen virtuellen Switch, der die Ports 1, 2 und 3 umfasst.

So, jetzt prökelst du den Futro in Port 3, und deinen Heimrouter in Port 1. Tolle Sache, du müsstest jetzt Zugang haben.

Jetzt aber kommt’s. Du willst die MESH-On-LAN Pakete im Futro als 100 Taggen. Prima.

Die Konfiguration auf Seiten des Switches sieht dann so aus

VLAN100: 1=E 2=E 3=T 4=U 5=U 6=U 7=U 8=U

Alle Pakete, die bei Port 3 mit dem Tag 100 reinkommen, fallen dann bei den Ports 5,6,7,8 untagged raus. Und alles, was bei den Ports 4,5,6,7,8 untagged reinkommt, landet als Tagged=100 auf Port 3.


#4

Denk dran die PVID von 1 auf das VLAN zu ändern.


#5

Moin @vax,

soweit ich das verstanden habe, musst du den VPN-Router doppelt verkabeln oder im uci rumhexen, was nicht Autoupdater konform wäre.

Ich würde den VPN-Router ganz normal ins private WLAN packen und dann auf zwei Ports im Switch ein unmarkiertes VLAN (untagged) zwischen dem VPN-Router und dem Mesh-Router machen und diese jeweils mit den gelben Ports verbinden. Dann wäre der VPN-Router zwar doppelt angeschlossen, aber der Autoupdater kann weiter laufen.

Grüße
MPW


#6

\o/ das habe ich glaube sogar verstanden! Tausend Dank! :smile:


#7

Ehm, war eine andere Fragestellung, geht um Futro, hat nur einen Port. Bei nem Plasterouter würde ich micht damit nicht aufhalten.


#8

Benötigt man noch kmod-801q für VLAN, oder ist das per default im x86-Image drin?


#9

Ist drin. Einfach eth0.x verwenden, läuft.


#10

Dann hab ich vorhin was falsch gemacht. Ich probier’s morgen nochmal. Also eth0.8 ging bei mir nicht.


#11

Moin Moin,

ich möchte das Thema VLAN nochmal aufgreifen und euch um Mithilfe bitten, denn mir fehlen die Kenntnisse.

Ziel soll es sein einen S550 Futro mittels VLAN mit nur einer LAN Karte zu betreiben, so wie es @cawi2001 hier: Thin Client Siemens Futro S550 im Einsatz als günstiger Offloader beschrieben hat.

1. Futro Config:
Welche Befehle müssen eingegeben werden um dem Futro ins VLAN zu bekommen?
ist dies updatessicher?

2. FF-Router Config?
Welche Befehle müssen eingegeben werden um den FF Router ins VLAN zu bekommen?

Schon mal Danke im Voraus!


#12

Futro:

Einfach auf dem Futro network.wan.ifname=eth0.7 setzen (wenn WAN auf VLAN 7 laufen soll) und Einträge für Mesh-on-“LAN” hinzufügen mit VLAN 8 z.B. :grinning:

uci set network.wan.ifname=eth0.7
uci set network.mesh_lan=interface
uci set network.mesh_lan.auto=1
uci set network.mesh_lan.ifname=eth0.8

uci set network.mesh_lan.macaddr=DENKDIRWASAUS !!!

uci set network.mesh_lan.mesh=bat0
uci set network.mesh_lan.proto=batadv

uci commit
(von Codefetch)

Nun zum 841er

Änderungen in /etc/config/network (nochmals geändert nach 4 Stunden probieren mit Codefetch)

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘8’

config switch_vlan
option device ‘switch0’
option vlan ‘8’
option ports ‘0 1t 3 4’

config switch_vlan
option device ‘switch0’
option vlan ‘7’
option ports ‘1t 2’

uci set network.mesh_lan.auto=1

Verkabelung:

Port 1 (4) Futro
Port 2 (3) Internet

Wlan funktioniert so ohne zusätzliches Kabel.

Die Ports entsprechen nicht unbedingt der (Beschriftung)

:smile:


Thin Client Siemens Futro S550 im Einsatz als günstiger Offloader
#13

Klasse vielen vielen Dank!

Ich habe das direkt in die FAQ eingetragen.


#14

Habe das noch einmal geändert. Viele Tests mit Codefetch durchgeführt.


#15

Danke ihr beiden hab das in der FAQ geändert.