LAN Ports mit WAN überbrücken

Ich habe bis jetzt immer erfolgreich mit der Anleitung FF MS Wiki mein privates LAN an die LAN Ports des FF-Router geschaltet bekommen (musste nur nach jedem Firmware-Update erneut gemacht werden.)

Nach dem letzten Update auf v2015.1.1+155 geht dies nun nicht mehr.
Erst habe ich den Router mit denselben UCI Befehlen ins Nirvana geschickt (Kein Ping mehr, kein anmeldem von Clients im WLAN, keine SSH Session). Nachdem ich dann im Configmode das „neue“ Mesh-over-LAN deaktiviert habe, konnte ich die UCI Kommandos machen, ohne das der Router nicht mehr erreichbar ist.

Aber trotzdem erhalte ich aktuell an den LAN-Ports IP-Adressen aus dem FF-Netz. Hier der aktuelle Status der beiden Parameter:

root@Agathastr:~# uci show network.wan.ifname
network.wan.ifname=eth0 eth1
root@Agathastr:~# uci show network.client.ifname
network.client.ifname=bat0
root@Agathastr:~#

Das Wiki sollte also unbedingt geändert werden, falls das nun die falschen Einstellungen sind.

1 Like

Mach mal bitte uci show network|grep eth

root@Agathastr:~# uci show network|grep eth
network.wan.ifname=eth0 eth1
network.mesh_lan.ifname=eth0

Wir haben standardmäßig LAN-Mesh aktiviert. Falls du den Router komplett neu installiert hast, wurde das aktiviert.

Das musst du zuerst im Konfigurationsmodus deaktivieren.

Das habe ich ja bereits getan.

Wenn du da schon im uci rumexperimentiert hast, würde ich Mal mit firstboot den Router neu initialisieren und es nochmal neu probieren.

Hmmm, kompletter Reset. Würd ich ja gerne vermeiden…

Rumgespielt mit uci hab ich nicht, nur nach Firmware-Update exakt die 3 Kommandos ausgeführt.

Aber wenn ich es beizeiten nicht wirklich zum Funktionieren bekomme, mache ich auch mal den firstboot.

Thx.

Mach mal uci set network.mesh_lan.ifname="" uci commit network reboot

1 Like

Super,vielen Dank! Das war die Lösung.
Hätte die Option nicht auch durch das Deaktivieren des Mesh-on-Lan im Expert-Config-Mode gelöscht werden müssen?

Ich beobachte das noch einmal beim nächsten Firmware-Update und vielleicht kommt für das WAN-on-LAN ja auch noch irgendwann mal eine GUI-Option.

Das Überschreiben der MeshOnLan-Option beim Update war ein Bug in der 2015.1, der erst mit der 2015.1.1 gefixt wurde. Soll jetzt updatefest sein.

Wir hatten aber 2015.1 nie draußen hier in Münster.

hmm… dann würde ich nochmal einen Bugreport dazu aufmachen, wenn es sich reproduzieren lässt.

Kleines Update: Mit der nun ausgerollten Firmware v2015.1.2+169 muss jetzt doch wieder der Mesh_Lan-Interface Name gesetzt werden:

uci set network.mesh_lan.ifname="eth0"

Auf das private WLAN oderdas LAN-Bridging an sich war keine Auswirkung zu spüren, aber Clients im Freifunk-Netz haben sonst keine IPv4-Adresse zugewiesen bekommen.

eth0 ist nicht eindeutig. Auf einigen Router-Typen ist das der WAN-Port wo anders der Switch. Mit dem Befehl oben sollte mesh-on-lan aktiv sein. Auf dem Switch wäre dann mesh-on-lan und „wan-on-lan“ (das ja das ursprüngliche Ziel?) aktiv sein.

Ja, du hast Recht. Der Vollständigkeit halber:

uci set network.mesh_lan.ifname="$(cat /lib/gluon/core/sysconfig/lan_ifname)"

Bei meinem 841N passt das aber mit eth0.
Mir ging es nur darum, das hier für die Münsteraner Firmware festzuhalten, falls noch jemand WAN-ON-LAN aktivieren möchte. Nachdem es halt mehrere Updates einfach glatt ging, einfach die beiden im Wiki gelisteten Befehle auszuführen, musste man nach dem vorletzten Update (Juli) den ifname-Parameter explizit leeren und nun nach dem letzten Update explizit wieder setzen.

Es kann natürlich sein, dass es bei anderen Routermodellen oder wenn ich die aktuelle Firmware mit Reset neu flashen würde anders aussieht.

uci set network.mesh_lan.ifname="eth0"

Echt? Wenn ich den Wert setze, dann kriege ich bei WAN on LAN keine IP mehr. (WRT160N)

cat /lib/gluon/release 
v2015.1.2+169

uci show network.mesh_lan.ifname
uci: Entry not found

uci show network.wan.ifname
network.wan.ifname=eth0 eth1

uci show network.client.ifname
network.client.ifname=bat0