Probleme bei den Wuppertaler Supernodes - jetzt mit IPv4 DHCP?


#1

Seit einigen Stunden sind alle fastd Freifunk-Router offline, die über Wuppertaler Supernodes angebunden sind:


#2

Die Nodes kommen gerade wieder online …


#3

aus Rheinbach kam gerade die Info, dass die fastd-Nodes leider keine IPv4 über DHCP liefern.


#4

Die dhcp-Ausfälle in rrh waren nach meiner Beobachtung aber jeweils nur ein paar Minuten.
In anderen wupper-Domains ist es nach wie vor “aus”, da gibt es auch kein Gateway mehr, wenn ich das so sehe.
Vermutlich gibt es einen Plan dazu, aber da ich den nicht kenne (habe ich auch keine Anspruch drauf, das zu erfahren), vermag ich halt nur zu sagen: Da funktioniert seit gestern irgendwas nicht mehr so wie zuvor.


#5

Scheint eine Störung zu sein. Siehe hier:


#6

Wie sieht es denn bei euch aktuell aus? Für Wuppertal könnte ich testen.


#7

Unter 10.111.x.y gibt es derzeit kein IPv4.

IPv6 only läuft ohne Probleme. Ich komme an alle Nodes.

http://map.freifunk-rheinbach.de/


#8

@Byggvir @DSchmidtberg: wenn IPv6 da ist, bringt es was, den public ssh key vom Dustin in eine Node zu packen, damit er beide Seiten sieht?


#9

Auf Wupper 1, 4 und 6 ist gleichzeitig der DHCP abgeschmiert. Da dies schon öfters vorgekommen ist wird der DHCP jetzt jede volle Stunde neu gestartet.


#10

Das hat leider nicht geholfen.

Ich sehe hier sehr viele “Gratuitious ARP for 0.0.0.0 8reply)” Pakete. Auf ein DHCP Discover kommt keine Antwort.


#11

Man kann soetwas durchaus monitoren, um z.B. über den zeitlichen Verlauf Rückschlüsse auf mögliche Ursachen durchführen zu können.

z.B. bei der Wupper-Wuppertal-Domain:


#12

hab hier in Lohmar gerade 2 alte fastd Nodes von Wupper umgeflasht - da war auch nix mehr mit DHCP IPv4 .
Testzeitraum: 17:00 bis 18:15


#13

Ich habe jetzt die IPv4 Adresse manuell gesetzt. (Das hilft immer, wenn ein Knoten am Anschlag läuft.) Über IPv4 geht zur Zeit nichts. Weder DNS noch ein Ping. (z.B. Nameserver 8.8.8.8.)

Es liegt daher wohl nicht an den DHCP-Servern.


Ssid ff_offline_
#14

In Radevormwalder Netz (Port 42477) werden die Wupper Server erst gar nicht mehr als Gateway (batctl gwl und Karte) aufgeführt. Bisher standen dort immer wupper4 (02:be:4a:de:fe:40) und wupper6 (02:be:4a:de:fe:60) in der Liste.


#15

Ach bei Dir geht es gar nicht um rrh, odern rhb?


#16

Mir geht es um Rheinbach = rhb. :wink:

Ich habe jetzt die IPv4 Adressen manuell gesetzt.

IP 10.111.0.233 (sollte kein anderer haben).
GW 10.111.0.246 (gateway für Wupper6 und 10.111.n.m)

Ich kann zwar das Gateway pingen, aber komme nicht darüber hinaus (Z.B. 8.8.8.8)

Ein funktionierender DHCP Server würde das Problem daher nur zum Teil lösen.

fastd funktioniert hier einwandfrei. Alle Router sind über IPv6 im Freifunk-Netz erreichbar.


#17

Du musst natürlich wenn du manuell eine IP setzt auch einen Router setzen, also eines der anpingbaren Gateways.

Ich würde darum bitten, den aktuellen Soll-Zustand der Wupper-Nonwuppertal-Domains zu dokumentieren in
https://wiki.freifunk-rheinland.net/wiki/Wupper#Funkzellen_in_der_Dom.C3.A4ne

Von da ausgehend könnte man dann schauen, ob Fehlersuche/-behebung notwendig ist, oder ob es ("die Abschaltung der Gateways für die Fremd-Wupper-L2-Domains) schlicht “so gewollt” ist.
Vielleicht wurde das ja schon lange angekündigt, nur halt nicht so öffentlich, dass man es hier mitbekommen hätte.


#18

Auf Wupper 1, 4 und 6 werden laut Log IP-Adressen verteilt. Es gibt aktuell aber Probleme die Daten ins Internet weiter zu leiten.


#19

Die Server erscheinen hier in Rade erst gar nicht mehr als Gateway. Scheint als sind das verschiedene dinge


#20

Hier gibt zur Zeit es keine IP-Adressen. Auch bei manueller Einrichtung werden Pakete über das Gateway (z.B. 10.111.0.246) nicht ins Internet weitergeleitet.