Projektvorstellung: Unterkunft mit Verkabelung und mehreren DSL-Anschlüssen; Anschlussfinanzierung durch Bewohner via Helferkreis

Hallo zusammen,

nachdem mich das Thema einiges an Zeit gekostet hat, möchte ich es hier mal vorstellen. Ich denke doch, dass ich nicht der erste bin, der sich mit Multi-DSL an einer Unterkunft abmüht - leider findet man weder ausreichend Informationen noch best-practice dazu.
Dies ist natürlich nur ein kurzer Abriss, der viele Entwicklungen dazwischen auslässt und nur die wichtigsten „Lessons Learned“ und Meilensteine darstellt; leider wirds tortzdem zu lang.
Zudem versuche ich das ganze möglichst wenig technisch zu schreiben, damit eine tiefe Einarbeitung in Protokoll und OpenWRT nicht nötig ist und man die Konfiguration trotzdem nachvollziehen kann.

Eigentlich war es ein ziemlich überschaubares Setup:

  • 2-stöckige Geflüchtetenunterkunft mit ~50 Bewohnern
  • Formals Geschäftsgebäude
  • Verkabelung vorhanden

Doch nichts ist so einfach wie es aussieht:

  • Maximal 16.000er DSL verfügbar
  • Zugangsprobleme, da Schlüssel beim Hausmeister (Zugang nur über Auftrag beim Landratsamt)
  • Dosen sind teilweise nicht mehr zugänglich (Bodentanks wurden verschlossen etc.)
  • Dosen sind falsch im Gebäudeplan eingezeichnet, Plan ist insgesamt nicht mehr aktuell
  • Verkabelung unbeschriftet (im „Netzwerkraum“ kommen einfach sämtliche Kabel aus der Wand)
  • Sehr hohe Ansprüche der Bewohner

Das größte Problem das wir sahen: Die Bewohner. Also blieb nur richtig oder gar nicht.
Also haben wir erstmal versucht einen entsprechend breiten Anschluss zu bekommen, was schon Mal einiges an Zeit ins Land gehen hat lassen. Alles ohne Erfolg außer der Tatsache, dass wir mehrere Anschlüsse haben können: Also fiel der Entschluss auf zwei 16er-DSL-Anschlüsse, sollte ja kein Problem sein die mit Freifunk sinnvoll aufzuteilen (dazu später mehr).

Also zum Setup:
EG: 1 kleinerer Schlafraum (ca. 5 Personen) in der vorderen Hälfte, außerdem Schulungsraum und Küche, sowie Netzwerkraum; 1 großer Schlafraum (ca. 20 Personen) und Treppenhaus/Eingangsbereich in der hinteren Hälfte
OG: 1 großer Schlafraum (ca. 20 Personen) in der vorderen Hälfte; 1 kleiner Schlafraum (ca. 5 Personen), außerdem Schulungsraum, Küche und Treppenhaus in der hinteren Hälfte

Somit erschienen uns von Fläche und Nutzeraufteilung 4 Access Points am sinnvollsten.

Damit kamen wir dann auf folgende Archtektur:
Je 1 TL-WR1043 v2 als Offloader an den DSL-Anschlüssen, je 1 TL-WR841 v9/10 pro Geschoss und Hälfte.

Beim Aufbau ergaben sich bezüglich Aufteilung und Verkabelung weitere Probleme:

  • Eine exakte Aufteilung war nich möglich, da man sich nach den verfügbaren Dosen richten musste. Nicht überall wo Kabel hingingen waren Dosen, nicht alle Dosen waren zugänglich
  • Die als Spende erhaltenen Stecker passten nicht auf die Verlegekabel (nochmal Abbruch, einkaufen, neuer Termin mit LRA…)

Als es dann endlich alles Stand blieb die Frage: Wie die DSL-Anschlüsse aufteilen? Segmentieren? Oder mach das Batman?
Die erste Idee: Je zwei APs an jeden Offloader, da ganze trennen und aufgrund der sowieso dauerhaften Auslastung und etwa gleichhohen Nutzerzal sollte das schon passen.
Nach Rücksprache mit einem Experten aus der Community: Meshen zwischen den beiden Segmenten, die APs suchen sich dann je nach Auslastung die bessere Leitung.

Architekturplan Endergebnis:

                           GW
                            |
                --------------------------
                |                        |
             Off1@DSL1               Off2@DSL2
             |   |    |               |   |   |
             |   |    -----------------   |   |
            AP1 AP2                      AP3  AP4

Danach erfolgte noch etwas WLAN Optimierung:

  • Abschalten des WLANs an den Offloadern (einer hatte zuvor als Übergangslösung bis zur fertigen Verkabelung gedient)
  • Abschalten des Meshings an den APs (bis auf den AP4, der Richtung Nachbarn zeigt)
  • Aufteilen der Kanäle der APs auf 1, 5, 9, 13 (wobei 5 als Mesh-Kanal natürlich an dem AP mit aktiven WLAN-Mesh blieb)

Also die Konfiguration:

  • der Offloader
  • Mesh-VPN auf WAN-Interface
  • LAN-Mesh auf LAN-Ports
  • WLAN aus
  • Autoupdate aus
  • der APs
  • WAN-Mesh auf WAN-Interface
  • Client-Netz auf LAN-Ports
  • WLAN-Mesh aus (bis auf einen)
  • Aufteilung auf verschiedene Kanäle

Nachdem das alles schön funktionierte kam die erste Ernüchterung: Es ist langsam. Ja, es sind 30 gleichzeitige Nutzer - aber die sind nur auf einer Leitung. Denn alle 4 APs wechseln gleichzeitig zwischen den beiden Offloadern hin- und her, statt primär „ihren“ zu benutzen und nur bei schlechter Leitung/hoher Auslastung auf den anderen zu gehen.
Es schien als würden sich immer alle gleichzeitig für die bessere (freie) Leitung entscheiden, um dann aufgrund der nun folgenden Auslastung sofort wieder auf die andere (jetzt leere und somit bessere) Leitung zu springen.

Nach etwas Googeln fand ich in einem Foren-Beitrag (Gibt es im Mesh ein Loadbalancing? - #18 von adorfer) die entscheidende Aussage zum beobachteten Phänomen:
Die ausgelastete Bandbreite ist Batman völlig egal, es nimmt immer die beste Verbindung - also den DSL-Anschluss, der gerade frei ist.

Nun bleibt die Frage: Was macht man mit der Verbindung zwischen den Routern? Segmente trennen? Oder gibt es eine passende Einstellung? Das hat nochmal gut Zeit gekostet…
Nach dem Testen diverser Optionen (gw_mode, Hop Penalty etc.) die riesige Erkenntnis: Aufgrund des Switches vor dem Offloader (was anderes sind die integrierten Switche der Plastikrouter wie allgemein bekannt ja nicht), sind die beiden Offloader für alle APs absolut identsich, da der Traffic ja nicht über das Batman Interface läuft. Manchmal steht man halt etwas auf der Leitung…
Also gibt es seitens der APs nichts, das man optimieren kann.

Daher musste dafür gesorgt werden, dass es für die APs einen Unterschied macht, welchen Offloader sie nehmen. Also muss der Traffic zwischen den Offloadern an den Offloadern über das bat0 laufen, um dadurch einen weiteren Hop zu erzeugen. Somit ist das Gateway für den AP vom eigenen Offloader aus näher, als vom anderen - zumindest virtuell.

Virtuell trifft es ganz gut, das ergab nämlich folgende Netzwerk-Konfiguration (/etc/config/network) mit einem weiteren VLAN (Kommentare gehören natürlich nicht dazu):

# Switch anpassen: Port 1 (intern Port 4, siehe https://wiki.openwrt.org/_detail/media/tplink/tl-wr1043/tl-wr1043nd-v2_schematics.png?id=toh%3Atp-link%3Atl-wr1043nd) mit Verbindung zum anderen Offloader aus der Config vom VLAN 1 raus, Port 0 (der Router selbst, also unser batman-Interface) mit Tag (t) an den Paketen damit klar ist von wo sie kommen
config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0t 2 3 4'

# Switch anpassen: Neuer Abschnitt fürs neue VLAN dazu (VLAN 3, da VLAN 1 unsere restlichen LAN-Ports sind und VLAN 2 die WAN-Ports); 0 muss als quasi Batman-Port wieder dazu - wieder mit Tag damit auch hier klar ist wo die Pakete herkommen
config switch_vlan
    option device 'switch0'
    option vlan '3'
    option ports '0t 1'

# LAN-Mesh anpassen: Wegen dem zweiten VLAN auf dem gleichen Interface (Port 0 = eth1), hat eth1 jetzt zwei Subinterfaces mit der Nummer des VLANs. Also müssen wir alle Erwähnungen von eth1 durch das richtige Interface ersetzten, sonst funktioniert es nicht mehr. Hier wird ifname auf das Interface der restlichen LAN-Ports gesetzt
config interface 'mesh_lan'
    option macaddr '32:b6:c3:bd:72:f2'
    option mesh 'bat0'
    option proto 'batadv'
    option auto '1'
    option ifname 'eth1.1'

# Neues Mesh Interface anlegen: Jetzt kommt ein neus virtuelles Interface dazu, damit unser vorher angelegtes VLAN mit seinen Ports auch separat an das bat0 angebunden ist. Die MAC-Adresse und der Name kann beliebig gewählt werden.
config interface 'mesh_offloader'
    option macaddr 'af:fe:c3:bd:72:f2'
    option mesh 'bat0'
    option proto 'batadv'
    option auto '1'
    option ifname 'eth1.3'

Nach dem Anpassen einfach ein „/etc/init.d/network reload“ ausführen. Aber Vorsicht: Sollte etwas falsch sein ist der Router eventuell nicht mehr erreichbar (was blöd wäre, wenn man z. B. erst den Zuständigen beim Landratsamt erreichen muss um an die Hardware zu kommen).

Mit dieser Konfiguration laufen alle Pakete, die von APs des einen Offloaders zu einem AP des anderen Offloaders, oder zum anderen Offloader, sollen über das Batman Interface statt einfach über den Switch.
Dies bedeutet: Normalerweise nehmen APs den Offloader an dem sie hängen um zum Gateway zu kommen. Sollte diese Verbindung nicht verfügbar sein, verbinden sie sich über den anderen Offloader.
Damit haben wir ein „Loadsharing“ erreicht indem die APs händisch auf die beiden DSL-Anschlüsse aufgeteilt haben, aber es fällt kein AP aus nur weil ein Anschluss nicht verfügbar ist. Zudem ist es hausintern möglich Daten mit voller Geschwindigkeit auszutauschen.

Verbliebene Probleme:

  • Die Dose eines APs hat einen Wackelkontakt und sorgt für Verbindungsprobleme (SSID bleibt bei Freifunk, somit großer Unmut bei Ausfall), er wird daher abgebaut → Anschlussaufteilung geht nicht mehr so schön auf
  • Die Ansprüche der Gelüchteten sind immer noch viel zu hoch und es ist ihnen trotz problemloser Funktion selbst beim Abspielen von YouTube etc. zu langsam
  • Das Netz der genutzten Community ist leider etwas langsam, daher kommen an den Offloadern schon nicht mehr als 10 Mbit/s durch

Was die Finanzierung angeht, so wurde die Hardware aus Spenden beschafft, die Gebühren für die Anschlüsse tragen die Geflüchteten selbst (macht pro Person ~1 €/Monat, das hat jeder mehr als locker übrig).

Ich denke ich muss da morgen nochmal drüber lesen, aber das sollte es soweit gewesen sein. Ich hoffe einigermaßen verständlich und doch für jemanden hilfreich.
Über Anmerkungen würde ich mich freuen :smile:
Eventuell folgen auch noch ein paar Bilder…

An der Stelle noch vielen Dank nach Darmstadt für die Unterstützung, obwohl es nicht euer Projekt war! :smiley:

Viele Grüße

DontSwitch

Paar Schlagworte für die Suche:
Loadbalancing, Loadsharing, Lastverteilung, Splitting, Segmentierung, Mesh on LAN, Mesh on WAN

11 Likes

Hi,

klingt nach einem tollen Projekt. Hier noch eine Anleitung, wie es @paulinsche in Warendorf mal umgesetzt hat: https://freifunk-muensterland.de/wiki/doku.php?id=technik:loadsharing

Liebe Grüße
Matthias

1 Like

Ich erlebe 10MBit/s auf einem „HT40 2,4GHz-Teich“ als hartes Limit.
„Teich“ bezeichne ich einen Bereich, in dem sich Stationen mit „einem Balken“ (ca -80dBm) hören können.
Das reicht in nämlich, um die das CarrierSensing ansprechen zu lassen und eine Station vom Senden abzuhalten.
Dagegen kommt man nur mit drastischer(!) Sendeleistungs-minimierung an. Und Kanalverteilung.
Leider beherrscht der von uns mehrheitlich genutzter ath9k weder clientbasierte TXpowercontroll, noch (echtes) Beamforming. Von Bandsteering gar nicht zu träumen.
Von daher ist leider auch mit viel Kraft aus dem Headend nichts zu reissen, wenn die Airtime „zuende“ ist.

(Und entgegen der landläufigen Meinung sind das eben nicht 300MBit/s, die langsamen Clients mit ihren 2-11MBit/s-Connects verbrauchen in der Praxis so viel Zeit, das für die wenigen „optimalen Links“ wenig übrig bleibt. Was natürlich nciht heisst, dass früh morgens direkt neben dem AP nicht auch mal 30MBit/s als Speedtest bekommt. Aber im Stundemittel ist dann eben bei 10MBit/s „Anschlag“, wenn man ins vnstat/mrtg/grafana schaut.)

@mpv: Wie schaut es mit Foren-Bereich "Gemeinschaftsunterkünfte" aus?

schönen Projekt, aber ich bekomm Bauchschmerzen bei den Wörtern

die Gebühren für die Anschlüsse tragen die Geflüchteten selbst (macht pro Person ~1 €/Monat,

Ich seh das vom psychologischen Aspekt:
So was Flüchtlingen hinzustellen und über einen Verein oder sonstwie zu finanzieren, ist einfach toll.
Aber den Flüchtlingen muss klar sein, es ist eine freiwillige Leistung und Spende.
Also KEIN Anspruch

Wen ich einen Preis daran hefte, egel wie klein der ist, entsteht ein Anspruchsdenken „ich hab das bezhalt, also will ich es auch haben“

Genau das darf nicht aufkommen. Ist psychologisch sehr bedenklich und der Boumerang und Ärger und Stress sind von der ersten Minute an implementiert. Egal, wie gut Ihr das kommuniziert habt. Das Denken im Hinterkopf „hab ich für bezahlt, will ich haben“ setzt sich fest.

Wenn so was gewollt ist, dann bitte soll das eine komemerzielle Firma machen.

Man kann das durchaus auch andersherum verargumentieren (nicht, dass ist das so zu 100% so sehe):

Die meisten Geflüchteten müssen für den Internetzugang für ihr Smartphone teure PrePaid-Mobilfunktarife kaufen oder auch noch aus dubiosen Quellen kaufen wg. erforderlichem Identitätsnachweis bei Mobilfunk-Produkten, der manchmal mangels Ausweise nicht möglich ist.

Da ist die Alternative für 1 € pro Person und Monat eine überaus preisgünstige Alternative.

1 Like

ja, deswegen stellen wir denen ja FF hin.

Aber es darf kein Anspruchsdenken wie bei einem Geschäft mit einem Preis daraus entstehen, überspitz ausgedrückt: kein Rechtsanspruch. (also auch kein Denken wie bei einem solchen)

Wir wollen dasselbe, aber ich will es so machen, dass im Ergebnis eine Harmonie entsteht und kein Gegeneinander, weil jemand meint, er müsse jetzt das, wofür er bezahlt hat, auch sofort erhalten. Solch ein Denken verursacht immer Unbill und Affront und im ungünstigen Fall Agressivität. Sollte von vorn herein vermieden werden.

Rechtsanspruch, Harmonie, Unbill und Affront, Agressivität

Meine Güte, nimms mir nicht übel, aber schreibst Du immer so „verquast“?

Wenn die 1 €/Mann/Monat laufende Kosten durch regelmäßige Spenden gedeckt würden, wäre super.

Aber wenn die Bewohner sich daran Beteiligen, wenn keine genügend Spenden da sind, was ist daran so schlimm?

1 Like

Klingt ähnlich, wobei sich hier aufgrund der unterschiedlichen Strecken dieses extreme Hopping nicht bemerkbar machen dürfte.
Die Seite hätte ich mal eher finden müssen, durch die gleichen Dokus habe ich mich auch gewühlt xD
Danke!

Ich glaube hier liegt ein Missverständnis vor. An den Offloadern = aus dem fastd-Tunnel.
Hier wird nix gemesht (mangels Partnern) und jedes Gerät mit aktivem WLAN hat seinen eigenen, überschneidungsfreien Kanal.

wenn Du meinen Gedanken nicht nachvollziehen kannst, tut es mir leid. In die Denke anderer reinversetzen ist nicht deine Stärke?
Mach ne Spendensammlung dafür bei den Flüchtlingen, freiwillig, aber keinen Preis.

…lassen wir es hier enden. Bringt uns beide nicht weiter, @Pinky . EOD

1 Like

gut, ist Euer Projekt. Ihr entscheidet wie Ihr das macht. War nur als Warnruf gedacht „vorsicht, Glatteis“

Könntest Ihr die Diskussion um die 1€/Monat/Person-Beteiligung von den Geflüchteten nicht irgendwo hin (Ja, ich weiss auch nicht wohin, ein Foren-Bereich dafür fehlt nach wie vor) auslagern.
Ich sehe nämlich wirklich, wirklich keinerlei Zusammenhang zu den im Betreff angesprochenen „mehreren DSL-Anschlüssen“ und der Verkabelung.

(Es sei denn, dieses Forum soll sich um einen Sonderpreis bewerben für „Threads wo Titel nicht zum Inhalt passen.“)

2 Likes

Naja, ein Thread ist das was man daraus macht. Wenn die Finanzierung ein wichtiger Punkt ist kann man ja darüber reden. Ich finde nur, dass man ohne die Lage vor Ort zu kennen schlecht etwas kritisieren kann.

Das Anspruchsdenken war leider bereits da, vor allem bei einigen „lauten“ Bewohnern. Wir haben das somit nicht erzeugt und es wurden auch genug Schritte unternommen um dem entgegen zu wirken.

Was die Finanzierung anging hatten wir drei Möglichkeiten:

  • Internetspende von Nachbarn
  • Geldspende für Anschlüsse
  • Finanzierung durch Bewohner

Die Nachbarn fielen leider raus, da mit den direkten nichts zu machen ist („Nachbarschaftsstreit“ wegen der Lautstärke) und ansonsten nichts stabiles erreichbar ist.

Also haben wir mit dem Helferkreis die anderen beiden Optionen eruiert. Spenden in Höhe von >1000 € nur für 2 Jahre Anschlussgebühr sammeln ist nicht, außerdem lässt sich das Geld anders besser verwenden. Und die Hardware wollten wir ja zusätzlich sowieso über Spenden finanzieren.

Also blieben die Bewohner. Da es 50 Leute sind und Konsens (und auch das Angebot von den Bewohnern) da war die Anschlussgebühr zu übernehmen (der Helferkreis hat das alles entsprechend kommuniziert), haben wir uns dafür entschieden.

Mir gefällt die Option allgemein sehr gut. Wenn ich eins gelernt habe, dann das „Verwöhnen“ mehr Probleme macht, als beteiligen.
Ständig Geschenke führt nur dazu, dass das Gefühl aufkommt, hier wäre alles umsonst. Genug kommen leider auch mit dieser Vorstellung.
So wissen sie, dass das Internet etwas kostet; um das klarer zu machen erklärt der Helferkreis alles entsprechend und hängt die Rechnungen aus.

Ein paar gibts aber halt immer die meinen das hat permanent zu 100 % so zu funktionieren wie sie sich das vorstellen - denen kommt man ganz schnell bei, wenn man „auf den Tisch haut“ und klar macht, dass man das ehrenamtlich macht und sie keine Ansprüche erheben brauchen.
Ich meine hier so Sachen wie Ansagen wo man was montieren soll, z. B. „Here black device“, weil der 841er als AP ja nicht gut genug ist.

Bei Aggressivität kann man seinen Punkt im Zweifel sehr schnell klar machen: Die Verträge sind innerhalb von einem Monat gekündigt und die Hardware ist ratzfatz abgebaut.
Da gab es aber bisher absolut keine Probleme, und wenn würden wir hier max. über 3 Bewohner von 50 reden.

Bei einem kommerziellen Anbieter würde es nicht besser funktionieren - aber jeden Bewohner mindestens 10 € im Monat kosten.

Die Bezahlung ist freiwillig, der Helferkeis kann schließlich niemanden zwingen. Sollte es aber keinen Konsens mehr geben müsste es weg - das gäbe nur internen Unmut, wenn ein Teil zahlt, der andere nicht, es aber alle nutzen.

PS: Das Modell haben wir jetzt für weitere Unterkünfte übernommen, Gründe siehe oben. Wird auch gut angenommen.

6 Likes