[SOLVED] 5GHz-Kanäle DE (Aktuelle GE Firmware auf TL-WDR4300)

Hallo,
ich bin gerade von der Domäne Ruhrgebiet auf Gelsenkirchen umgestiegen und habe erhebliche Probleme mit dem WLAN in der aktuellen Firmware 0.7.2.
Die Performance im 2,4GHz-Band ist sehr schlecht (im privaten WLAN) und 5GHz funktioniert gar nicht mehr.
Gibt es ein Archiv, wo man ältere builds finden kann? Hat noch jemand anders die gleichen Probleme?

Außerdem finde ich auf der Download-Seite (und auch sonst nirgendwo auf den Seiten von FF-GE) keinen Link zu den Quellen+Configs der Firmware. (Das wäre eine Verletzung der GPL) Ich habe lediglich gehört, dass es ein dediziertes github-repo geben soll.

Morgen, ich bin zwar nicht aus GE oder Wupper aber was du suchst ist in deinem Router.

/lib/gluon/site.conf

und die site.mk gibts hier
https://firmware.freifunk-wuppertal.net/firmware/wupper/site/site.mk

Und um mal gegen zu schießen, warum MUSS man die site.conf und site.mk veröffentlichen?
Das sind Konfigurationsfiles und das geht mal grob gesagt die leute einen feuchten …an :smile:
LG

Tante Edit sagt…hier sind die Originale ^^

http://46.38.238.147/images/gek/stable/site/site.conf
http://46.38.238.147/images/gek/stable/site/site.mk

Allein schon wegen dem PPA. Man muss genug Informationen veröffentlichen, damit jeder der möchte, mitmeshen kann. Da gehört das was in der site.conf drin steht natürlich dazu.

Ob es eine GPL-Verletzung ist, weiß ich nicht, ich glaube da waren wir uns bei der letzten Diskussion nicht 100% einig. Da die GPL „im Geiste“ aber fordert, dass man ohne viele unnötige Probleme aus den Quellen den Krempel nachbauen können muss, wäre es auf jeden Fall aus dieser Schiene auch gut, die so zu veröffentlichen, dass man sich nicht totsucht.

Es ging mir auch nur um die GPL-Verletzung, natürlich ist es im Sinne von Freifunk die Sachen zu veröffentlichen :smile:

LG

Frequently Asked Questions about the GNU Licenses - GNU Project - Free Software Foundation ff.

Die GPL war aber eigentlich nur eine Randnotiz. Mir ging es in erster Linie darum, dass ich mit der GE Firmware funktionale Probleme habe. (Aber ich hab schon verstanden, geht mich alles einen feuchten … an? @mattes )

Also nochmal, an die Gelsenkirchener: Kann jemand die Probleme bestätigen oder ist jemand glücklich mit 0.7.2 auf dem WDR4300?

So kann man es auch drehen, aber wenn jemand mit der Ordnungsschelle kommt gibts halt ein konter :smiley:
Ich Tippe mal auf die gewählten WLAN Kanäle (1 HT40+) und (52 HT40+) wirds evt. liegen, falls ihr vorher
andere hattet …was ich mal annehme weil ihr vorher Ruhrgebiet wart. (Kanal 3 HT40+ und 44 HT40+).

LG

Hallo

Vorweg erst einmal ein herzliches willkommen @babak schön das du den Weg ins Forum gefunden hast und auch direkt Feedback zur FW gibst.

Das Repo sollte unter https://github.com/ff-gek/site zu finden sein, auch wenn der Browser, warum auch immer, einen 404er liefert.
Außerdem sollten die Images jetzt auch unter images.freifunk-gelsenkirchen.de zu finden sein.

@Enrique konntest du schon ähnliche Probleme feststellen?

@PetaByteBoy und @adorfer können vielleicht mehr zur technischen Seite sagen.

1 Like

Wie hast du denn die neue Firmware geflasht? So geflasht das er die Einstellungen der vorherigen Firmware nicht behält? Wenn du die Einstellungen der Ruhrgebiets Firmware beibehalten hast, dann hast du jetzt einen vermurksten Knoten.

Abhilfe: Entweder per SSH drauf gehen im normal Betrieb, oder mit Telnet wenn er im Konfigmodus ist und firstboot auf der Konsole eingeben. Dann sollte der Knoten mit der Firmware die drauf ist jungfäulich Booten und du kannst ihn nochmal neu Konfigurieren. Vielleicht klappt dann alles.

Habe es erst mit einem unclean flash versucht (sysupgrade, konfig behalten) und nachdem es Probleme gab einen clean flash (full reset, factory image). Die Konfig war weg, die Probleme blieben. Ich kann es aber heute Abend noch mal probieren.

Ich kann es weder bestätigen noch dementieren. Es gibt 2 4300er - Cafe Faber und Die Grünen.

Das Factory Image flasht man nur wenn man die original TP-Link Firmware noch drauf hat!

Das device file für radio1 (5GHz) sieht mir seltsam aus: pci0000:00/0000:00:00.0

Auszug aus /etc/config/wireless:

config wifi-device 'radio1'
     option type 'mac80211'
     option hwmode '11a'
     option path 'pci0000:00/0000:00:00.0'
     option channel '52'
     option htmode 'HT40+'
     option country 'DE'

Ist das korrekt so?

Ist wohl aber korrekt so. Bei meinem WDR4300 siehts genauso aus.

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option channel '44'
	option htmode 'HT40+'
	option country 'DE'

root@MA-WDR4300:~# iwinfo client1 info
client1   ESSID: "uelzen.freifunk.net"
          Access Point: EA:96:F8:CD:6E:18
          Mode: Master  Channel: 44 (5.220 GHz)
          Tx-Power: 14 dBm  Link Quality: 62/70
          Signal: -48 dBm  Noise: -94 dBm
          Bit Rate: 150.0 MBit/s
          Encryption: none
          Type: nl80211  HW Mode(s): 802.11an
          Hardware: 168C:0033 168C:A120 [Atheros AR9580]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1
root@MA-WDR4300:~# iwinfo mesh1 info
mesh1     ESSID: "F4:ED:39:BF:BC:95"
          Access Point: F4:ED:39:BF:BC:95
          Mode: Ad-Hoc  Channel: 44 (5.220 GHz)
          Tx-Power: 14 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -94 dBm
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11an
          Hardware: 168C:0033 168C:A120 [Atheros AR9580]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1
root@MA-WDR4300:~#

Sowohl der Router bei den Grünen (meshvpn) als auch das Cafe Faber (wifimesh) laufen damit mit zahlreichen NutzerInnen mit der 0.7.1 und jetzt mit der 0.7.2. (factory)

und wer’s nicht findet:
site.conf
site.mk

Faber:

Grüne:

Oder über den Rescue-TFP-loader gehen möchte. (Finde ich immer ganz praktisch für Reinstallationen, weil es schlicht einfach sehr schnell geht und man mindestens einen Boot und einmal „schauen, was überhaupt läuft“ wegfällt)

Bei mir sieht es leider weniger erfreulich aus:

client1   
          ESSID: unknown
          Access Point: 00:00:00:00:00:00
          Mode: Client  Channel: unknown (unknown)
          Tx-Power: 14 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -95 dBm
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11an
          Hardware: 168C:0033 168C:A120 [Atheros AR9580]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

@adorfer Kann man auch herausfinden in welchem Band die Clients verbunden sind? Könnte ja nach diesem Graph auch sein, dass die alle im 2,4er sind und das fehlen von 5GHz schlicht noch nicht aufgefallen ist.

Versuch mal wieder auf Factory zu gehen. Hier kann man für diverse Modelle von TP-Link die Stripped Firmware herunter laden. friedzombie.com - Informationen zum Thema friedzombie.
Diese dann flashen ohne die Einstellungen beizubehalten. Wenn er dann mit der Original Firmware gebootet ist nochmal die neuste Hersteller Firmware drüber bügeln und dann noch mal mit der Freifunk Factory Firmware rüber. Wenn dann immer noch die 5 GHz Wifi keine MAC Adresse hat, dann hat das Gerät ne Macke.

Dann würde ich in die rc.local was schreiben, was per grep die /etc/wireless prüft und ggf. per sed ggf. die mac-adresse für 5GHz fest setzt.

Ich habe deine Anleitung befolgt, jedoch (wie erwartet) ohne Erfolg.
Mit anderen OpenWRT/gluon Images funktioniert 5GHz radio problemlos, ich würde einen Hardware-Defekt daher ausschließen.

Ich bin ein bisschen ratlos… das einzige halbwegs Interessante, was mir dmesg verrät ist:

[   29.480000] IPv6: ADDRCONF(NETDEV_UP): client1: link is not ready
[   29.530000] device client1 entered promiscuous mode
[   29.540000] br-client: port 2(client1) entered forwarding state
[   29.540000] br-client: port 2(client1) entered forwarding state
[   29.700000] br-client: port 2(client1) entered disabled state
[   29.840000] device client1 left promiscuous mode
[   29.850000] br-client: port 2(client1) entered disabled state
[   30.070000] IPv6: ADDRCONF(NETDEV_UP): client1: link is not ready

Im Gegensatz zu:

[   29.520000] IPv6: ADDRCONF(NETDEV_UP): client0: link is not ready
[   29.570000] device client0 entered promiscuous mode
[   29.580000] br-client: port 3(client0) entered forwarding state
[   29.580000] br-client: port 3(client0) entered forwarding state
[   29.700000] br-client: port 3(client0) entered disabled state
[   30.900000] br-client: port 3(client0) entered forwarding state
[   30.900000] br-client: port 3(client0) entered forwarding state
[   30.910000] IPv6: ADDRCONF(NETDEV_CHANGE): client0: link becomes ready
[   32.900000] br-client: port 3(client0) entered forwarding state

ip a:

15: client0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-client qlen 1000
    link/ether 66:68:b4:fa:a6:a0 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::6468:b4ff:fefa:a6a0/64 scope link 
       valid_lft forever preferred_lft forever
16: client1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq qlen 1000
    link/ether 66:68:b5:fa:a6:a0 brd ff:ff:ff:ff:ff:ff

Sieht ein bisschen nach Treiberproblemen aus…

Spätestens an dieser stelle wären die Quellen, mit denen dieser build entstanden ist, wirklich hilfreich.

Weiß zufällig jemand wie ich an (debug) logs komme?

Siehe meine Links oben zur site.mk und site.conf.
Ändere doch mal manuell die SSID für den 5GHz-AP in /etc/config/wireless
Zum Beispiel auf „Freifunk (5GHz)“ und schaue dann ob das (auf einem entsprechenden Client) nach dem Reboot zu finden und auch nutzbar ist.