Stand der Dinge 2015-05

@phip DNS für GL ist 10.156.3.1
Ich kann hier auch nicht über das 241er GW pingen
Wie sollen nach den nächsten Update die Adressen lauten?

SeaMonkey meldet:

Sichere Verbindung fehlgeschlagen

Ein Fehler ist während einer Verbindung mit firmware.freifunk-wuppertal.net aufgetreten.

Sichere Kommunikation mit der Gegenstelle ist nicht möglich: Keine gemeinsamen Verschlüsselungsalgorithmen.

(Fehlercode: ssl_error_no_cypher_overlap)

Die aufgerufene Seite kann nicht angezeigt werden, da die Echtheit der emfangenen Daten nicht verifiziert werden konnte.Bitte kontaktieren Sie die Website-Betreiber, um sie über dieses Problem zu informieren.

OK, done!

@uwho aus dem ersten Post

geht bei mir übrigens :wink:

Meine lieben, aus privaten Gründen wird es heute sehr eng werden. Ich sehe zu, dass es noch vor der Deadline was wird, ich verspreche aber nichts. Wenn ihr wisst was passiert ist, würdet Ihr es verstehen.

Um mich ein wenig zu entlasten: ich habe rechtzeitig ein Ticket angelegt. Es wurde mir jetzt vor zwei Tagen auch auf die Schnelle geholfen – danke dafür – trotzdem ist es jetzt viel zu spät und viel zu eng, um mit Freude irgend etwas zu Stande zu bringen. Und natürlich kommt dann auch noch Murphy, gerade jetzt – und irgendwie habe ich es gewusst, dass der nochmal, schon wieder recht haben wird … Was ich heute eingerichtet habe, sollte eigentlich laufen. Habt Ihr den 10.X.0.241er richtig als GW für die statische Route eingerichtet? Ich kann einfach nicht verstehen, woran es scheitern mag.

Ich habe in ein paar Stunden wieder Zeit und melde mich. Teste es notfalls auch mit eigenen fastd-Tunneln …

Verbinden sich alle Knoten zum wupper1?

bei mir im Graphen sind alle GL Nodes mit Wupper 1 verbunden

prima, danke. ich nehme an, die anderen Wolken verbinden sich auch zu w1. in TRO will sich „gateway1“ nicht mit dem w1 verbinden und in GL/GM der w7. Den w7 werde ich noch dazu bringen, es kann aber sein, dass die Karte für GL/GM ausfällt … Details.


ein mal eine freie Sekunde finden, tief durchatmen, kurz nachdenken, kurz eigene Probleme auf der Rückenlehne aufhängen, Perspektive wechseln (TRO-FW installieren), noch ein mal kurz nachdenken und alles Schritt für Schritt durchgehen. Nach 19 Minuten Fehler gefunden: die Routing-Regel für die B.A.T.M.A.N.-Advanced-Schnittstellen war nicht gesetzt. Den Befehl habe ich mir ganz unten in meinen Notizen für später (als ganz wichtig markiert) aufgehoben und ganz einfach total vergessen …


Zum Glück hat Tilaa die Server noch nicht abgeschaltet. Vielleicht fahren sie die UTC, vielleicht hat der Verein noch mal einen Monat dazu bestellt, vielleicht sind die so lieb und geben ein paar Tage zum Umzug drauf – ich weiß es nicht. … Glück im Unglück. Ich schalte nun den DHCP auf w1 ein und auf w0 aus. Mal schauen was passiert. WUP und TRO sind von mir getestet, die anderen müssten der Theorie nach funktionieren. Wer noch nicht schläft, bitte testen.

Graph zeigt bei mir an:
Wupper 7 <= VPN => Wupper 0
Wupper 0 <= VPN => Wupper 1 + 7
Wupper 1 <= VPN => Wupper 0

Edit
jetzt 03:20
Wupper 7 <= VPN => Wupper 0 + Wupper 1
Wupper 1 <= VPN => Wupper 0 + Wupper 7
Wupper 0 <= VPN => Wupper 1 + Wupper 7

Danke Klaus für die Informationen … es war ein DNS-Problem


ich habe 5 Stunden nach der Deadline den DHCP in WUP und TRO auf w1 aktiviert und auf w0 deaktiviert. Läuft. Der Theorie nach müsste EU, HEF, GL und GM auch laufen. Ich werde jetzt auf Verdacht auch hier den DHCP verlegen. Ich habe leider keine Zeit das zu testen, da ich hier gerade begrenzte Ressourcen habe und ich den ausgeliehenen Router nicht sinnlos Fläschen möchte. Ich drücke die Daumen, dass alles problemlos klappt. Bitte meldet Probleme.

nach ca.15 Minuten sind weitere 3 Server eingerichtet … die Befehle werde ich in ein paar Wochen dokumentiert veröffentlichen. w4 wird irgendwann zu w0. Ich warte nun auf die Tunneldaten vom FFRL e. V. …

Wenn es keine Probleme in EU, HEF, GL und GM gibt, ist die Arbeit für IPv4 erledigt. Bei übernächster freien Sekunde folgt IPv6.

@phip du hast es geschafft :wink:
Der doppelte 360 ist gelungen.
GL funzt wunderbar.

Gibts dann nochmal ne Liste der neuen Server mit MACs damit ich die Karte schön machen kann?

TOP - Super Arbeit @phip

Hier läuft alles. Server verbinden sich jetzt auch … dort waren noch fehler in den Peers. …

IPv6 wäre der Traum! :wink:


Gibt es irgendwo eine Komplette Liste (MAC Adressen, DNS Namen, Ports, fastd Keys …)

Inet weg - jetzt dürfen wir meckern

@phip

ich bekomm seit gerade keine IPv4 mehr und kann die 241 nicht pingen
nur wenn ich manuell 240 als GW eintrage hab ich inet

@DSchmidtberg
kannst du DHCP auf W0 (240 ist doch W0 ode?) mal wieder starten um erstmal inet wieder hinzubekommen?
@phip ist jetzt wahrscheinlich im Tiefschlaf und das wollen wir ihm auch gönnen

Und schon rettet uns unser Notfall-Schweden-Gateway …

1 Like

Das GW ist nicht das Problem, W0 leitet ja raus wenn man den clients das sagt

Ich versuche jetzt einen DHCP auf gl1 aufzusetzen

Hat jemand davon Ahnung und Zeit für Mumble?

Das kannst du dir sparen … BATMAN nutzt den DHCP nur von Servern die sich als gateway announcen…

Und das macht wupper gerade nicht …

Wie kann ich das auf einem eigenen Server ändern?

Update: Uuuund läuft!

@phip damit kann dhcp auf den Wupper* Servern für GL abgeschaltet werden. Wenn ich auf W1 ändern kann bescheid geben! Ansonsten trage ich gerne ssh-keys ein.

batctl -m BAT_SCHNITTSTELLE gw server 96mbit/99mbit

Weißt du wie man einen DNS mitannouncen kann? panik

Das machst du mit dem DHCP …

Beispiel TRO:

ddns-update-style none;
 option domain-name ".fftdf";
 default-lease-time 600;
 max-lease-time 3600;
 log-facility local7;
 subnet 10.188.0.0 netmask 255.255.0.0 {
 authoritative;
 range 10.188.200.1 10.188.200.254;
 option domain-name-servers 10.188.1.100;
 option routers 10.188.1.55;
 interface bat0;
 }
 include "/etc/dhcp/static.conf";

Hab ich eigentlich so:

default-lease-time 600;
max-lease-time 7200;

authoritative;

log-facility local7;

subnet 10.156.0.0 netmask 255.255.0.0 {
  interface bat0;
  range 10.156.10.0 10.156.20.255;
  option routers 10.156.0.240;
  option domain-name ".ffgl";
  option domain-name-servers 10.156.3.1;
}

kommt aber beim client nicht an mit dem dns