Statische IP-Config möglich bzw. neue Gluon-Version verfügbar?

Hallo zusammen,

in meinem Netzwerk muss ich eine statische IP-Adresse für alle angeschlossenen Geräte konfigurieren, DHCP ist nicht verfügbar. Daher wollte ich eine statische IP für den WAN-Port vergeben.

Die Anleitung habe ich hier gefunden, allerdings komme ich dann nicht ins Internet. Leider kann ich keine genaueren Infos zur Konnektivität liefern, da ich nicht weiß, wie ich das genau debuggen soll. Das Gerät antwortet jedenfalls auf der statisch konfigurierten Adresse auf ping.

Ich habe auch gelesen, dass die statische IP-Config erst von Gluon 2014.3.1 unterstütutzt wird. Bei den Images steht nur 2014.3-stable-1, ich nehme an, das ist dann die Vorgängerversion?

Gibt es eventuell ein FFRL-Image, das bereits 2014.3.1 hat? Gerne auch experimentell.
Ich bin in der Domäne Rheinufer.

Gruß
David

1 Like

@yayachiken
Das sollte auch mit der 2013.3.0 schon funktionieren.

Set a static IPv4 for the WAN-Port

# uci set network.wan.proto=static
# uci set network.wan.ipaddr=XXX.XXX.XXX.XXX
# uci set network.wan.netmask=XXX.XXX.XXX.XXX
# uci set network.wan.gateway=XXX.XXX.XXX.XXX
# uci commit network
# reboot

wobei natürlich die XXXe mi den entsprechenden Werten zu füllen sind.

2 Likes

Wie gesagt, das hab ich gemacht, ging aber eben nicht…

Die Info dass es ein neues Feature von 2014.3.1 ist habe ich von hier

Irgendeine Idee wie ich debuggen könnte, was da hakt?

Notralls(!) editierst Du /etc/config/network von Hand.
Da steht derzeit gegen Ende etwas wie

config interface ‚wan‘
option ifname ‚eth1‘
option proto ‚dhcp‘
option type ‚bridge‘
option peerdns ‚0‘

Daraus machst Du dann z.B.

config interface ‚wan‘
option ifname ‚eth1‘
option proto ‚static‘
option proto ‚ipaddr‘ ‚192.168.178.221‘
option proto ‚netmask‘ ‚255.255.255.0‘
option proto ‚gateway‘ ‚192.168.178.1‘
option proto ‚dns‘ ‚192.168.178.1‘
option type ‚bridge‘
option peerdns ‚0‘

Wie kommst du den auf die Kiste aktuell drauf?
Im Config Mode? Da geht natürlich nichts.

Falls du im Normalbetrieb auf die Kiste kommst schau doch am besten erstmal nach ob alles so ok ist wie es soll. „ip route show“, „ip addr show“, …

G T

Kann es sein, dass die ganzen „proto“ ein Vertipper sind?

In meiner /etc/config/network steht folgendes

config interface ‚wan‘
option ifname ‚eth1‘
option proto ‚static‘
option ipaddr ‚DIE IP-ADRESSE‘
option netmask ‚255.255.252.0‘
option gateway ‚DAS GATEWAY‘
option type ‚bridge‘
option peerdns ‚0‘

Ich habe nochmal versucht die Zeile

option dns ‚8.8.8.8‘

hizuzufügen, dann gab es (nach Reboot) folgende Änderung:

Wenn ich nun versuche google.de zu pingen während ich per ssh auf dem Router bin, dann konnte der Name vorher nicht aufgelöst werden. Nun kommt die Meldung

ping: sendto: Operation not permitted

Ein Ping auf 8.8.8.8 verläuft weiterhin erfolgreich.

Traceroute auf 8.8.8.8 vom Router aus geht ausschließlich durch mein Netzwerk, kommt dann direkt bei einer IP vom DECIX vorbei und geht dann nach Google. Ist das so korrekt, dass vom Router selbst anscheinend kein Tunnel genutzt wird?

Bin per ssh drin (falls es wichtig ist: Rechner ist direkt an einen LAN-Port des Freifunkrouters gestöpselt, WAN ist im Netzwerkswitch eingestöpselt, über den ich ins große weite Internet komme)

Ich weiß jetzt leider nicht so ganz genau wie es aussehen soll wenn es funktioniert, aber auf jeden Fall hat br-lan die korrekte IP-Adresse und Netzmaske und ip route gibt mir auch als Defaultroute den Weg über das Gateway aus.

na dann ping doch mal das Gateway

Ist erreichbar. Hätte ich vielleicht sagen sollen :wink:

Das steht das hoffentlich nicht so in der Datei, oder? (Klingt jetzt mehr nach einem Router eines Friseurs oder Kneipiers…,-)

1 Like

Na dann ist das schon mal nicht das Problem :frowning:

  • FW auf dem Gateway? Du brauchst Port 10000 UDP
  • Router registriert?

Das wäre so erst mal die verdächtigen.

Natürlich nicht, ist aber eine öffentliche IP und nicht jeder muss gleich per Whois rausfinden können, wo ich sitze :slight_smile:

Das kann gut sein, das werde ich erst einmal checken!

Ich hoffe mal, das ist irgendwo in der Doku versteckt, wäre peinlich, das einfach überlesen zu haben.

Router ist registriert, das ist es also hoffentlich nicht :wink: Kann aber natürlich sein dass ich da irgendwas verbockt hab.

Eine öffentliche IPv4 für einen FF-Router? Nobel geht die Welt zugrunde!
Dann schreib doch

option ipaddr ‚\geheim

(Dann wird klar, dass Du’s manuell herausgenommen hast)

Naja irgendwie muss der Router ja mit seiner Außenwelt kommunizieren :smile:
Oder anders ausgedrückt: „Muss man Wissen!“ :smiley:

Oha, laut Netzwerkdoku hier ist TCP/10000 inbound zu, aufgrund einer Advisory von 2005…
Aber UDP sollte auf sein. Falls UDP versehentlich auch gesperrt wurde, dann kann ich da auch leider nichts dran machen…

Auf dem Gateway hab ich noch gefunden dass die TTL auf 1 gesetzt wurde, mit einer Ausnahme für meine IP-Adresse ändert sich aber immer noch nichts, das ist also nicht der einzige Grund.

Ich nehme an, ich werde mich dann mal nächste Woche mit unseren Admins zusammen setzen müssen. Danke für die Hilfe!

Urgh, es lag nicht an der Firewall. Jetzt funktioniert alles. Aber es ist nicht schön.

Mir ist aufgefallen dass die „sendto: operation not permitted“ Fehlermeldung nur bei IPv6-Adressen auftrat ($DEITY sei dank gibt Ping die aufgelöste Adresse nochmal aus!)

Ich habe jetzt alle Vorkommen von „rheinland{0-3}.freifunk-rheinland.net“ in Configdateien durch die IPv4 ersetzt, auf die es auflöst. Anscheinend hat das Ding versucht, sich per IPv6 mit den Supernodes zu verbinden, obwohl nur eine IPv4 statisch konfiguriert war.

Ich habe irgendwie das Gefühl, das wird nur Probleme verursachen, daher werde ich die Kiste wohl wieder abschalten und auf „richtigen“ Support für statische Adressen warten müssen… Was meint ihr?

Nebenbei: Es ist Port 10040 nicht 10000, zumindest laut meiner Configdatei.

also in der config dabei /overlay/etc/fastd steht port 10000

also in der Domain Ruhrgebiet ist das korrekt. Die Supernodes sind aktuell nur per IPv4 erreichbar :frowning:

Die Kiste läuft doch. Warum willst du die jetzt wieder abschalten?
Es gibt hier und da die ein oder andere Ungereimtheit in der Gould Software aber das ist schon ok so. Läuft.

Gruß
Thomas

1 Like

10040 wunderte mich ebenfalls, aber ja doch…

1 Like

Könnte es sein, dass irgendeine Firewall meint, den Traffic anhand des „BehaviourPatterns“ als irgendeine Form von „Storm“ abwehren zu müssen?

In jedem Fall fehlt da noch ein wenig Doku für die Leute, die FF-Nodes vielleicht auch mal in „vernagelten Firmennetzen“ installieren möchten.
Also „welche Ports müssen zwingend in welcher Richtung offen sein“.