Thin Client Siemens Futro S550 im Einsatz als günstiger Offloader

Das ist natürlich möglich, ich gehe aber davon aus, dass das nicht der Fall ist, weil die Karte mit dem Futro mitgeliefert wurde.
Das Image habe ich hiermit draufgezogen alex's coding playground » USB Image Tool
Karte in einen Kartenleser und ab dafür.

Meine Idee wäre jetzt, die CF-Karte im laufenden Betrieb zu installieren und nach nem Neustart davon zu booten. Ich bekomme sie aber nicht gemountet. Wie gesagt, ich glaube, dass es an der Hardware des Boards liegt. Ich bin da aber nicht Fachkundig genug. Deswegen ja der Thread hier :smile:

Grundsätzlich möglich, aber das würde ich nicht machen.

Kopiere das Image besser unter Linux mittels dd auf die cf.

Terminal:
sudo dd if=/PATHzumIMAGE/image.img of=/dev/NAMEderCFkarte

1 Like

Also, wenn du willst, werd ich das so mal versuchen, auch wenn ich nicht glaube, dass das den Unterschied macht.

Allerdings wäre mein Weg praktikabler für Leute, die den Futro nicht aufschrauben möchten. Denn die Karte ist von Außen nicht zugänglich

Ich schreibe das nur weil ich neulich ein ähnliches Problem mit einem USB Stick hatte der erst bootete, nachdem ich das Image mittels dd auf die Karte gebracht habe.

Die CF Karte steckt im Futro.
Ich dachte mir, wenn ich es nicht gebacken kriege, die Karte zu mounten, brauche ich nicht versuchen ein System davon zu starten. Das versuche ich grad.

Um die Karte per dd zu beschreiben ist ein Mounten nicht notwendig. Es reicht wenn die Karte über das Kernelsubsystem als Blockdevice eingebunden wird (/dev/sdX).
Ggf. kommst du hier über ein Live System per USB gebootet weiter?

1 Like

Unter /dev taucht nur sda sda1 und sda2 auf.
Also das System scheint die Karte nicht zu erkennen.

Heißt das im System ist noch eine Festplatte verbaut? Oder ist sda vielleicht die CF Karte?

sda ist der Usbstick sda1 und sda2 die Partitionen darauf, wenn ich das richtig verstanden habe.

hier mal ein auszug

Probier mal

lsblk -f

Und

fdisk -l

Kennt er beides nicht

 blkid -o list

Oder mal googlen busybox list partitions

kennt er auch nicht.
Ich such mir schon die Finger wund. Dadurch, dass unter dev nur zwei Partitionen auftauchen,
gehe ich davon aus, dass er die CF-Karte garnicht erst sieht. Ich werde morgen mal eine andere CF-karte ausprobieren, und natürlich das Image per dd aufzuspielen.

Interessant wäre tatsächlich mal das System von einem USB Stick mit einer vollumfänglichen Distribution deiner Wahl zu booten. Ich vermute hier auch, dass einfach Treiber fehlen. Gluon ist sehr, sehr minimal gehalten. Da ist quasi kaum ein Treiber drin, der nicht manuell vorausgewählt wurde.

Treiber fehlen definitiv. Er sieht das Gerät gar nicht. Kann man im Betrieb rein und rausstecken… dmesg schweigt. Ich habe leider noch nicht herausgefunden welchen treiber wir brauchen

Lässt sich den der Treiber sobald er gefunden wurde updatesicher einbauen oder dies vielleicht direkt im gluon x86 master hinterlegen?

Ja, sogar mit kaum mehr als 20 Zeichen Code.

Kann es daran liegen, das im Gluon keine IDE-Treiber verbaut sind, weil die nie gebraucht wurden? die CF-Karte hängt mit ziemlicher großer Wahrscheinlichkeit an einem integrierten Adapter. Das Board hat sogar eine unbestückten IDE-Steckplatz.

1 Like

Wenn das Ding vom USB nicht bootet, dann kann es daran liegen, dass das BIOS (dort) kein Medium mit Partitionstabelle erwartet.
Oder umgekehrt, es ist ein Medium ohne Partitionstabelle („large floppy“) drin, aber es hätte gern eine Partitionstabelle.

Wenn das Ding vom USB nicht bootet, dann kann es daran liegen, dass das BIOS (dort) kein Medium mit Partitionstabelle erwartet.
Oder umgekehrt, es ist ein Medium ohne Partitionstabelle („large floppy“) drin, aber es hätte gern eine Partitionstabelle.

Vom USB-Stick bootet er wunderbar. Nur von der CF-Karte vom onboard CF-Steckplatz nicht.