TL WR710n v2 Firmware?

Hallo ich habe heute den v2 bekommen und scheinbar gibt es den v1 so ohne weiteres nicht mehr. Wird es in naher Zukunft ein Firmware geben dafür? Sonst muss ich mich nach etwas anderem umsehen.

Der V2 ist insofern total unsexy, als das er nur 4MB-Flash hat, während der V1.2 8MB-Flash hat.

Aber TP-Link hat ein Einsehen, dass das Kappes ist, und die V2.1 hat wieder 8MB-Flash (und ist Hardwaremässig eigentlich eine Wiederauflage der V1.2).

Vercheck’ den V2er bei Ebay, und besorg’ dir eine V2.1 von dem Teil. Oder einen V1.2 ausm Altbestand…

Naja ich bring den in den laden zurück dann. Aber wo gibt es den 1.2 oder auch wann den 2.1?

Saturn hat den in der Produktpalette. Du kannst dir auf www.saturn.de mit dem Suchbegriff „TP-Link“ das Ding raussuchen, und dann checken, ob er in „deiner“ Filiale vorrätig ist. Wenn ja, hingehen und gucken.

Das dolle ist, dass du bei den TP-Links im Allgemeinen schon auf der Schachtel sehen kannst, was drin ist, beim 710er ist das Etikett mit der Versionsnummer auf der Unterseite des Einschubs.

Meinen V1.2 habe ich auch so gekauft.

@StefanT: Der TL-WR710N wird durch den Commit 8ccb173 im Master derzeit unterstützt.

Wenn du uns deine Community verrätst, kann diese dir bestimmt schon ein Image bauen, sofern sie überhaupt mit Gluon arbeitet.

4MB-Flash sind kein Problem, alle 841er haben nur so viel. RAM ist viel entscheidender.

Grüße
Matthias

@MPW ich bin bei FF-STuttgart , da gibt es aber derzeit nur den v1 , den Teil der Profile.mk hatte ich selbst auch schon geändert aber build schlägt fehl. vermutlich muss ich noch etwas anpassen.

Du musst wie gesagt Gluon-Master nehmen.

Gefühlt geht es so:

(Abhängigkeiten für ein Gluon-Build installieren: Getting Started — Gluon 2021.1 documentation)

git clone https://github.com/freifunk-gluon/gluon.git
cd gluon
git checkout master

Falls du gluon schon hast Mal aufräumen:

make dirclean

Dann eure Konfiguration nach gluon/site/ kopieren, sodass sie in gluon/site liegt:

git clone https://github.com/freifunk-stuttgart/site-ffs.git site

Dann kompilieren:

cd .. (wieder zurück ins Gluon-Verzeichnis)
make update GLUON_RELEASE=master GLUON_TARGET=ar71xx-generic
make GLUON_RELEASE=master GLUON_TARGET=ar71xx-generic V=s -jX

(-jX Anzahl der Kerne deines Rechners.)

Meld dich, wenn du Schwierigkeiten hast. Am Build soll es nicht scheitern!

Grüße
Matthias

@MPW also fertig ist es soweit nun. ICh meine das ich irgendwo etwas gelesen hatte das man die firmware noch signieren muss.
Kannst du mir da auch noch weiter helfen? die bin ist jetzt 3,8MB

Das ist für die reine Funktion nicht nötig.

Eine signierte FW wird nur für den Autoupdater benötigt.

na dann werd ich mal flashen auch wenn ich noch keine stock firmware gefunden habe für den weg zurück :wink:
edit:
also dies ist erst mein zweiter knoten und meine erste „eigene“ firmware , aber mir wäre als wenn Freifunk unter wlan angezeigt wurde auch wenn der knoten noch nicht aktviert wurde.
aber gestartet soweit ist der immerhin das ich im gloun alles einstellen und neu starten konnte :slight_smile:

1 Like

Das ist doch super!

Bitte denke daran, den Autoupdater bei Master immer auszuschalten, sonst zerhaut er dir das ganze System.

Grüße
Matthias

Mich würde es wundern, wenn der Router mit der site.conf in Verbindung mit dem aktuellen gluon-Master eine sinnvolle /etc/config/wireless hätte.
Schlicht weil sich die Syntax für die Interfaces geändert hat.
Ach ja, „simple_tc“ heisst jetzt „bandwith_limit“ und ist direkt in den fastd-Bereich gezogen.

das ist vermutlich der grund warum kein Freifunk angezeigt wird.
Wie gesagt starten tut der Router , Ich kann alle Einstellungen machen (per Lan) aber es gibt kein Wlan.
Unter Einstellungen zeigt er mit zwar die verschiedenen Modi an *dbm/*mW aber selbst die zu ändern bringt nichts.

@adorfer es wäre aber schön wenn du mir sagt was man wo und wie ändern musst, anstatt zu sagen es geht nicht. das etwas nicht funktioniert weis ich auch, aber wo steht wie es richtig zu machen ist?
Bitte bedenke nicht jeder kennt die Software oder den Code auswendig oder ist bis ins letzte vertraut mit den Änderungen die jemand macht . Ich bin beim FFS jetzt seit ca 8 Wochen und arbeite mich langsam in die Technik ein. Ich versuche auf ein Firmware zu bauen , was ich vorher noch nie gemacht habe. Ich bin nicht ganz unwissend , aber alles wissen oder hellsehen kann ich nicht, Mit Antworten wie von @MPW kann ich was anfangen , immerhin wurde damit das FW gebaut im Gegensatz zu den make Beschreibungen aus der gloun doku

Teste mal diese site.conf:

Angepasst nach:
https://gluon.readthedocs.org/en/latest/user/site.html

Wenn das nicht klappt bitte Kontakt mit euren FW Bäckern aufnehmen.

@anon68922371
Danke werde ich testen

   }
  },
 
  bandwidth_limit = {
    -- The bandwidth limit can be enabled by default here.
    enabled = false,
 
    -- Default upload limit (kbit/s).
    egress = 400,
 
    -- Default download limit (kbit/s).
    ingress = 6000,
  },

sieht dort aber noch etwas anders aus oder lese ich da zuviele ),

muss das nicht dann so

                                                        },
                }
          }
      },

  bandwidth_limit = {
    -- The bandwidth limit can be enabled by default here.
    enabled = false,

    -- Default upload limit (kbit/s).
    egress = 400,

    -- Default download limit (kbit/s).
    ingress = 6000,
  },
}

Wird bei euch noch der VPN-Schlüssel angezeigt oder benötigt? Dann musst du auch noch etwas ändern.

Ich habe bei uns in der Firmware einen eigenen Branch, der diese Änderungen bereits drin hat. Den kannst du zwar nicht übernehmen, aber dir angucken, was sich alles seit v2015.1.2 geändert hat: https://github.com/FreiFunkMuenster/site-ffms/tree/gluon-master

Grüße
Matthias

/home/stefan/clones/gluon/build/ar71xx-generic/openwrt/staging_dir/host/bin/lua: …e/gluon-core/files/usr/lib/lua/gluon/site_config.lua:9: [string „site.conf“]:22: ‚}‘ expected (to close ‚{‘ at line 1) near ‚=‘
stack traceback:
[C]: in function ‚assert‘
…e/gluon-core/files/usr/lib/lua/gluon/site_config.lua:9: in main chunk
[C]: ?
Your site configuration did not pass validation

das kommt mit der geänderten site.conf

Hast du bandwith_limit an der richtigen Ebene drin? Die Position hat sich nämlich geändert.

Bitte zeige uns deine site.conf, sonst ist das hier nur Rumgerate.

btw was hat es mit dem /etc/config/wireless auf sich was adorfer meinte? muss man noch etwas ändern?
https://github.com/freifunk-stuttgart/site-ffs/blob/beta/site.conf
habe diese geändert gehabt mit dem bandwith_limit