TL WR710n v2 Firmware?

Die Position von bandwith_limit ist falsch. Schau dir mal das Orginal Beispiel an: gluon/site.conf at master · freifunk-gluon/gluon · GitHub

[quote=„Tarnatos, post:14, topic:8751“]
Angepasst nach:
https://gluon.readthedocs.org/en/latest/user/site.html[/quote]

!! 20ZEICHENBRAUCHTMAN

ok also ich habe nun hier eine „neue“ site.conf und das bandwith_limit am ende von fastd . das Image wird erstellt , läst sich auch flashen aber genau wie bei den zwei versuchen zuvor , wird kein wlan aktiv bzw nicht angezeigt.
für den lerneffekt muss ich wohl das teil auf machen und per rx/tx schauen was nach dem u-boot passiert oder gibt es eine andere möglichkeit?

Du könntest auch die /etc/config/wireless von hand (vi) editieren.

@adorfer
wie sollte die dann aussehen?

config wifi-device ‚radio0‘
option type ‚mac80211‘
option hwmode ‚11g‘
option path ‚platform/ar933x_wmac‘
option htmode ‚HT20‘
option channel ‚1‘
option country ‚DE‘
option txpower ‚15‘

so sieht die derzeit aus

iw list

iw list
Wiphy phy0
	max # scan SSIDs: 4
	max scan IEs length: 2257 bytes
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Device supports AP-side u-APSD.
	Device supports T-DLS.
	Available Antennas: TX 0x1 RX 0x1
	Configured Antennas: TX 0x1 RX 0x1
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * WDS
		 * monitor
		 * mesh point
		 * P2P-client
		 * P2P-GO
	Band 1:
		Capabilities: 0x116e
			HT20/HT40
			SM Power Save disabled
			RX HT20 SGI
			RX HT40 SGI
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 8 usec (0x06)
		HT TX/RX MCS rate indexes supported: 0-7
		Frequencies:
			* 2412 MHz [1] (15.0 dBm)
			* 2417 MHz [2] (18.0 dBm)
			* 2422 MHz [3] (18.0 dBm)
			* 2427 MHz [4] (18.0 dBm)
			* 2432 MHz [5] (18.0 dBm)
			* 2437 MHz [6] (18.0 dBm)
			* 2442 MHz [7] (18.0 dBm)
			* 2447 MHz [8] (18.0 dBm)
			* 2452 MHz [9] (18.0 dBm)
			* 2457 MHz [10] (18.0 dBm)
			* 2462 MHz [11] (15.0 dBm)
			* 2467 MHz [12] (18.0 dBm)
			* 2472 MHz [13] (18.0 dBm)
			* 2484 MHz [14] (disabled)
	valid interface combinations:
		 * #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
		   total <= 2048, #channels <= 1, STA/AP BI must match
		 * #{ WDS } <= 2048,
		   total <= 2048, #channels <= 1, STA/AP BI must match
		 * #{ IBSS, AP, mesh point } <= 1,
		   total <= 1, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }

	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing


 iw wlan0 info
Interface wlan0
	ifindex 5
	wdev 0x1
	addr 14:cc:20:96:72:88
	type managed
	wiphy 0

Ich kann das Forum derzeit nur vom Hand aus erreichen, da ich sonst nur UnityMedia habe und da verstopft das Routing zum Forum leider bei „Freifunk Hamburg“.

@adorfer ich kann auch nicht per unitymedia aufs forum , nur per o2 oder freifunk

Will sagen: ich würde dir gern das passende Codeschnipsel pasten, bekomme das aber nicht ohne extreme Verrenkungen ins Handy in den Browser.

Wenn ich mich jetzt nicht doll vertippt habe:
/etc/config/wireless (komplett)

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ar933x_wmac'
    option htmode 'HT20'
    option channel '1'
    option country 'DE'
    option txpower '15'

config wifi-iface 'client_radio0'
        option ifname 'client0'
        option network 'client'
        option disabled '0'
        option device 'radio0'
        option mode 'ap'
        option macaddr '14:cc:20:96:72:88'
        option ssid 'Freifunk'

config wifi-iface 'mesh_radio0'
        option ifname 'mesh0'
        option network 'mesh_radio0'
        option device 'radio0'
        option bssid '02:04:08:16:32:64'
        option disabled '0'
        option mcast_rate '12000'
        option mode 'adhoc'
        option macaddr '14:cc:20:96:72:88'
        option ssid '02:04:08:16:32:64'

nach copy&paste fehlern geht das soweit
aber: der verteilt/bezieht keine ipv4 adressen
und wie bekomme ich das ins firmware rein ohne es dann dauernd händisch zu machen?

ok edit 2: nach 10 minuten warten wurde er scheinbar erst richtig aktiv :slight_smile:

Also ich fasse mal zusammen

git clone https://github.com/freifunk-gluon/gluon.git
cd gluon
git checkout master
make dirclean

Diese site.conf
http://pastebin.com/LTL4AaKH
make update GLUON_RELEASE=master GLUON_TARGET=ar71xx-generic
make GLUON_RELEASE=master GLUON_TARGET=ar71xx-generic V=s -j1

dann weiter per ssh

 iw wlan0 info
Interface wlan0
	ifindex 5
	wdev 0x1
	addr 14:cc:20:96:72:88
	type managed
	wiphy 0

und zum Schluss weil copy&paste schneller geht

rm /etc/config/wireless
vi /etc/config/wireless
config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ar933x_wmac'
    option htmode 'HT20'
    option channel '1'
    option country 'DE'
    option txpower '15'

config wifi-iface 'client_radio0'
        option ifname 'client0'
        option network 'client'
        option disabled '0'
        option device 'radio0'
        option mode 'ap'
        option macaddr '14:cc:20:96:72:88'
        option ssid 'Freifunk'

config wifi-iface 'mesh_radio0'
        option ifname 'mesh0'
        option network 'mesh_radio0'
        option device 'radio0'
        option bssid '02:04:08:16:32:64'
        option disabled '0'
        option mcast_rate '12000'
        option mode 'adhoc'
        option macaddr '14:cc:20:96:72:88'
        option ssid '02:04:08:16:32:64'

dann fehlt jetzt nur noch wie der das automatisch richtig in die wireless rein bringt.
danke soweit schon mal @anon68922371 @MPW @adorfer

Okay, also das Image baut jetzt aber trotz korrekter site.conf sind manuelle Anpassungen nötig? Das klingt nach einem Bug in Gluon, oder?

Wenn ja, dann bitte ein Issue erstellen, neoraider guckt sich das dann bestimmt an: Issues · freifunk-gluon/gluon · GitHub

@MPW genau so schaut es aus.
Ich warte erstmal auf @adorfer , der scheint das Problem ja schon zu kennen.
Das positive dabei ist aber , das der v2 jetzt rennt.
Wenn das Problem weiter besteht , dann mach ich einen issue auf.

Gut gut, es ist für die Entwickler immer wichtig, dass sie Rückmeldungen bekommen. Die machen das auch nur als Hobby und haben nicht die finanziellen Ressourcen und nicht die Zeit alle Geräte zu testen.

Hab auch nicht die finanziellen mittel um mehr zu testen aber wenn das mit dem klappt werde ich mich an sunxi machen mit dem lamobo r1

@neoraider kannst du ein Blick dazu tun;)?

Die WLAN-Config in der geposteten site.conf ist noch auf Stand von v2015.1.x, im Master muss das ganz anders aussehen… das Beispiel wurde ja schon verlinkt.

@NeoRaider

wäre diese Variante dann richtig?
mir ist nicht ganz klar was bei mesh die id sein soll oder müsste dazu erst was an den gateways passieren?

Ich verstehe den Hintergrund hinter „automatisch“ nicht.
Das machst Du einmal und es überlebt auch einen Boot.
Den Autoupdater solltest Du natürlich abschalten, denn sonst es gleich wieder hinüber wenn eine Version kommt, die nicht angepasst ist. Damit würde ich dann wirklcih auf eine Stable-Release Deiner Community warten.

@adorfer naja ich habe unter Umstand vor von dem teil noch ein paar zu besorgen, aber wenig Lust das jedes mal erst anzupassen :wink:
Ich möchte dann einfach flashen und gut ist.
Die auto updates sind aus und bleiben es auch bis sich bei uns was bewegt.

Dann fehlt einfach jemand, der das mal richtig baut.

Wobei der größte Aufwand dabei ist die Anpassung der Site.Conf, die aber sowieso früher oder später geleistet werden muss zum nächsten Gluon-Release.
Das sollte Eure lokalen FW-Backenden eigentlich überzeugen.