TP-Link WR741ND ConfigMode einschalten

Hallo liebe Gemeinde,

ich habe aus dem Lager eines Bekannten 4Stück vom WR741ND mit alter Firmware gefunden.

Hier bekomme ich aber auf keine Art in den ConfigMode. Ich habe aber derweil heraus bekommen, wie ich in den FailsafeMode komme.
Daten der aktuell noch aufgespielten Firmware sind

ATTITUDE ADJUSTMENT (bleeding edge, r32690) -----------------------------------

  • Linux 3.3.8
  • B.A.T.M.A.N.-adv

  • FFRheinland config 2013-05-26_git-21a3fc3

Kann mir jemand sagen wie ich entweder
a) in den ConfigMode komme? (QSS-Knopf und auch den Reset-Knopf habe ich bis zu 90 Sek. gedrückt gehalten - ohne Reaktion in irgend einer Art)
oder
b) ob und wenn ja, wie ich die neue Firmware per FailsafeMode flashen kann?

Vielen Dank im Voraus für die Zeit.

Gruß
Christian

Genau das würde ich tun. Du bist per Serieller Konsole drauf?

Versuche im ersten Schuss doch mal nach dem
mount_root
ein
firstboot
und dann
reboot -f

Wenn das nicht hilft: Netzwerk manuell hochbringen, falls es noch nicht geht. (ohne Gewähr!)

echo config interface ‚wan‘ >/etc/config/network
echo option peerdns ‚0‘ >>/etc/config/network
echo option ifname ‚eth1‘>>/etc/config/network
echo option auto ‚1‘>>/etc/config/network
echo option type ‚bridge‘>>/etc/config/network
echo option proto ‚dhcp‘>>/etc/config/network
echo nameserver 127.0.0.1>/etc/resolv.conf
echo nameserver 8.8.8.8>>/etc/resolv.conf
/etc/init.d/network reload
Und dann das passende sysupgrade image per wget nach /tmp:
cd /tmp
wget http://images.freifunk-rheinland.net/images/gluon/rheinufer/stable/sysupgrade/gluon-rheinufer-2014.3-stable-1-tp-link-tl-wr740n-nd-v4-sysupgrade.bin (Du suchst Dir natürlich das passende aus http://images.freifunk-rheinland.net/images/gluon/rheinufer/stable/sysupgrade/ )
Dann „sysupgrade -n“ mit der heruntergelandenen datei ausführen und hoffen, dass er dann in den Configmode fällt.
sysupgrade -n gluon-rheinufer-2014.3-stable-1-tp-link-tl-wr740n-nd-v4-sysupgrade.bin

Super danke!
Upgrade läuft schon! :smiley: :smiley: :smiley:
Echt super mit Euch zu arbeiten! :wink:

1 Like

Die alte Firmware hatte keinen Config-Mode. Da war noch CLI angesagt, weil für luci kein Platz mehr war.

Du musst tatsächlich wie @adorfer sagt in den Failsafe mode, dann da rein telnet-en, eine Internetverbindung herstellen (sollte problemlos gehen, wenn am WAN-Port ein Router mit DHCP steckt, damals gab es die VPN-Funktionalität noch nicht out-of-the-box), und mit wget ein neues Image nach /tmp ziehen. Dann ganz normal weiter flashen mit sysupgrade -n.

edit: Schön, dass es schon geklappt hat :slight_smile:

edit2:Es gibt allerdings ein eigenes Image für den WR741N (@adorfer hat den WR740N verlinkt) → http://images.freifunk-rheinland.net/images/gluon/rheinufer/stable/sysupgrade/gluon-rheinufer-2014.3-stable-1-tp-link-tl-wr741n-nd-v4-sysupgrade.bin (Das ist v4, gibt noch v1 und v2)

Macht das einen großen Unterschied?

Das war Absicht, damit es „auf den ersten Blick“ falsch ist, da ich nicht weiss, ob v1/v2/v4 benötigt wird für den 741 und wir nicht hinterher mit einem wirklich gebrickten dastehen, beim 740er wird’s ja hoffentlich „wenn falsch“ sofort abgelehnt beim Versuch eines Sysupgrades ohne „force“.

2 Likes

Alles ist okay! Ich habe das schon verstanden und die passende Version aufgesetzt. Wer lesen kann ist klar im Vorteil! :wink:

Servus @TheKick kannst Du mir verraten wie man in den FailsafeMode kommt? Habe hier nämlich auch noch einen WR741ND mit alter Firmware.

ich hatte schon VOR dem Einschalten den Reset-Knopf gedrückt gehalten und erst nach 20 oder 30 Sekunden los gelassen, dann war der Failsafe-Mode an.

4 Beiträge wurden in ein neues Thema verschoben: Fail-safe Mode für TP-Link WDR4300