Viele APs offline oder ffmap defekt? (Rheinufer)

Hallo zusammen,

beim Blick auf die ffmap sehe ich für mein dafürhalten ziemlich viele graue anstatt grüne Kreise und laut Liste sind nur 77 von 206 Router online.


Haben wir ein Problem oder ist die Karte defekt?

Gruß
Jan

Das kann ich gerade leider nicht mehr nachvollziehen. Aber am Wochenende hatte ich Probleme, weil ein Server von unserem Provider neu gestartet wurde und er nicht mit aktueller Konfiguration wieder hochgekommen ist.

Aktueller Stand in der Domäne Rheinufer: 138 Nodes von 213 online.

Hm, und jetzt sind es 83 von 266. Keine berauschende Quote.

Jetzt sind es 140. Da gibt es anscheinend bei der Zählung durch Alfred starke Schwankungen.

Wenn ich unseren Graphen anschaue, der nicht per Alfred, sondern per Zeilenzählung in der Shell entsteht, dann gibt es noch mehr wesentlich mehr online Nodes. Das sind die gesamte Zeit über zwischen 230 und 240.

Ich hätte mich auch gewundert, wenn es anders wäre.
Spannende Grafik, öffentlich zugänglich und konfigurierbar ist das nicht, oder?

Der Graph kommt von unserem Graphite-Server im Freifunk-Netz. Auf der Website für Freifunk Düsseldorf habe ich einen Button eingebaut, der den Graphen wie im Screenshot anzeigt.

Diesen und andere Graphen lassen sich von dem Server generieren, wie in der Graphite URL API beschrieben. Das ist jedoch komplex und erfordert einige Zeit, sich da einzuarbeiten.

Was genau wird denn da für die Zählung zugrunde gelegt?

Linus meinte das Ergebnis der ffmap mit um die 140 Router entspricht schon der Realität, da dort nur die Router gezählt werden die noch online und vorhanden sind.

Bei uns im Ruhrgebiet kann ich die ffmap Zahlen definitiv auch als richtig bestätigen.

Ich mache einfach ein „batctl o“ und zähle die Zeilen. Abzüglich zwei Zeilen für den Header der Ausgabe komme ich dann auf die Zahl der Batman-Nodes.

Was dann im Falle des Ruhrgebiets:

# batctl o | wc -l
361

359 Nodes wären…

Sind aber unter Garantie nur 210 Router, genau wie auch in der ffmap Ruhrgebiet angegeben!

Hi,

ich kann hier in Aachen seit einigen Tagen feststellen, dass ab und an viele Nodes als offline angezeigt werden - die aber nicht offline sind.

Nach ca. 30 Minuten beruhigt sich das dann wieder, dafür werden kurze Zeit später andere Nodes als offline angezeigt.

Gibt es da irgendwelche bekannten Probleme?

Gruß

Flam

Ich kann’s meine Nodes bestätigen: Die verschwinden munter und kommen wieder, fast im 10-Minuten-Takt.
Erstaunlicherweise zeigt der graph dann auch Nodes und ganze Inseln ohne einen einzigen VPN-Uplink.

Und die Knotenzahl liegt dann deutlich unter 120, um kurz darauf wieder fast doppelt so hoch zu sein.
Die „verschwundenen“ Nodes sind aber im Netz sowohl intern wie extern anpingbar und die Status-Seite lässt sich auch abrufen. Wie auch immer die Zählung funktioniert, aber 114 im Graphen und 356 Lines im batctl o passen nicht zueinander.

Sprich: Irgendwas wackelt da ganz extrem seit letztem Wochenende.

Ich halte mal fest, dass sich bis jetzt nichts geändert hat. Ich empfinde diese Situation als äußerst unbefriedigend, nicht nur weil ich bei bedenklicher Stabilität ungerne neue Freifunker ansprechen möchte, sondern auch weil die Außenwirkung fatal ist: Freifunk funktioniert nicht!

Gibt es bei den Insidern eine Idee woran das liegen könnte? Braucht ihr Hilfe? Vielleicht können wir was organisieren. Evtl. könnte man dann auch die Statistikfunktion beleben.

Es ist schon etwas frustrierend.
Auf der einen Seite überlegen wir, ob wir besser APs mit 2xMIMO herausstellen für besseren Durchsatz oder stabilere Verbindungen.
Und auf der anderen Seite ist das Netz dann immer wieder für Zeiträume nicht wirklich nutzbar.

Wäre es nicht möglich, dass die Nodes „bei Nichtverfügbarkeit von Internet-Connectivity“ und/oder „Nichtverfügbarkeit von DHCP“ die SSID für den Freifunk-AP abzuschalten?
Dann würden die Leute gleich sehen „Freifunk jetzt nicht da“ und würden nicht immer wieder versucht sein, sich nach 30-60s Timeout vor die Tür gesetzt zu fühlen.
Das ist nämlich sehr frustrierend.

1 Like

Bin da auch LEIDENDER und habe noch ein Problem: GESICHTSVERLUST! RUFSCHÄDIGUNG!
Ich werde nicht mal annähernd die Leistung der Programmierer würdigen können, weil das ein Buch mit 7 Siegeln für mich ist. Ich ahne nur, dass es ein Engagement ist, das viel Lebensqualität raubt.
Von daher steht mir nicht zu, hier auf Defizite hinzuweisen.
Andererseits tingel ich hier vor Ort durch die „Lokale,“ schwöre die Leute auf etwas ein, was scheinbar gut gemeint, aber nicht jeden Tag gut daher kommt.
Diese rabenschwarzen Tage fallen aber auf mnich persönlich (mein Gesicht ist ja bekannt) zurück - und nicht auf irgendjemand UNBEKANNTEN, der da was an irgendwelchen Servern frickelt und das System ausbremst.

Mein Eindruck verstärkt sich, dass hier irgendwas im Bereich Bananensoftware (reift beim und auf Kosten des Freifunk-Verbreiters) abläuft.
Das brauche ich eigentlich nicht. Verlorenes Vertrauen wieder herzustellen ist viel schwieriger, als die Leute für einen ersten Versuch zu ermuntern…

1 Like
  • eigentlich offtopic (Ruhrgebiet und nix Map) , aber mal ein Motivationsmoment -

Wenn Ich die für unseren Erfolg wichtigsten Nötigen Arbeitsgruppen bennen sollte, so wären dies:

  • Qualität&Verfügbarkeit in der Technik
  • gute rechtliche solide Werbematerialien fürs Klinkenputzen

Nun ist das aber ein Verein, wo jeder seinen - sehr diversen - Interessen nachgeht.

Ich möchte aber auch mal dafür werben, dass unser „Servicelel“ gar nicht so schlecht ist. Das möchte Ich mit paar Zahlen von Kempener Nodes illustrieren.

Paar Kommentare:

  • gemessen wird die Erreichbarkeit aus dem Internet. das ist bis auf DHCP schon ziemlich End2End. Also auch, alle Wackler der Internetverbindungen, Zwangstrennung, Aufsteller nimmt mal die Steckdose fürs Staubsaugen
  • schwarzer Router grad absichtlich aus
  • roter (in dem Moment offline) braucht bekanntermassen mal ne anderen Antenne um sich sein Internet aus dem Mesh zu holen
  • …Schmed… Hängt an ner 1,3KM Funkstrecke mit preiswert/Stamdardkomponenten
  • …Heilig… Hatte nen „Katzendefekt“ am Kabel und war für die Zeit im Monitoring, daher statistisch von vorher 99,x „etwas abgerutscht“

Ich find das alles mal so schlecht nicht.
Werte am Rheinufer sahen in ner Testphase nicht wirklich anders aus.

1 Like

mir ist auch aufgefallen, dass Nodes von der Kiefern mal angezeigt werden mal nicht. Ab und zu werden sie in der Liste all offline angezeigt, owohl sie definitiv online sind. Im Graph werden sie auch mal angezeigt mal nicht. Ist verwirrend, aber solange es funktioniert sehe ich es eher als visuelle verunsicherung. Schön wäre es natürlich, wenn die Anzeigen stabiler wären, gerade für Freifunker_innen, die nicht den technischen Background haben. Die Frage ist haben nur wir in der Domäne Rheinufer das Problem? Wie sieht die Anzeige bei den andren Domänen aus? Wie lösen die andren Domänen die Anzeige der Nodes. Vielleicht gibt es hier Ansätze :wink:

1 Like

Dieser Zustand hält jetzt seit etwa anderthalb Wochen an.
Die Zahl der Nodes in der Map schwankt etwa zwischen 110 und 220 (mit vielerlei Zwischenschritten), obwohl vermutlich die ganze Zeit 220 da sind.
Das hat irgendwie was von „Petrus kämpft an der Himmelspforte mit Klingelstreichen (Klinngelmännchen?) weil im Krankenhaus ständig reanimiert wird“.
Ich weiss nicht was es ist, aber wenn sich der Fehler nicht finden lässt, warum die nodes-json ständig in der Vollständigkeit schwankt, könnte man das mit einem softwaremäßigen Filter nicht „beruhigen“, also die Nodes über einen längeren Zeitraum filtern vor der Weiterverarbeitung (Ablage der Liste auf dem webserver). „Node erst nach 15 Minuten löschen“ würde vermutlich völlig reichen.

1 Like

Ich lasse meine Nodes auch anpingen. Unerreichbar sind die nie.
Die Ziele waren auch immer anpingbar in den Momenten, als die Webseiten nicht geliefert wurden.

Ein echter End2End-Test wäre, eine Webseite oder Datei mittels eines WLAN-Clients herunter zu laden.
Daran wird in Troisdorf gearbeitet (mithilfe eines Raspberry Pi) Dann wird allerdings immer nur ein Node getestet. Für viele Nodes bräuchte man viele WLAN-Clients, die testen…

Achja, der Client müsste bei jedem Test das WLAN neu verbinden, um sicher zu gehen, dass DHCP funktioniert.^^

1 Like

Wäre ja n klassicher Ansatz aus dem Servicemanagement.

Nu sollte man aber die Anzahl der probe-clients und deren Aktivität limitieren, damit wir nicht anschliessen 50% Kappa für mesh-traffic und Monitoring investieren. :wink:

An so einer Lösung wäre Ich für uns sofort auch interessiert.

Am Raspy solls nicht scheitern.

Aus meiner Sicht haben wir mehrere Probleme.

  1. Die Karte zeigt manchmal nur wenige Nodes an. Vermutlich kommen die Alfred-Daten nicht immer durch zum Server.
  2. Routen in Richtung USA sind teilweise sehr langsam. Ich habe noch nicht verstanden warum und spreche noch mit dem Team des Rheinland Backbone.
  3. Ich war überlastet mit Aufgaben (Umzug des Forums und des Monitorings). Ab sofort werde ich mich wieder auf die Administration der Supernodes im Rheinufer konzentrieren.
3 Likes